summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-28 05:48:05 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-28 05:48:05 +0000
commit2a3e666b91860513814ef865daa11a5c709b299e (patch)
tree2647dce226ff0cd7d239374a5f62dd352f1c8b4c /sys-cluster/torque
parentStable x86; I'm done for the night (diff)
downloadgentoo-2-2a3e666b91860513814ef865daa11a5c709b299e.tar.gz
gentoo-2-2a3e666b91860513814ef865daa11a5c709b299e.tar.bz2
gentoo-2-2a3e666b91860513814ef865daa11a5c709b299e.zip
(#149327) Don't treat .keep files from keepdir() as queue files. Also, pass scp rather than crypt as the actual configure argument.
(Portage version: 2.1.2_pre1-r3)
Diffstat (limited to 'sys-cluster/torque')
-rw-r--r--sys-cluster/torque/ChangeLog10
-rw-r--r--sys-cluster/torque/files/2.1.2-skip-dotnames.patch15
-rw-r--r--sys-cluster/torque/files/digest-torque-2.1.2-r23
-rw-r--r--sys-cluster/torque/torque-2.1.2-r1.ebuild4
-rw-r--r--sys-cluster/torque/torque-2.1.2-r2.ebuild148
5 files changed, 177 insertions, 3 deletions
diff --git a/sys-cluster/torque/ChangeLog b/sys-cluster/torque/ChangeLog
index c804380e9e79..f1042ae37343 100644
--- a/sys-cluster/torque/ChangeLog
+++ b/sys-cluster/torque/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/torque
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.35 2006/09/28 03:13:23 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.36 2006/09/28 05:48:05 dberkholz Exp $
+
+*torque-2.1.2-r2 (28 Sep 2006)
+
+ 28 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/2.1.2-skip-dotnames.patch, torque-2.1.2-r1.ebuild,
+ +torque-2.1.2-r2.ebuild:
+ (#149327) Don't treat .keep files from keepdir() as queue files. Also, pass
+ scp rather than crypt as the actual configure argument.
28 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
torque-1.2.0_p5-r1.ebuild, torque-1.2.0_p5-r2.ebuild,
diff --git a/sys-cluster/torque/files/2.1.2-skip-dotnames.patch b/sys-cluster/torque/files/2.1.2-skip-dotnames.patch
new file mode 100644
index 000000000000..f1d391582643
--- /dev/null
+++ b/sys-cluster/torque/files/2.1.2-skip-dotnames.patch
@@ -0,0 +1,15 @@
+--- src/server/pbsd_init.c (revision 1016)
++++ src/server/pbsd_init.c (working copy)
+@@ -1415,6 +1415,11 @@
+ {
+ struct stat sb;
+
++ if (*filename == '.')
++ {
++ return(-1);
++ }
++
+ if (stat(filename,&sb) == -1)
+ {
+ return(errno);
+
diff --git a/sys-cluster/torque/files/digest-torque-2.1.2-r2 b/sys-cluster/torque/files/digest-torque-2.1.2-r2
new file mode 100644
index 000000000000..5bb1ccd8379b
--- /dev/null
+++ b/sys-cluster/torque/files/digest-torque-2.1.2-r2
@@ -0,0 +1,3 @@
+MD5 f1b37efb5d4770a0105c66294a05d140 torque-2.1.2.tar.gz 2686724
+RMD160 7ba5cf4b4655d6e77c705be30c539380ca5863c1 torque-2.1.2.tar.gz 2686724
+SHA256 c7bade897fc12f27f128e4081c8ed1f3137bf42684ca239c48b18eb01314710a torque-2.1.2.tar.gz 2686724
diff --git a/sys-cluster/torque/torque-2.1.2-r1.ebuild b/sys-cluster/torque/torque-2.1.2-r1.ebuild
index 579fe2984a16..1c1ccf7717b2 100644
--- a/sys-cluster/torque/torque-2.1.2-r1.ebuild
+++ b/sys-cluster/torque/torque-2.1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-2.1.2-r1.ebuild,v 1.4 2006/09/28 03:13:23 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-2.1.2-r1.ebuild,v 1.5 2006/09/28 05:48:05 dberkholz Exp $
inherit autotools flag-o-matic eutils
@@ -59,7 +59,7 @@ src_compile() {
fi
if use crypt; then
- myconf="${myconf} --with-rcp=crypt"
+ myconf="${myconf} --with-rcp=scp"
else
myconf="${myconf} --with-rcp=mom_rcp"
fi
diff --git a/sys-cluster/torque/torque-2.1.2-r2.ebuild b/sys-cluster/torque/torque-2.1.2-r2.ebuild
new file mode 100644
index 000000000000..b20f1d2419da
--- /dev/null
+++ b/sys-cluster/torque/torque-2.1.2-r2.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-2.1.2-r2.ebuild,v 1.1 2006/09/28 05:48:05 dberkholz Exp $
+
+
+inherit autotools flag-o-matic eutils
+
+MY_P="${P/_}"
+DESCRIPTION="Resource manager and queuing system based on OpenPBS"
+HOMEPAGE="http://www.clusterresources.com/products/torque/"
+SRC_URI="http://www.clusterresources.com/downloads/${PN}/${MY_P}.tar.gz"
+
+LICENSE="openpbs"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="tk crypt server"
+PROVIDE="virtual/pbs"
+
+# ed is used by makedepend-sh
+DEPEND_COMMON="virtual/libc
+ sys-libs/ncurses
+ sys-libs/readline
+ tk? ( dev-lang/tk )
+ !virtual/pbs"
+
+DEPEND="${DEPEND_COMMON}
+ sys-apps/ed"
+
+RDEPEND="${DEPEND_COMMON}
+ crypt? ( net-misc/openssh )
+ !crypt? ( net-misc/netkit-rsh )"
+
+PDEPEND=">=sys-cluster/openpbs-common-1.1.1"
+
+S="${WORKDIR}/${MY_P}"
+
+SPOOL_LOCATION="/var/spool" # this needs to move to /var later on
+PBS_SERVER_HOME="${SPOOL_LOCATION}/PBS/"
+
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch ${FILESDIR}/${PN}-setuid-safety.patch
+ epatch ${FILESDIR}/${PV}-skip-dotnames.patch
+}
+
+
+
+src_compile() {
+
+ local myconf
+ if use server; then
+ myconf="--enable-server --with-default-server=$(hostname)"
+ elif [[ -n ${PBS_SERVER_NAME} ]]; then
+ myconf="--disable-server --with-default-server=${PBS_SERVER_NAME}"
+ else
+ myconf="--disable-server --with-default-server=$(hostname)"
+ fi
+
+ if use crypt; then
+ myconf="${myconf} --with-rcp=scp"
+ else
+ myconf="${myconf} --with-rcp=mom_rcp"
+ fi
+
+ econf \
+ $(use_enable tk gui) \
+ --libdir="\${exec_prefix}/$(get_libdir)/pbs/lib" \
+ --with-server-home=${PBS_SERVER_HOME} \
+ --with-environ=/etc/pbs_environment \
+ ${myconf} \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+# WARNING
+# OpenPBS is extremely stubborn about directory permissions. Sometimes it will
+# just fall over with the error message, but in some spots it will just ignore
+# you and fail strangely. Likewise it also barfs on our .keep files!
+pbs_createspool() {
+ local root="$1"
+ local s="${SPOOL_LOCATION}"
+ local h="${PBS_SERVER_HOME}"
+ local sp="${h}/server_priv"
+ einfo "Building spool directory under ${D}${h}"
+ local a d m
+ for a in \
+ 0755:${s} 0755:${h} 0755:${h}/aux 0700:${h}/checkpoint \
+ 0755:${h}/mom_logs 0751:${h}/mom_priv 0751:${h}/mom_priv/jobs \
+ 0755:${h}/sched_logs 0750:${h}/sched_priv \
+ 0755:${h}/server_logs \
+ 0750:${h}/server_priv 0755:${h}/server_priv/accounting \
+ 0750:${h}/server_priv/acl_groups 0750:${h}/server_priv/acl_hosts \
+ 0750:${h}/server_priv/acl_svr 0750:${h}/server_priv/acl_users \
+ 0750:${h}/server_priv/jobs 0750:${h}/server_priv/queues \
+ 1777:${h}/spool 1777:${h}/undelivered ;
+ do
+ d="${a/*:}"
+ m="${a/:*}"
+ if [[ ! -d "${root}${d}" ]]; then
+ install -d -m${m} "${root}${d}"
+ else
+ chmod ${m} "${root}${d}"
+ fi
+ # (#149226) If we're running in src_*, then keepdir
+ if [[ ${root} = ${D} ]]; then
+ keepdir ${d}
+ fi
+ done
+}
+
+src_install() {
+ # Make directories first
+ pbs_createspool "${D}"
+
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGELOG DEVELOPMENT README.* Release_Notes doc/admin_guide.ps
+
+ # this file MUST exist for PBS/Torque to work
+ # but try to preserve any customatizations that the user has made
+ dodir /etc
+ if [[ -f "${ROOT}etc/pbs_environment" ]]; then
+ cp "${ROOT}etc/pbs_environment" "${D}"/etc/pbs_environment
+ else
+ touch "${D}"/etc/pbs_environment
+ fi
+
+ if [ -f "${ROOT}var/spool/PBS/server_name" ]; then
+ cp "${ROOT}var/spool/PBS/server_name" "${D}/var/spool/PBS/server_name"
+ fi
+
+ # The build script isn't alternative install location friendly,
+ # So we have to fix some hard-coded paths in tclIndex for xpbs* to work
+ for file in `find "${D}" -iname tclIndex`; do
+ sed -e "s/${D//\// }/ /" "${file}" > "${file}.new"
+ mv "${file}.new" "${file}"
+ done
+}
+
+pkg_postinst() {
+ # make sure the directories exist
+ pbs_createspool "${ROOT}"
+ [ ! -f "${ROOT}etc/pbs_environment" ] && \
+ touch "${ROOT}etc/pbs_environment"
+}