summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-01-13 03:24:49 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-01-13 03:24:49 +0000
commit515e238867fb71fe7e5697118baf78109221fcfa (patch)
tree050c99973b4967def464cb56e41d7e3e0b62b2b7 /sys-cluster/swift
parentBump, drop minor arches due to enum34 keywords missing, drop pypy because key... (diff)
downloadgentoo-2-515e238867fb71fe7e5697118baf78109221fcfa.tar.gz
gentoo-2-515e238867fb71fe7e5697118baf78109221fcfa.tar.bz2
gentoo-2-515e238867fb71fe7e5697118baf78109221fcfa.zip
removing old, vulnerable versions
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'sys-cluster/swift')
-rw-r--r--sys-cluster/swift/ChangeLog11
-rw-r--r--sys-cluster/swift/files/CVE-2013-2161.patch13
-rw-r--r--sys-cluster/swift/files/CVE-2014-0006-havana.diff51
-rw-r--r--sys-cluster/swift/files/CVE-2014-0006-master.diff28
-rw-r--r--sys-cluster/swift/files/CVE-2014-3497-1.13.patch88
-rw-r--r--sys-cluster/swift/swift-1.13.1-r1.ebuild112
-rw-r--r--sys-cluster/swift/swift-2.0.0.ebuild115
-rw-r--r--sys-cluster/swift/swift-2.1.0.ebuild116
-rw-r--r--sys-cluster/swift/swift-2014.1.9999.ebuild113
9 files changed, 9 insertions, 638 deletions
diff --git a/sys-cluster/swift/ChangeLog b/sys-cluster/swift/ChangeLog
index 6337414f65f8..d447df8e1dc2 100644
--- a/sys-cluster/swift/ChangeLog
+++ b/sys-cluster/swift/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/swift
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/ChangeLog,v 1.35 2014/11/18 19:27:57 prometheanfire Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/ChangeLog,v 1.36 2015/01/13 03:24:49 prometheanfire Exp $
+
+ 13 Jan 2015; Matthew Thode <prometheanfire@gentoo.org>
+ -files/CVE-2013-2161.patch, -files/CVE-2014-0006-havana.diff,
+ -files/CVE-2014-0006-master.diff, -files/CVE-2014-3497-1.13.patch,
+ -swift-1.13.1-r1.ebuild, -swift-2.0.0.ebuild, -swift-2.1.0.ebuild,
+ -swift-2014.1.9999.ebuild:
+ removing old, vulnerable versions
*swift-2.2.0 (18 Nov 2014)
diff --git a/sys-cluster/swift/files/CVE-2013-2161.patch b/sys-cluster/swift/files/CVE-2013-2161.patch
deleted file mode 100644
index 19ff3b48e741..000000000000
--- a/sys-cluster/swift/files/CVE-2013-2161.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/swift/account/server.py b/swift/account/server.py
-index 4c08fc1..8acd5f5 100644
---- a/swift/account/server.py
-+++ b/swift/account/server.py
-@@ -253,7 +253,7 @@ class AccountController(object):
- account_list = json.dumps(data)
- elif out_content_type.endswith('/xml'):
- output_list = ['<?xml version="1.0" encoding="UTF-8"?>',
-- '<account name="%s">' % account]
-+ '<account name="%s">' % saxutils.escape(account)]
- for (name, object_count, bytes_used, is_subdir) in account_list:
- name = saxutils.escape(name)
- if is_subdir:
diff --git a/sys-cluster/swift/files/CVE-2014-0006-havana.diff b/sys-cluster/swift/files/CVE-2014-0006-havana.diff
deleted file mode 100644
index e0c0634f6e1c..000000000000
--- a/sys-cluster/swift/files/CVE-2014-0006-havana.diff
+++ /dev/null
@@ -1,51 +0,0 @@
-commit 6c378b4b65524ea3b485c47d829ed0aebbdb86c0
-Author: Samuel Merritt <sam@swiftstack.com>
-Date: Fri Jan 3 09:26:11 2014 -0800
-
- Backported tempurl const time compare for 1.10.0
-
- Change-Id: I6db8f9a568dab8403ed74a83ba0c9548f06425e1
-
-diff --git a/swift/common/middleware/tempurl.py b/swift/common/middleware/tempurl.py
-index ffc1431..ae2f4a1 100644
---- a/swift/common/middleware/tempurl.py
-+++ b/swift/common/middleware/tempurl.py
-@@ -98,7 +98,7 @@ from urlparse import parse_qs
-
- from swift.proxy.controllers.base import get_account_info
- from swift.common.swob import HeaderKeyDict
--from swift.common.utils import split_path
-+from swift.common.utils import split_path, streq_const_time
-
-
- #: Default headers to remove from incoming requests. Simply a whitespace
-@@ -267,17 +267,20 @@ class TempURL(object):
- if not keys:
- return self._invalid(env, start_response)
- if env['REQUEST_METHOD'] == 'HEAD':
-- hmac_vals = self._get_hmacs(env, temp_url_expires, keys,
-- request_method='GET')
-- if temp_url_sig not in hmac_vals:
-- hmac_vals = self._get_hmacs(env, temp_url_expires, keys,
-- request_method='PUT')
-- if temp_url_sig not in hmac_vals:
-- return self._invalid(env, start_response)
-+ hmac_vals = (self._get_hmacs(env, temp_url_expires, keys,
-+ request_method='GET') +
-+ self._get_hmacs(env, temp_url_expires, keys,
-+ request_method='PUT'))
- else:
- hmac_vals = self._get_hmacs(env, temp_url_expires, keys)
-- if temp_url_sig not in hmac_vals:
-- return self._invalid(env, start_response)
-+
-+ # While it's true that any() will short-circuit, this doesn't affect
-+ # the timing-attack resistance since the only way this will
-+ # short-circuit is when a valid signature is passed in.
-+ is_valid_hmac = any(streq_const_time(temp_url_sig, h)
-+ for h in hmac_vals)
-+ if not is_valid_hmac:
-+ return self._invalid(env, start_response)
- self._clean_incoming_headers(env)
- env['swift.authorize'] = lambda req: None
- env['swift.authorize_override'] = True
diff --git a/sys-cluster/swift/files/CVE-2014-0006-master.diff b/sys-cluster/swift/files/CVE-2014-0006-master.diff
deleted file mode 100644
index bf545908434b..000000000000
--- a/sys-cluster/swift/files/CVE-2014-0006-master.diff
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/swift/common/middleware/tempurl.py b/swift/common/middleware/tempurl.py
-index c9b9d94..5748694 100644
---- a/swift/common/middleware/tempurl.py
-+++ b/swift/common/middleware/tempurl.py
-@@ -106,7 +106,7 @@ from urlparse import parse_qs
- from swift.proxy.controllers.base import get_account_info
- from swift.common.swob import HeaderKeyDict, HTTPUnauthorized
- from swift.common.utils import split_path, get_valid_utf8_str, \
-- register_swift_info, get_hmac
-+ register_swift_info, get_hmac, streq_const_time
-
-
- #: Default headers to remove from incoming requests. Simply a whitespace
-@@ -284,7 +284,13 @@ class TempURL(object):
- request_method='PUT'))
- else:
- hmac_vals = self._get_hmacs(env, temp_url_expires, keys)
-- if temp_url_sig not in hmac_vals:
-+
-+ # While it's true that any() will short-circuit, this doesn't affect
-+ # the timing-attack resistance since the only way this will
-+ # short-circuit is when a valid signature is passed in.
-+ is_valid_hmac = any(streq_const_time(temp_url_sig, hmac)
-+ for hmac in hmac_vals)
-+ if not is_valid_hmac:
- return self._invalid(env, start_response)
- self._clean_incoming_headers(env)
- env['swift.authorize'] = lambda req: None
diff --git a/sys-cluster/swift/files/CVE-2014-3497-1.13.patch b/sys-cluster/swift/files/CVE-2014-3497-1.13.patch
deleted file mode 100644
index 9164933849b5..000000000000
--- a/sys-cluster/swift/files/CVE-2014-3497-1.13.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-https://review.openstack.org/gitweb?p=openstack%2Fswift.git;a=commitdiff;h=b223322ed1ef44f61490f820240aa01f1047ae2e
-author John Dickinson <me@not.mn>
- Sat, 7 Jun 2014 02:46:41 +0800 (11:46 -0700)
-committer John Dickinson <me@not.mn>
- Thu, 19 Jun 2014 06:28:33 +0800 (15:28 -0700)
-HTTP header values should be quoted. Since the WWW-Authenticate
-header value contains user-supplied strings, it's important to
-ensure it's properly quoted to ensure the integrity of the protocol.
-
-Previous to this patch, the URL was unquoted and then the unquoted
-value was returned in the header. This patch re-quotes the value
-when it is set on the response.
-
-This is filed as CVS-2014-3497
-
-Fixes bug 1327414
-
-Change-Id: If8bd8842f2ce821756e9b4461a18a8ac8d42fb8c
-diff --git a/swift/common/swob.py b/swift/common/swob.py
-index 638086e..f4f38c7 100644 (file)
---- a/swift/common/swob.py
-+++ b/swift/common/swob.py
-@@ -1203,7 +1203,7 @@ class Response(object):
- realm = 'unknown'
- except (AttributeError, ValueError):
- realm = 'unknown'
-- return 'Swift realm="%s"' % realm
-+ return 'Swift realm="%s"' % urllib2.quote(realm)
-
- @property
- def is_success(self):
-diff --git a/test/functional/tests.py b/test/functional/tests.py
-index ad8c398..7983815 100644 (file)
---- a/test/functional/tests.py
-+++ b/test/functional/tests.py
-@@ -333,6 +333,19 @@ class TestAccount(Base):
- self.assertEqual(sorted(containers, cmp=locale.strcoll),
- containers)
-
-+ def testQuotedWWWAuthenticateHeader(self):
-+ conn = Connection(config)
-+ conn.authenticate()
-+ inserted_html = '<b>Hello World'
-+ hax = 'AUTH_haxx"\nContent-Length: %d\n\n%s' % (len(inserted_html),
-+ inserted_html)
-+ quoted_hax = urllib.quote(hax)
-+ conn.connection.request('GET', '/v1/' + quoted_hax, None, {})
-+ resp = conn.connection.getresponse()
-+ resp_headers = resp.getheaders()
-+ expected = ('www-authenticate', 'Swift realm="%s"' % quoted_hax)
-+ self.assert_(expected in resp_headers)
-+
-
- class TestAccountUTF8(Base2, TestAccount):
- set_up = False
-diff --git a/test/unit/common/test_swob.py b/test/unit/common/test_swob.py
-index 7cc5439..b0452b9 100644 (file)
---- a/test/unit/common/test_swob.py
-+++ b/test/unit/common/test_swob.py
-@@ -601,6 +601,28 @@ class TestRequest(unittest.TestCase):
- self.assertEquals('Me realm="whatever"',
- resp.headers['Www-Authenticate'])
-
-+ def test_401_www_authenticate_is_quoted(self):
-+
-+ def test_app(environ, start_response):
-+ start_response('401 Unauthorized', [])
-+ return ['hi']
-+
-+ hacker = 'account-name\n\n<b>foo<br>' # url injection test
-+ quoted_hacker = quote(hacker)
-+ req = swift.common.swob.Request.blank('/v1/' + hacker)
-+ resp = req.get_response(test_app)
-+ self.assertEquals(resp.status_int, 401)
-+ self.assert_('Www-Authenticate' in resp.headers)
-+ self.assertEquals('Swift realm="%s"' % quoted_hacker,
-+ resp.headers['Www-Authenticate'])
-+
-+ req = swift.common.swob.Request.blank('/v1/' + quoted_hacker)
-+ resp = req.get_response(test_app)
-+ self.assertEquals(resp.status_int, 401)
-+ self.assert_('Www-Authenticate' in resp.headers)
-+ self.assertEquals('Swift realm="%s"' % quoted_hacker,
-+ resp.headers['Www-Authenticate'])
-+
- def test_not_401(self):
-
- # Other status codes should not have WWW-Authenticate in response
diff --git a/sys-cluster/swift/swift-1.13.1-r1.ebuild b/sys-cluster/swift/swift-1.13.1-r1.ebuild
deleted file mode 100644
index 359d5c792530..000000000000
--- a/sys-cluster/swift/swift-1.13.1-r1.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-1.13.1-r1.ebuild,v 1.1 2014/06/24 09:49:27 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils linux-info user
-
-DESCRIPTION="A highly available, distributed, eventually consistent object/blob store"
-HOMEPAGE="https://launchpad.net/swift"
-SRC_URI="http://launchpad.net/${PN}/icehouse/${PV}/+download/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="proxy account container object test +memcache"
-REQUIRED_USE="|| ( proxy account container object )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.6.0[${PYTHON_USEDEP}]
- <dev-python/pbr-1.0[${PYTHON_USEDEP}]
- test? ( >=dev-python/hacking-0.8.0[${PYTHON_USEDEP}]
- <dev-python/hacking-0.9[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nosexcover[${PYTHON_USEDEP}]
- dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
- dev-python/nosehtmloutput[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
- >=dev-python/mock-0.8.0[${PYTHON_USEDEP}]
- dev-python/python-swiftclient[${PYTHON_USEDEP}] )"
-
-RDEPEND=">=dev-python/dnspython-1.9.4[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.9.15[${PYTHON_USEDEP}]
- >=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
- >=dev-python/netifaces-0.5[${PYTHON_USEDEP}]
- >=dev-python/pastedeploy-1.3.3[${PYTHON_USEDEP}]
- >=dev-python/simplejson-2.0.9[${PYTHON_USEDEP}]
- dev-python/pyxattr[${PYTHON_USEDEP}]
- memcache? ( net-misc/memcached )
- net-misc/rsync[xattr]"
-
-CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
-~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
-~ZFS"
-
-PATCHES=( "${FILESDIR}/"CVE-2014-3497-1.13.patch )
-
-pkg_setup() {
- enewuser swift
- enewgroup swift
-}
-
-src_prepare() {
- sed -i 's/xattr/pyxattr/g' "${S}/swift.egg-info/requires.txt"
- sed -i 's/xattr/pyxattr/g' "${S}/requirements.txt"
- distutils-r1_python_prepare_all
-}
-
-src_test () {
- # https://bugs.launchpad.net/swift/+bug/1249727
- find . \( -name test_wsgi.py -o -name test_locale.py -o -name test_utils.py \) -delete || die
- SKIP_PIP_INSTALL=1 PBR_VERSION=0.6.0 sh .unittests || die
-}
-
-python_install() {
- distutils-r1_python_install
- keepdir /etc/swift
- insinto /etc/swift
-
- newins "etc/swift.conf-sample" "swift.conf"
-# newins "etc/swift-bench.conf-sample" "swift-bench.conf-sample"
- newins "etc/rsyncd.conf-sample" "rsyncd.conf"
- newins "etc/mime.types-sample" "mime.types-sample"
- newins "etc/memcache.conf-sample" "memcache.conf-sample"
- newins "etc/drive-audit.conf-sample" "drive-audit.conf-sample"
- newins "etc/dispersion.conf-sample" "dispersion.conf-sample"
-
- if use proxy; then
- newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
- newins "etc/proxy-server.conf-sample" "proxy-server.conf"
- if use memcache; then
- sed -i '/depend/a\
- need memcached' "${D}/etc/init.d/swift-proxy"
- fi
- fi
- if use account; then
- newinitd "${FILESDIR}/swift-account.initd" "swift-account"
- newins "etc/account-server.conf-sample" "account-server.conf"
- fi
- if use container; then
- newinitd "${FILESDIR}/swift-container.initd" "swift-container"
- newins "etc/container-server.conf-sample" "container-server.conf"
- fi
- if use object; then
- newinitd "${FILESDIR}/swift-object.initd" "swift-object"
- newins "etc/object-server.conf-sample" "object-server.conf"
- newins "etc/object-expirer.conf-sample" "object-expirer.conf"
- fi
-
- fowners swift:swift "/etc/swift" || die "fowners failed"
-}
-
-pkg_postinst() {
- elog "Openstack swift will default to using insecure http unless a"
- elog "certificate is created in /etc/swift/cert.crt and the associated key"
- elog "in /etc/swift/cert.key. These can be created with the following:"
- elog " * cd /etc/swift"
- elog " * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
-}
diff --git a/sys-cluster/swift/swift-2.0.0.ebuild b/sys-cluster/swift/swift-2.0.0.ebuild
deleted file mode 100644
index 3e222578f7e8..000000000000
--- a/sys-cluster/swift/swift-2.0.0.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-2.0.0.ebuild,v 1.1 2014/07/08 23:30:31 prometheanfire Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils linux-info user
-
-DESCRIPTION="A highly available, distributed, eventually consistent object/blob store"
-HOMEPAGE="https://launchpad.net/swift"
-SRC_URI="http://launchpad.net/${PN}/juno/${PV}/+download/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="proxy account container object test +memcache"
-REQUIRED_USE="|| ( proxy account container object )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.6.0[${PYTHON_USEDEP}]
- <dev-python/pbr-1.0[${PYTHON_USEDEP}]
- test? ( >=dev-python/hacking-0.8.0[${PYTHON_USEDEP}]
- <dev-python/hacking-0.9[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nosexcover[${PYTHON_USEDEP}]
- dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
- dev-python/nosehtmloutput[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0[${PYTHON_USEDEP}]
- dev-python/python-swiftclient[${PYTHON_USEDEP}] )"
-
-RDEPEND=">=dev-python/dnspython-1.9.4[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.9.15[${PYTHON_USEDEP}]
- >=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
- >=dev-python/netifaces-0.5[${PYTHON_USEDEP}]
- !~dev-python/netifaces-0.10.0[${PYTHON_USEDEP}]
- !~dev-python/netifaces-0.10.1[${PYTHON_USEDEP}]
- >=dev-python/pastedeploy-1.3.3[${PYTHON_USEDEP}]
- >=dev-python/simplejson-2.0.9[${PYTHON_USEDEP}]
- dev-python/pyxattr[${PYTHON_USEDEP}]
- memcache? ( net-misc/memcached )
- net-misc/rsync[xattr]"
-
-CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
-~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
-~ZFS"
-
-PATCHES=(
-)
-
-pkg_setup() {
- enewuser swift
- enewgroup swift
-}
-
-src_prepare() {
- sed -i 's/xattr/pyxattr/g' "${S}/swift.egg-info/requires.txt"
- sed -i 's/xattr/pyxattr/g' "${S}/requirements.txt"
- distutils-r1_python_prepare_all
-}
-
-src_test () {
- # https://bugs.launchpad.net/swift/+bug/1249727
- find . \( -name test_wsgi.py -o -name test_locale.py -o -name test_utils.py \) -delete || die
- SKIP_PIP_INSTALL=1 PBR_VERSION=0.6.0 sh .unittests || die
-}
-
-python_install() {
- distutils-r1_python_install
- keepdir /etc/swift
- insinto /etc/swift
-
- newins "etc/swift.conf-sample" "swift.conf"
-# newins "etc/swift-bench.conf-sample" "swift-bench.conf-sample"
- newins "etc/rsyncd.conf-sample" "rsyncd.conf"
- newins "etc/mime.types-sample" "mime.types-sample"
- newins "etc/memcache.conf-sample" "memcache.conf-sample"
- newins "etc/drive-audit.conf-sample" "drive-audit.conf-sample"
- newins "etc/dispersion.conf-sample" "dispersion.conf-sample"
-
- if use proxy; then
- newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
- newins "etc/proxy-server.conf-sample" "proxy-server.conf"
- if use memcache; then
- sed -i '/depend/a\
- need memcached' "${D}/etc/init.d/swift-proxy"
- fi
- fi
- if use account; then
- newinitd "${FILESDIR}/swift-account.initd" "swift-account"
- newins "etc/account-server.conf-sample" "account-server.conf"
- fi
- if use container; then
- newinitd "${FILESDIR}/swift-container.initd" "swift-container"
- newins "etc/container-server.conf-sample" "container-server.conf"
- fi
- if use object; then
- newinitd "${FILESDIR}/swift-object.initd" "swift-object"
- newins "etc/object-server.conf-sample" "object-server.conf"
- newins "etc/object-expirer.conf-sample" "object-expirer.conf"
- fi
-
- fowners swift:swift "/etc/swift" || die "fowners failed"
-}
-
-pkg_postinst() {
- elog "Openstack swift will default to using insecure http unless a"
- elog "certificate is created in /etc/swift/cert.crt and the associated key"
- elog "in /etc/swift/cert.key. These can be created with the following:"
- elog " * cd /etc/swift"
- elog " * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
-}
diff --git a/sys-cluster/swift/swift-2.1.0.ebuild b/sys-cluster/swift/swift-2.1.0.ebuild
deleted file mode 100644
index 4018359045a2..000000000000
--- a/sys-cluster/swift/swift-2.1.0.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-2.1.0.ebuild,v 1.1 2014/10/11 22:15:17 prometheanfire Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils linux-info user
-
-DESCRIPTION="A highly available, distributed, eventually consistent object/blob store"
-HOMEPAGE="https://launchpad.net/swift"
-SRC_URI="http://launchpad.net/${PN}/juno/${PV}/+download/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="proxy account container object test +memcache"
-REQUIRED_USE="|| ( proxy account container object )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.6.0[${PYTHON_USEDEP}]
- <dev-python/pbr-1.0[${PYTHON_USEDEP}]
- test? ( >=dev-python/hacking-0.8.0[${PYTHON_USEDEP}]
- <dev-python/hacking-0.9[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nosexcover[${PYTHON_USEDEP}]
- dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
- dev-python/nosehtmloutput[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
- dev-python/oslo-sphinx[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0[${PYTHON_USEDEP}]
- dev-python/python-swiftclient[${PYTHON_USEDEP}] )"
-
-RDEPEND=">=dev-python/dnspython-1.9.4[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.9.15[${PYTHON_USEDEP}]
- >=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
- >=dev-python/netifaces-0.5[${PYTHON_USEDEP}]
- !~dev-python/netifaces-0.10.0[${PYTHON_USEDEP}]
- !~dev-python/netifaces-0.10.1[${PYTHON_USEDEP}]
- >=dev-python/pastedeploy-1.3.3[${PYTHON_USEDEP}]
- >=dev-python/simplejson-2.0.9[${PYTHON_USEDEP}]
- dev-python/pyxattr[${PYTHON_USEDEP}]
- memcache? ( net-misc/memcached )
- net-misc/rsync[xattr]"
-
-CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
-~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
-~ZFS"
-
-PATCHES=(
-)
-
-pkg_setup() {
- enewuser swift
- enewgroup swift
-}
-
-src_prepare() {
- sed -i 's/xattr/pyxattr/g' "${S}/swift.egg-info/requires.txt"
- sed -i 's/xattr/pyxattr/g' "${S}/requirements.txt"
- distutils-r1_python_prepare_all
-}
-
-src_test () {
- # https://bugs.launchpad.net/swift/+bug/1249727
- find . \( -name test_wsgi.py -o -name test_locale.py -o -name test_utils.py \) -delete || die
- SKIP_PIP_INSTALL=1 PBR_VERSION=0.6.0 sh .unittests || die
-}
-
-python_install() {
- distutils-r1_python_install
- keepdir /etc/swift
- insinto /etc/swift
-
- newins "etc/swift.conf-sample" "swift.conf"
-# newins "etc/swift-bench.conf-sample" "swift-bench.conf-sample"
- newins "etc/rsyncd.conf-sample" "rsyncd.conf"
- newins "etc/mime.types-sample" "mime.types-sample"
- newins "etc/memcache.conf-sample" "memcache.conf-sample"
- newins "etc/drive-audit.conf-sample" "drive-audit.conf-sample"
- newins "etc/dispersion.conf-sample" "dispersion.conf-sample"
-
- if use proxy; then
- newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
- newins "etc/proxy-server.conf-sample" "proxy-server.conf"
- if use memcache; then
- sed -i '/depend/a\
- need memcached' "${D}/etc/init.d/swift-proxy"
- fi
- fi
- if use account; then
- newinitd "${FILESDIR}/swift-account.initd" "swift-account"
- newins "etc/account-server.conf-sample" "account-server.conf"
- fi
- if use container; then
- newinitd "${FILESDIR}/swift-container.initd" "swift-container"
- newins "etc/container-server.conf-sample" "container-server.conf"
- fi
- if use object; then
- newinitd "${FILESDIR}/swift-object.initd" "swift-object"
- newins "etc/object-server.conf-sample" "object-server.conf"
- newins "etc/object-expirer.conf-sample" "object-expirer.conf"
- fi
-
- fowners swift:swift "/etc/swift" || die "fowners failed"
-}
-
-pkg_postinst() {
- elog "Openstack swift will default to using insecure http unless a"
- elog "certificate is created in /etc/swift/cert.crt and the associated key"
- elog "in /etc/swift/cert.key. These can be created with the following:"
- elog " * cd /etc/swift"
- elog " * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
-}
diff --git a/sys-cluster/swift/swift-2014.1.9999.ebuild b/sys-cluster/swift/swift-2014.1.9999.ebuild
deleted file mode 100644
index d43b3ee08a35..000000000000
--- a/sys-cluster/swift/swift-2014.1.9999.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-2014.1.9999.ebuild,v 1.1 2014/04/28 01:22:27 prometheanfire Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils git-2 linux-info user
-
-DESCRIPTION="A highly available, distributed, eventually consistent object/blob store"
-HOMEPAGE="https://launchpad.net/swift"
-EGIT_REPO_URI="https://github.com/openstack/swift.git"
-EGIT_BRANCH="stable/icehouse"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS=""
-IUSE="proxy account container object test +memcache"
-REQUIRED_USE="|| ( proxy account container object )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.6.0[${PYTHON_USEDEP}]
- <dev-python/pbr-1.0[${PYTHON_USEDEP}]
- test? ( >=dev-python/hacking-0.8.0[${PYTHON_USEDEP}]
- <dev-python/hacking-0.9[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nosexcover[${PYTHON_USEDEP}]
- dev-python/openstack-nose-plugin[${PYTHON_USEDEP}]
- dev-python/nosehtmloutput[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
- >=dev-python/mock-0.8.0[${PYTHON_USEDEP}]
- dev-python/python-swiftclient[${PYTHON_USEDEP}] )"
-
-RDEPEND=">=dev-python/dnspython-1.9.4[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.9.15[${PYTHON_USEDEP}]
- >=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
- >=dev-python/netifaces-0.5[${PYTHON_USEDEP}]
- >=dev-python/pastedeploy-1.3.3[${PYTHON_USEDEP}]
- >=dev-python/simplejson-2.0.9[${PYTHON_USEDEP}]
- dev-python/pyxattr[${PYTHON_USEDEP}]
- memcache? ( net-misc/memcached )
- net-misc/rsync[xattr]"
-
-CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
-~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
-~ZFS"
-
-#PATCHES=( "${FILESDIR}/CVE-2014-0006-master.diff" )
-
-pkg_setup() {
- enewuser swift
- enewgroup swift
-}
-
-src_prepare() {
- sed -i 's/xattr/pyxattr/g' "${S}/swift.egg-info/requires.txt"
- sed -i 's/xattr/pyxattr/g' "${S}/requirements.txt"
- distutils-r1_python_prepare_all
-}
-
-src_test () {
- # https://bugs.launchpad.net/swift/+bug/1249727
- find . \( -name test_wsgi.py -o -name test_locale.py -o -name test_utils.py \) -delete || die
- SKIP_PIP_INSTALL=1 PBR_VERSION=0.6.0 sh .unittests || die
-}
-
-python_install() {
- distutils-r1_python_install
- keepdir /etc/swift
- insinto /etc/swift
-
- newins "etc/swift.conf-sample" "swift.conf"
-# newins "etc/swift-bench.conf-sample" "swift-bench.conf-sample"
- newins "etc/rsyncd.conf-sample" "rsyncd.conf"
- newins "etc/mime.types-sample" "mime.types-sample"
- newins "etc/memcache.conf-sample" "memcache.conf-sample"
- newins "etc/drive-audit.conf-sample" "drive-audit.conf-sample"
- newins "etc/dispersion.conf-sample" "dispersion.conf-sample"
-
- if use proxy; then
- newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
- newins "etc/proxy-server.conf-sample" "proxy-server.conf"
- if use memcache; then
- sed -i '/depend/a\
- need memcached' "${D}/etc/init.d/swift-proxy"
- fi
- fi
- if use account; then
- newinitd "${FILESDIR}/swift-account.initd" "swift-account"
- newins "etc/account-server.conf-sample" "account-server.conf"
- fi
- if use container; then
- newinitd "${FILESDIR}/swift-container.initd" "swift-container"
- newins "etc/container-server.conf-sample" "container-server.conf"
- fi
- if use object; then
- newinitd "${FILESDIR}/swift-object.initd" "swift-object"
- newins "etc/object-server.conf-sample" "object-server.conf"
- newins "etc/object-expirer.conf-sample" "object-expirer.conf"
- fi
-
- fowners swift:swift "/etc/swift" || die "fowners failed"
-}
-
-pkg_postinst() {
- elog "Openstack swift will default to using insecure http unless a"
- elog "certificate is created in /etc/swift/cert.crt and the associated key"
- elog "in /etc/swift/cert.key. These can be created with the following:"
- elog " * cd /etc/swift"
- elog " * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
-}