summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2013-02-02 14:12:05 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2013-02-02 14:12:05 +0000
commit451f2f471639ad681019bfcc1482272707749f0c (patch)
tree9766157324c7f93cdd9ce26032bd0b4a6dc440a9 /sys-cluster/pbs-python
parentVersion bump. (diff)
downloadgentoo-2-451f2f471639ad681019bfcc1482272707749f0c.tar.gz
gentoo-2-451f2f471639ad681019bfcc1482272707749f0c.tar.bz2
gentoo-2-451f2f471639ad681019bfcc1482272707749f0c.zip
Port to distutils-r1, drop old
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 895192F9)
Diffstat (limited to 'sys-cluster/pbs-python')
-rw-r--r--sys-cluster/pbs-python/ChangeLog12
-rw-r--r--sys-cluster/pbs-python/pbs-python-4.1.0.ebuild38
-rw-r--r--sys-cluster/pbs-python/pbs-python-4.3.3-r1.ebuild (renamed from sys-cluster/pbs-python/pbs-python-4.3.3.ebuild)39
3 files changed, 25 insertions, 64 deletions
diff --git a/sys-cluster/pbs-python/ChangeLog b/sys-cluster/pbs-python/ChangeLog
index 5ab4321c4d8a..508c117a3efc 100644
--- a/sys-cluster/pbs-python/ChangeLog
+++ b/sys-cluster/pbs-python/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/pbs-python
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pbs-python/ChangeLog,v 1.6 2012/11/08 15:43:51 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pbs-python/ChangeLog,v 1.7 2013/02/02 14:12:05 xarthisius Exp $
+
+*pbs-python-4.3.3-r1 (02 Feb 2013)
+
+ 02 Feb 2013; Kacper Kowalik <xarthisius@gentoo.org>
+ +pbs-python-4.3.3-r1.ebuild, -pbs-python-4.1.0.ebuild,
+ -pbs-python-4.3.3.ebuild:
+ Port to distutils-r1, drop old
*pbs-python-4.3.3 (08 Nov 2012)
@@ -34,4 +41,3 @@
24 Mar 2008; Donnie Berkholz <dberkholz@gentoo.org>; +metadata.xml,
+pbs-python-2.9.4.ebuild:
Python bindings to the PBS C API.
-
diff --git a/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild b/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild
deleted file mode 100644
index 65cfab7bf380..000000000000
--- a/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pbs-python/pbs-python-4.1.0.ebuild,v 1.2 2010/06/09 14:32:13 arfrever Exp $
-
-EAPI=3
-PYTHON_DEPEND="2"
-PYTHON_MODNAME="pbs"
-
-inherit distutils
-
-MY_P=${P/-/_}
-
-DESCRIPTION="Python bindings to the Torque C API"
-HOMEPAGE="https://subtrac.sara.nl/oss/pbs_python/"
-SRC_URI="ftp://ftp.sara.nl/pub/outgoing/${MY_P}.tar.gz"
-
-LICENSE="openpbs"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples"
-
-RDEPEND="sys-cluster/torque"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_install() {
- distutils_src_install
- if use examples; then
- insinto /usr/share/doc/${P} || die
- doins "${S}"/examples/* || die
- fi
-}
diff --git a/sys-cluster/pbs-python/pbs-python-4.3.3.ebuild b/sys-cluster/pbs-python/pbs-python-4.3.3-r1.ebuild
index 15786e6539eb..cde8f538f7bd 100644
--- a/sys-cluster/pbs-python/pbs-python-4.3.3.ebuild
+++ b/sys-cluster/pbs-python/pbs-python-4.3.3-r1.ebuild
@@ -1,16 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pbs-python/pbs-python-4.3.3.ebuild,v 1.1 2012/11/08 15:43:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pbs-python/pbs-python-4.3.3-r1.ebuild,v 1.1 2013/02/02 14:12:05 xarthisius Exp $
EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-PYTHON_DEPEND="2"
-PYTHON_MODNAME="pbs"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES=1
-
-inherit distutils
+inherit distutils-r1
MY_P=${P/-/_}
@@ -18,30 +13,28 @@ DESCRIPTION="Python bindings to the Torque C API"
HOMEPAGE="https://subtrac.sara.nl/oss/pbs_python/"
SRC_URI="ftp://ftp.sara.nl/pub/outgoing/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="openpbs"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples"
-RDEPEND="sys-cluster/torque"
-DEPEND="${RDEPEND}"
+DEPEND="sys-cluster/torque"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
-#pkg_setup() {
-# python_set_active_version 2
-# python_pkg_setup
-#}
+python_prepare_all() {
+ sed -i -e "s/4.1.3/${PV}/" setup.py.in || die
+ distutils-r1_python_prepare_all
+}
-src_configure() {
- configure() {
- econf
- }
- python_execute_function -s configure
+python_configure_all() {
+ econf
}
-src_install() {
- distutils_src_install
+python_install_all() {
+ distutils-r1_python_install_all
+
if use examples; then
insinto /usr/share/doc/${P}
doins "${S}"/examples/*