summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-09-26 00:15:33 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-09-26 00:15:33 +0000
commit71baa78752629ec5d9aa64a7ab9cf4f37fd1d0fd (patch)
tree34c46ce31e7c1dd8cea47b78f5aeb61523f050e6 /sys-cluster/nova
parentUse relative symlinks. (diff)
downloadgentoo-2-71baa78752629ec5d9aa64a7ab9cf4f37fd1d0fd.tar.gz
gentoo-2-71baa78752629ec5d9aa64a7ab9cf4f37fd1d0fd.tar.bz2
gentoo-2-71baa78752629ec5d9aa64a7ab9cf4f37fd1d0fd.zip
lxml and directory ownership
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster/nova')
-rw-r--r--sys-cluster/nova/ChangeLog10
-rw-r--r--sys-cluster/nova/nova-2012.2.4-r10.ebuild (renamed from sys-cluster/nova/nova-2012.2.4-r9.ebuild)13
-rw-r--r--sys-cluster/nova/nova-2013.1.3-r6.ebuild (renamed from sys-cluster/nova/nova-2013.1.3-r5.ebuild)12
-rw-r--r--sys-cluster/nova/nova-2013.1.9999.ebuild12
-rw-r--r--sys-cluster/nova/nova-9999.ebuild11
5 files changed, 45 insertions, 13 deletions
diff --git a/sys-cluster/nova/ChangeLog b/sys-cluster/nova/ChangeLog
index a3192bc740b6..50044aaa3e0d 100644
--- a/sys-cluster/nova/ChangeLog
+++ b/sys-cluster/nova/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/nova
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.28 2013/09/13 20:47:34 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.29 2013/09/26 00:15:33 prometheanfire Exp $
+
+*nova-2012.2.4-r10 (26 Sep 2013)
+*nova-2013.1.3-r6 (26 Sep 2013)
+
+ 26 Sep 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +nova-2012.2.4-r10.ebuild, +nova-2013.1.3-r6.ebuild, -nova-2012.2.4-r9.ebuild,
+ -nova-2013.1.3-r5.ebuild, nova-2013.1.9999.ebuild, nova-9999.ebuild:
+ lxml and directory ownership
*nova-2012.2.4-r9 (13 Sep 2013)
diff --git a/sys-cluster/nova/nova-2012.2.4-r9.ebuild b/sys-cluster/nova/nova-2012.2.4-r10.ebuild
index 5b3d249154ba..365506624f39 100644
--- a/sys-cluster/nova/nova-2012.2.4-r9.ebuild
+++ b/sys-cluster/nova/nova-2012.2.4-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2012.2.4-r9.ebuild,v 1.1 2013/09/13 20:47:34 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2012.2.4-r10.ebuild,v 1.1 2013/09/26 00:15:33 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -30,6 +30,8 @@ RDEPEND="~dev-python/amqplib-0.6.1[${PYTHON_USEDEP}]
postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
<dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
~dev-python/boto-2.1.1[${PYTHON_USEDEP}]
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ <dev-python/lxml-2.3.6
>=dev-python/eventlet-0.9.17[${PYTHON_USEDEP}]
~dev-python/kombu-1.0.4[${PYTHON_USEDEP}]
~dev-python/routes-1.12.3[${PYTHON_USEDEP}]
@@ -78,8 +80,13 @@ python_install() {
use spicehtml5proxy && dosym /etc/init.d/nova /etc/init.d/nova-spicehtml5proxy
use xvpvncproxy && dosym /etc/init.d/nova /etc/init.d/nova-xvpncproxy
- dodir /var/log/nova
- fowners nova:nova /var/log/nova
+ diropts -m 0750
+ dodir /var/run/nova /var/log/nova /var/lock/nova
+ fowners nova:nova /var/log/nova /var/lock/nova /var/run/nova
+
+ diropts -m 0755
+ dodir /var/lib/nova/instances
+ fowners nova:nova /var/lib/nova/instances
keepdir /etc/nova
insinto /etc/nova
diff --git a/sys-cluster/nova/nova-2013.1.3-r5.ebuild b/sys-cluster/nova/nova-2013.1.3-r6.ebuild
index a7c3ad3ee4cd..18889d120522 100644
--- a/sys-cluster/nova/nova-2013.1.3-r5.ebuild
+++ b/sys-cluster/nova/nova-2013.1.3-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2013.1.3-r5.ebuild,v 1.1 2013/09/12 06:55:26 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2013.1.3-r6.ebuild,v 1.1 2013/09/26 00:15:33 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -31,6 +31,7 @@ RDEPEND=">=dev-python/amqplib-0.6.1[${PYTHON_USEDEP}]
postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
<dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
dev-python/boto[${PYTHON_USEDEP}]
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
>=dev-python/eventlet-0.9.17[${PYTHON_USEDEP}]
>=dev-python/kombu-1.0.4-r1[${PYTHON_USEDEP}]
>=dev-python/routes-1.12.3-r1[${PYTHON_USEDEP}]
@@ -83,8 +84,13 @@ python_install() {
use spicehtml5proxy && dosym /etc/init.d/nova /etc/init.d/nova-spicehtml5proxy
use xvpvncproxy && dosym /etc/init.d/nova /etc/init.d/nova-xvpncproxy
- dodir /var/log/nova
- fowners nova:nova /var/log/nova
+ diropts -m 0750
+ dodir /var/run/nova /var/log/nova /var/lock/nova
+ fowners nova:nova /var/log/nova /var/lock/nova /var/run/nova
+
+ diropts -m 0755
+ dodir /var/lib/nova/instances
+ fowners nova:nova /var/lib/nova/instances
keepdir /etc/nova
insinto /etc/nova
diff --git a/sys-cluster/nova/nova-2013.1.9999.ebuild b/sys-cluster/nova/nova-2013.1.9999.ebuild
index 88a35e4100fa..1aa2da16b064 100644
--- a/sys-cluster/nova/nova-2013.1.9999.ebuild
+++ b/sys-cluster/nova/nova-2013.1.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2013.1.9999.ebuild,v 1.7 2013/09/12 06:18:01 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2013.1.9999.ebuild,v 1.8 2013/09/26 00:15:33 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -32,6 +32,7 @@ RDEPEND=">=dev-python/amqplib-0.6.1[${PYTHON_USEDEP}]
postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
<dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
dev-python/boto[${PYTHON_USEDEP}]
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
>=dev-python/eventlet-0.9.17[${PYTHON_USEDEP}]
>=dev-python/kombu-1.0.4-r1[${PYTHON_USEDEP}]
>=dev-python/routes-1.12.3-r1[${PYTHON_USEDEP}]
@@ -82,8 +83,13 @@ python_install() {
use spicehtml5proxy && dosym /etc/init.d/nova /etc/init.d/nova-spicehtml5proxy
use xvpvncproxy && dosym /etc/init.d/nova /etc/init.d/nova-xvpncproxy
- dodir /var/log/nova
- fowners nova:nova /var/log/nova
+ diropts -m 0750
+ dodir /var/run/nova /var/log/nova /var/lock/nova
+ fowners nova:nova /var/log/nova /var/lock/nova /var/run/nova
+
+ diropts -m 0755
+ dodir /var/lib/nova/instances
+ fowners nova:nova /var/lib/nova/instances
keepdir /etc/nova
insinto /etc/nova
diff --git a/sys-cluster/nova/nova-9999.ebuild b/sys-cluster/nova/nova-9999.ebuild
index 7bffb5f96bbf..8ae9b6dd7845 100644
--- a/sys-cluster/nova/nova-9999.ebuild
+++ b/sys-cluster/nova/nova-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-9999.ebuild,v 1.8 2013/09/12 06:18:01 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-9999.ebuild,v 1.9 2013/09/26 00:15:33 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -89,8 +89,13 @@ python_install() {
use spicehtml5proxy && dosym /etc/init.d/nova /etc/init.d/nova-spicehtml5proxy
use xvpvncproxy && dosym /etc/init.d/nova /etc/init.d/nova-xvpncproxy
- dodir /var/log/nova
- fowners nova:nova /var/log/nova
+ diropts -m 0750
+ dodir /var/run/nova /var/log/nova /var/lock/nova
+ fowners nova:nova /var/log/nova /var/lock/nova /var/run/nova
+
+ diropts -m 0755
+ dodir /var/lib/nova/instances
+ fowners nova:nova /var/lib/nova/instances
keepdir /etc/nova
insinto /etc/nova