summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2011-06-12 22:37:21 +0000
committerJustin Bronder <jsbronder@gentoo.org>2011-06-12 22:37:21 +0000
commit2e75a21c53d9ac7fb0f1d30add01d0e9652f7651 (patch)
treeb804c0a70ec506e4a9efd2cad2a6e4c4cb7acaa7 /sys-cluster/mpich2
parentFix bug #369543. (diff)
downloadgentoo-2-2e75a21c53d9ac7fb0f1d30add01d0e9652f7651.tar.gz
gentoo-2-2e75a21c53d9ac7fb0f1d30add01d0e9652f7651.tar.bz2
gentoo-2-2e75a21c53d9ac7fb0f1d30add01d0e9652f7651.zip
Fix pkg-config files, #369263
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/mpich2')
-rw-r--r--sys-cluster/mpich2/ChangeLog8
-rw-r--r--sys-cluster/mpich2/files/fix-pkg-config-files.patch123
-rw-r--r--sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild (renamed from sys-cluster/mpich2/mpich2-1.4_rc2.ebuild)8
3 files changed, 136 insertions, 3 deletions
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
index d411874a4ff9..cd6a1b8d150d 100644
--- a/sys-cluster/mpich2/ChangeLog
+++ b/sys-cluster/mpich2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/mpich2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.70 2011/05/10 14:31:03 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.71 2011/06/12 22:37:21 jsbronder Exp $
+
+*mpich2-1.4_rc2-r1 (12 Jun 2011)
+
+ 12 Jun 2011; Justin Bronder <jsbronder@gentoo.org> -mpich2-1.4_rc2.ebuild,
+ +mpich2-1.4_rc2-r1.ebuild, +files/fix-pkg-config-files.patch:
+ Fix pkg-config files, #369263
10 May 2011; Justin Bronder <jsbronder@gentoo.org> mpich2-1.4_rc2.ebuild:
Correct fix for #293665
diff --git a/sys-cluster/mpich2/files/fix-pkg-config-files.patch b/sys-cluster/mpich2/files/fix-pkg-config-files.patch
new file mode 100644
index 000000000000..9e319f4acfc0
--- /dev/null
+++ b/sys-cluster/mpich2/files/fix-pkg-config-files.patch
@@ -0,0 +1,123 @@
+From e4ffe1eb191ab5d02de5c25e416f1d4d0f471f44 Mon Sep 17 00:00:00 2001
+From: Justin Bronder <jsbronder@gmail.com>
+Date: Sun, 12 Jun 2011 14:45:34 -0400
+Subject: [PATCH] fix pkg-config files
+
+https://trac.mcs.anl.gov/projects/mpich2/ticket/1044
+https://trac.mcs.anl.gov/projects/mpich2/ticket/1500
+---
+ configure.in | 6 ++++++
+ src/packaging/pkgconfig/mpich2-c.pc.in | 10 ++--------
+ src/packaging/pkgconfig/mpich2-cxx.pc.in | 10 ++--------
+ src/packaging/pkgconfig/mpich2-f77.pc.in | 10 ++--------
+ src/packaging/pkgconfig/mpich2-f90.pc.in | 10 ++--------
+ 5 files changed, 14 insertions(+), 32 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index de22cac..8543bb1 100644
+--- a/configure.in
++++ b/configure.in
+@@ -5329,6 +5329,12 @@ AC_SUBST(MPICH_TIMER_KIND)
+ # Setup other replaceable values
+ AC_SUBST(MPILIBNAME)
+ AC_SUBST(PMPILIBNAME)
++PKGCONFIG_PMPILIB=""
++if test "$NEEDSPLIB" = yes -a test -n "${PMPILIBNAME}" ; then
++ PKGCONFIG_PMPILIB="-l${PMPILIBNAME}"
++fi
++AC_SUBST(PKGCONFIG_PMPILIB)
++
+ # Note that aint_size must be used instead of void_p where the desired check
+ # is on the size of MPI_Aint
+ aint_size=$ac_cv_sizeof_void_p
+diff --git a/src/packaging/pkgconfig/mpich2-c.pc.in b/src/packaging/pkgconfig/mpich2-c.pc.in
+index b071fc6..e0ab3fa 100644
+--- a/src/packaging/pkgconfig/mpich2-c.pc.in
++++ b/src/packaging/pkgconfig/mpich2-c.pc.in
+@@ -4,15 +4,9 @@ exec_prefix=@exec_prefix@
+ libdir=@libdir@
+ includedir=@includedir@
+
+-if test "@NEEDSPLIB@" = "yes" ; then
+- plib=@PMPILIBNAME@
+-else
+- plib=
+-fi
+-
+ Name: mpich2
+ Description: MPICH2 is an implementation of the Message-Passing Interface (MPI). The goals of MPICH2 are to provide an MPI implementation for important platforms, including clusters, SMPs, and massively parallel processors. It also provides a vehicle for MPI implementation research and for developing new and better parallel programming environments.
+ Version: @MPICH2_VERSION@
+ Requires:
+-Libs: @WRAPPER_LDFLAGS@ -L$libdir -l$plib -l@MPILIBNAME@ @WRAPPER_LIBS@
+-Cflags: @WRAPPER_CPPFLAGS@ @WRAPPER_CFLAGS@ -I$includedir
++Libs: @WRAPPER_LDFLAGS@ -L${libdir} @PKGCONFIG_PMPILIB@ -l@MPILIBNAME@ @WRAPPER_LIBS@
++Cflags: @WRAPPER_CPPFLAGS@ @WRAPPER_CFLAGS@ -I${includedir}
+diff --git a/src/packaging/pkgconfig/mpich2-cxx.pc.in b/src/packaging/pkgconfig/mpich2-cxx.pc.in
+index d21f9e6..d82e184 100644
+--- a/src/packaging/pkgconfig/mpich2-cxx.pc.in
++++ b/src/packaging/pkgconfig/mpich2-cxx.pc.in
+@@ -4,15 +4,9 @@ exec_prefix=@exec_prefix@
+ libdir=@libdir@
+ includedir=@includedir@
+
+-if test "@NEEDSPLIB@" = "yes" ; then
+- plib=@PMPILIBNAME@
+-else
+- plib=
+-fi
+-
+ Name: mpich2
+ Description: MPICH2 is an implementation of the Message-Passing Interface (MPI). The goals of MPICH2 are to provide an MPI implementation for important platforms, including clusters, SMPs, and massively parallel processors. It also provides a vehicle for MPI implementation research and for developing new and better parallel programming environments.
+ Version: @MPICH2_VERSION@
+ Requires:
+-Libs: @WRAPPER_LDFLAGS@ -L$libdir -l$plib -l@MPILIBNAME@ @WRAPPER_LIBS@
+-Cxxflags: @WRAPPER_CPPFLAGS@ @WRAPPER_CXXFLAGS@ -I$includedir
++Libs: @WRAPPER_LDFLAGS@ -L${libdir} @PKGCONFIG_PMPILIB@ -l@MPILIBNAME@ @WRAPPER_LIBS@
++Cxxflags: @WRAPPER_CPPFLAGS@ @WRAPPER_CXXFLAGS@ -I${includedir}
+diff --git a/src/packaging/pkgconfig/mpich2-f77.pc.in b/src/packaging/pkgconfig/mpich2-f77.pc.in
+index 1b48bf6..193c2ab 100644
+--- a/src/packaging/pkgconfig/mpich2-f77.pc.in
++++ b/src/packaging/pkgconfig/mpich2-f77.pc.in
+@@ -4,15 +4,9 @@ exec_prefix=@exec_prefix@
+ libdir=@libdir@
+ includedir=@includedir@
+
+-if test "@NEEDSPLIB@" = "yes" ; then
+- plib=@PMPILIBNAME@
+-else
+- plib=
+-fi
+-
+ Name: mpich2
+ Description: MPICH2 is an implementation of the Message-Passing Interface (MPI). The goals of MPICH2 are to provide an MPI implementation for important platforms, including clusters, SMPs, and massively parallel processors. It also provides a vehicle for MPI implementation research and for developing new and better parallel programming environments.
+ Version: @MPICH2_VERSION@
+ Requires:
+-Libs: @WRAPPER_LDFLAGS@ -L$libdir -l$plib -l@MPILIBNAME@ @WRAPPER_LIBS@
+-Fflags: @WRAPPER_FFLAGS@ -I$includedir
++Libs: @WRAPPER_LDFLAGS@ -L${libdir} @PKGCONFIG_PMPILIB@ -l@MPILIBNAME@ @WRAPPER_LIBS@
++Fflags: @WRAPPER_FFLAGS@ -I${includedir}
+diff --git a/src/packaging/pkgconfig/mpich2-f90.pc.in b/src/packaging/pkgconfig/mpich2-f90.pc.in
+index ebb8499..700976f 100644
+--- a/src/packaging/pkgconfig/mpich2-f90.pc.in
++++ b/src/packaging/pkgconfig/mpich2-f90.pc.in
+@@ -4,15 +4,9 @@ exec_prefix=@exec_prefix@
+ libdir=@libdir@
+ includedir=@includedir@
+
+-if test "@NEEDSPLIB@" = "yes" ; then
+- plib=@PMPILIBNAME@
+-else
+- plib=
+-fi
+-
+ Name: mpich2
+ Description: MPICH2 is an implementation of the Message-Passing Interface (MPI). The goals of MPICH2 are to provide an MPI implementation for important platforms, including clusters, SMPs, and massively parallel processors. It also provides a vehicle for MPI implementation research and for developing new and better parallel programming environments.
+ Version: @MPICH2_VERSION@
+ Requires:
+-Libs: @WRAPPER_LDFLAGS@ -L$libdir -l$plib -l@MPILIBNAME@ @WRAPPER_LIBS@
+-Fcflags: @WRAPPER_FCFLAGS@ -I$includedir
++Libs: @WRAPPER_LDFLAGS@ -L${libdir} @PKGCONFIG_PMPILIB@ -l@MPILIBNAME@ @WRAPPER_LIBS@
++Fcflags: @WRAPPER_FCFLAGS@ -I${includedir}
+--
+1.7.3.4
+
diff --git a/sys-cluster/mpich2/mpich2-1.4_rc2.ebuild b/sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild
index 12356f86d05e..0300ba5680cc 100644
--- a/sys-cluster/mpich2/mpich2-1.4_rc2.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.4_rc2.ebuild,v 1.5 2011/05/10 14:31:03 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.4_rc2-r1.ebuild,v 1.1 2011/06/12 22:37:21 jsbronder Exp $
EAPI=2
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs autotools
MY_PV=${PV/_/}
DESCRIPTION="MPICH2 - A portable MPI implementation"
@@ -49,6 +49,10 @@ src_prepare() {
sed -i \
-e 's,\(.*=\ *\)"@WRAPPER_[A-Z]*FLAGS@",\1"",' \
src/env/*.in || die
+
+ # 369263 and 1044, 1500 upstream.
+ epatch "${FILESDIR}"/fix-pkg-config-files.patch
+ AT_M4DIR="${S}"/confdb eautoreconf || die
}
src_configure() {