summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-01-26 06:27:21 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-01-26 06:27:21 +0000
commita412a4ea229f82330abd10559b6746ad87408b6f (patch)
tree81b0a1a2a53bc5cc74f195112aff27640a2a07dc /sys-cluster/cinder
parentinitial add of setuptools-git for sys-cluster/cinder (diff)
downloadgentoo-2-a412a4ea229f82330abd10559b6746ad87408b6f.tar.gz
gentoo-2-a412a4ea229f82330abd10559b6746ad87408b6f.tar.bz2
gentoo-2-a412a4ea229f82330abd10559b6746ad87408b6f.zip
initial add of openstack cinder
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster/cinder')
-rw-r--r--sys-cluster/cinder/ChangeLog10
-rw-r--r--sys-cluster/cinder/cinder-2012.2.1.ebuild67
-rw-r--r--sys-cluster/cinder/metadata.xml13
3 files changed, 90 insertions, 0 deletions
diff --git a/sys-cluster/cinder/ChangeLog b/sys-cluster/cinder/ChangeLog
new file mode 100644
index 000000000000..aeab2a31183a
--- /dev/null
+++ b/sys-cluster/cinder/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-cluster/cinder
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/ChangeLog,v 1.1 2013/01/26 06:27:21 prometheanfire Exp $
+
+*cinder-2012.2.1 (26 Jan 2013)
+
+ 26 Jan 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +cinder-2012.2.1.ebuild, +metadata.xml:
+ initial add of openstack cinder
+
diff --git a/sys-cluster/cinder/cinder-2012.2.1.ebuild b/sys-cluster/cinder/cinder-2012.2.1.ebuild
new file mode 100644
index 000000000000..1e75c73ba3c7
--- /dev/null
+++ b/sys-cluster/cinder/cinder-2012.2.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/cinder-2012.2.1.ebuild,v 1.1 2013/01/26 06:27:21 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cinder is the OpenStack Block storage service. This is a spin out
+of nova-volumes."
+HOMEPAGE="https://launchpad.net/cinder"
+SRC_URI="http://launchpad.net/${PN}/folsom/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="=dev-python/amqplib-0.6.1
+ >=dev-python/anyjson-0.2.4
+ >=dev-python/eventlet-0.9.17
+ =dev-python/kombu-1.0.4
+ =dev-python/lockfile-0.8
+ >=dev-python/lxml-2.3
+ =dev-python/routes-1.12.3
+ >=dev-python/webob-1.0.8
+ =dev-python/wsgiref-0.1.2
+ >=dev-python/greenlet-0.3.1
+ =dev-python/pastedeploy-1.5.0
+ dev-python/paste
+ >=dev-python/sqlalchemy-0.7.3
+ <=dev-python/sqlalchemy-0.7.9
+ >=dev-python/sqlalchemy-migrate-0.7.2
+ >=dev-python/stevedore-0.8
+ =dev-python/suds-0.4
+ dev-python/paramiko
+ >=dev-python/Babel-0.9.6
+ >=dev-python/iso8601-0.1.4
+ >=dev-python/setuptools-git-0.4
+ >=dev-python/python-glanceclient-0.5.0
+ <dev-python/python-glanceclient-2
+ >=dev-python/python-keystoneclient-0.2.0
+ dev-python/sqlalchemy"
+
+pkg_setup() {
+ enewuser swift
+ enewgroup swift
+}
+
+python_install() {
+ distutils-r1_python_install
+ keepdir /etc/cinder
+ keepdir /etc/cinder/rootwrap.d
+ insinto /etc/cinder
+
+ newins "etc/cinder/cinder.conf.sample" "cinder.conf"
+ newins "etc/cinder/api-paste.ini" "api-paste.ini"
+ newins "etc/cinder/cinder_emc_config.xml.sample" "cinder_emc_config.xml.sample"
+ newins "etc/cinder/logging_sample.conf" "logging_sample.conf"
+ newins "etc/cinder/policy.json" "policy.json"
+ newins "etc/cinder/rootwrap.conf" "rootwrap.conf"
+ insinto /etc/cinder/rootwrap.d
+ newins "etc/cinder/rootwrap.d/volume.filters" "volume.filters"
+}
diff --git a/sys-cluster/cinder/metadata.xml b/sys-cluster/cinder/metadata.xml
new file mode 100644
index 000000000000..f3ed38a15db9
--- /dev/null
+++ b/sys-cluster/cinder/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Cinder is the OpenStack Block storage service.
+ This is a spin out of nova-volumes.
+ </longdescription>
+</pkgmetadata>
+