summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-08-02 18:27:50 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-08-02 18:27:50 +0000
commit1cd678dea0f2ce0572e8cec1d3ad248f497b0129 (patch)
treea696878b7eb88622eee68054b72844890bce0eb0 /sys-cluster/cinder
parentcorrect slot and keywords for keystone-2013.1.9999 (diff)
downloadgentoo-2-1cd678dea0f2ce0572e8cec1d3ad248f497b0129.tar.gz
gentoo-2-1cd678dea0f2ce0572e8cec1d3ad248f497b0129.tar.bz2
gentoo-2-1cd678dea0f2ce0572e8cec1d3ad248f497b0129.zip
stable/grizzly for cinder
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster/cinder')
-rw-r--r--sys-cluster/cinder/ChangeLog8
-rw-r--r--sys-cluster/cinder/cinder-2013.1.9999.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/sys-cluster/cinder/ChangeLog b/sys-cluster/cinder/ChangeLog
index 8260623d1592..810779283c33 100644
--- a/sys-cluster/cinder/ChangeLog
+++ b/sys-cluster/cinder/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/cinder
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/ChangeLog,v 1.10 2013/06/06 19:18:06 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/ChangeLog,v 1.11 2013/08/02 18:27:50 prometheanfire Exp $
+
+*cinder-2013.1.9999 (02 Aug 2013)
+
+ 02 Aug 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +cinder-2013.1.9999.ebuild:
+ stable/grizzly for cinder
*cinder-2013.1.2 (06 Jun 2013)
diff --git a/sys-cluster/cinder/cinder-2013.1.9999.ebuild b/sys-cluster/cinder/cinder-2013.1.9999.ebuild
new file mode 100644
index 000000000000..040736b0a150
--- /dev/null
+++ b/sys-cluster/cinder/cinder-2013.1.9999.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/cinder-2013.1.9999.ebuild,v 1.1 2013/08/02 18:27:50 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils git-2
+
+DESCRIPTION="Cinder is the OpenStack Block storage service. This is a spin out
+of nova-volumes."
+HOMEPAGE="https://launchpad.net/cinder"
+EGIT_REPO_URI="https://github.com/openstack/cinder.git"
+EGIT_BRANCH="stable/grizzly"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="=dev-python/amqplib-0.6.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/anyjson-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.9.17[${PYTHON_USEDEP}]
+ >=dev-python/kombu-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/lockfile-0.8[${PYTHON_USEDEP}]
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ >=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
+ =dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
+ >=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.7.3
+ <=dev-python/sqlalchemy-0.7.9
+ >=dev-python/sqlalchemy-migrate-0.7.2
+ >=dev-python/stevedore-0.8
+ >=dev-python/suds-0.4
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ >=dev-python/Babel-0.9.6[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-git-0.4[${PYTHON_USEDEP}]
+ >=dev-python/python-glanceclient-0.5.0[${PYTHON_USEDEP}]
+ <dev-python/python-glanceclient-2[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.2.0[${PYTHON_USEDEP}]
+ dev-python/python-swiftclient[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+
+PATCHES=( )
+
+python_install() {
+ distutils-r1_python_install
+ keepdir /etc/cinder
+ keepdir /etc/cinder/rootwrap.d
+ insinto /etc/cinder
+
+ newins "${S}/etc/cinder/cinder.conf.sample" "cinder.conf"
+ newins "${S}/etc/cinder/api-paste.ini" "api-paste.ini"
+ newins "${S}/etc/cinder/logging_sample.conf" "logging_sample.conf"
+ newins "${S}/etc/cinder/policy.json" "policy.json"
+ newins "${S}/etc/cinder/rootwrap.conf" "rootwrap.conf"
+ insinto /etc/cinder/rootwrap.d
+ newins "${S}/etc/cinder/rootwrap.d/volume.filters" "volume.filters"
+}