summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2007-03-09 10:57:12 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2007-03-09 10:57:12 +0000
commitbbbdccf48f71f76c73061167c08346e7f1cbf7bf (patch)
tree2016949a2d7cbab7860f36d4eb4d464c233d95ed /sys-cluster/ccs/ccs-1.04.00.ebuild
parentstable x86; bug #169987 (diff)
downloadgentoo-2-bbbdccf48f71f76c73061167c08346e7f1cbf7bf.tar.gz
gentoo-2-bbbdccf48f71f76c73061167c08346e7f1cbf7bf.tar.bz2
gentoo-2-bbbdccf48f71f76c73061167c08346e7f1cbf7bf.zip
Version bump, relaxed dependencies.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sys-cluster/ccs/ccs-1.04.00.ebuild')
-rw-r--r--sys-cluster/ccs/ccs-1.04.00.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-cluster/ccs/ccs-1.04.00.ebuild b/sys-cluster/ccs/ccs-1.04.00.ebuild
new file mode 100644
index 000000000000..a60804cb1502
--- /dev/null
+++ b/sys-cluster/ccs/ccs-1.04.00.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ccs/ccs-1.04.00.ebuild,v 1.1 2007/03/09 10:57:12 xmerlin Exp $
+
+CLUSTER_RELEASE="1.04.00"
+MY_P="cluster-${CLUSTER_RELEASE}"
+
+DESCRIPTION="cluster configuration system to manage the cluster config file"
+HOMEPAGE="http://sources.redhat.com/cluster/"
+SRC_URI="ftp://sources.redhat.com/pub/cluster/releases/${MY_P}.tar.gz"
+IUSE=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+
+DEPEND="=sys-cluster/magma-${CLUSTER_RELEASE}*
+ dev-libs/libxml2
+ sys-libs/zlib"
+
+S="${WORKDIR}/${MY_P}/${PN}"
+
+src_compile() {
+ ./configure || die "configure problem"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "install problem"
+
+ newinitd ${FILESDIR}/${PN}d.rc ${PN}d || die
+ newconfd ${FILESDIR}/${PN}d.conf ${PN}d || die
+}