summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-05-02 06:32:31 +0000
committerJeroen Roovers <jer@gentoo.org>2010-05-02 06:32:31 +0000
commit95e812c23dce50e475343877b73eb34e87d20347 (patch)
tree2c395cac21b3aa1a8144bb506ed45866b897b732 /sys-boot
parentold (diff)
downloadgentoo-2-95e812c23dce50e475343877b73eb34e87d20347.tar.gz
gentoo-2-95e812c23dce50e475343877b73eb34e87d20347.tar.bz2
gentoo-2-95e812c23dce50e475343877b73eb34e87d20347.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/unetbootin/ChangeLog7
-rw-r--r--sys-boot/unetbootin/unetbootin-442.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-boot/unetbootin/ChangeLog b/sys-boot/unetbootin/ChangeLog
index 145560925680..ec88117e2b01 100644
--- a/sys-boot/unetbootin/ChangeLog
+++ b/sys-boot/unetbootin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/unetbootin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.38 2010/04/27 04:57:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.39 2010/05/02 06:32:31 jer Exp $
+
+*unetbootin-442 (02 May 2010)
+
+ 02 May 2010; Jeroen Roovers <jer@gentoo.org> +unetbootin-442.ebuild:
+ Version bump.
*unetbootin-436 (27 Apr 2010)
diff --git a/sys-boot/unetbootin/unetbootin-442.ebuild b/sys-boot/unetbootin/unetbootin-442.ebuild
new file mode 100644
index 000000000000..157e97d860f8
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-442.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-442.ebuild,v 1.1 2010/05/02 06:32:31 jer Exp $
+
+inherit qt4
+
+DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
+distributions."
+HOMEPAGE="http://unetbootin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/unetbootin/${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+DEPEND="x11-libs/qt-gui"
+RDEPEND="${DEPEND}
+ sys-fs/mtools
+ sys-boot/syslinux
+ app-arch/p7zip"
+
+src_compile() {
+ lupdate unetbootin.pro || die "lupdate failed"
+ lrelease unetbootin.pro || die "lrelease failed"
+ eqmake4 unetbootin.pro || die "eqmake4 failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin unetbootin || die "dobin failed"
+ insinto /usr/share/applications
+ doins unetbootin.desktop || die "doins failed"
+}