summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-03-17 02:07:08 +0000
committerMike Gilbert <floppym@gentoo.org>2015-03-17 02:07:08 +0000
commit82f52c258fc47e3a9f0b56a48c3e1796e23329ec (patch)
tree4229b06ddd5b7bed6f58321e6c6e2987a7972fa3 /sys-boot
parentWe need to set TARGET_LDFLAGS, not LDFLAGS. (diff)
downloadgentoo-2-82f52c258fc47e3a9f0b56a48c3e1796e23329ec.tar.gz
gentoo-2-82f52c258fc47e3a9f0b56a48c3e1796e23329ec.tar.bz2
gentoo-2-82f52c258fc47e3a9f0b56a48c3e1796e23329ec.zip
Append to TARGET_LDFLAGS instead of replacing it.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog7
-rw-r--r--sys-boot/grub/grub-2.00_p5107-r2.ebuild4
-rw-r--r--sys-boot/grub/grub-2.02_beta2-r3.ebuild4
-rw-r--r--sys-boot/grub/grub-2.02_beta2-r6.ebuild4
-rw-r--r--sys-boot/grub/grub-2.02_beta2-r7.ebuild4
-rw-r--r--sys-boot/grub/grub-9999-r1.ebuild4
6 files changed, 16 insertions, 11 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 5ec0086e5910..77703cc1bc43 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.350 2015/03/17 02:00:07 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.351 2015/03/17 02:07:08 floppym Exp $
+
+ 17 Mar 2015; Mike Gilbert <floppym@gentoo.org> grub-2.00_p5107-r2.ebuild,
+ grub-2.02_beta2-r3.ebuild, grub-2.02_beta2-r6.ebuild,
+ grub-2.02_beta2-r7.ebuild, grub-9999-r1.ebuild:
+ Append to TARGET_LDFLAGS instead of replacing it.
17 Mar 2015; Mike Gilbert <floppym@gentoo.org> grub-2.00_p5107-r2.ebuild,
grub-2.02_beta2-r3.ebuild, grub-2.02_beta2-r6.ebuild,
diff --git a/sys-boot/grub/grub-2.00_p5107-r2.ebuild b/sys-boot/grub/grub-2.00_p5107-r2.ebuild
index 719d25a0ed1b..b65c24287224 100644
--- a/sys-boot/grub/grub-2.00_p5107-r2.ebuild
+++ b/sys-boot/grub/grub-2.00_p5107-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00_p5107-r2.ebuild,v 1.11 2015/03/17 02:00:07 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00_p5107-r2.ebuild,v 1.12 2015/03/17 02:07:08 floppym Exp $
EAPI=5
@@ -222,7 +222,7 @@ src_configure() {
use static && export HOST_LDFLAGS="${HOST_LDFLAGS} -static"
tc-ld-disable-gold #439082 #466536 #526348
- export TARGET_LDFLAGS=${LDFLAGS}
+ export TARGET_LDFLAGS+=" ${LDFLAGS}"
unset LDFLAGS
tc-export CC NM OBJCOPY STRIP
diff --git a/sys-boot/grub/grub-2.02_beta2-r3.ebuild b/sys-boot/grub/grub-2.02_beta2-r3.ebuild
index 93c4970113ec..12142e1173f5 100644
--- a/sys-boot/grub/grub-2.02_beta2-r3.ebuild
+++ b/sys-boot/grub/grub-2.02_beta2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r3.ebuild,v 1.7 2015/03/17 02:00:07 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r3.ebuild,v 1.8 2015/03/17 02:07:08 floppym Exp $
EAPI=5
@@ -237,7 +237,7 @@ src_configure() {
use static && HOST_LDFLAGS+=" -static"
tc-ld-disable-gold #439082 #466536 #526348
- export TARGET_LDFLAGS=${LDFLAGS}
+ export TARGET_LDFLAGS+=" ${LDFLAGS}"
unset LDFLAGS
tc-export CC NM OBJCOPY STRIP
diff --git a/sys-boot/grub/grub-2.02_beta2-r6.ebuild b/sys-boot/grub/grub-2.02_beta2-r6.ebuild
index 385938949400..738aa76db3ac 100644
--- a/sys-boot/grub/grub-2.02_beta2-r6.ebuild
+++ b/sys-boot/grub/grub-2.02_beta2-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r6.ebuild,v 1.5 2015/03/17 02:00:07 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r6.ebuild,v 1.6 2015/03/17 02:06:52 floppym Exp $
EAPI=5
@@ -237,7 +237,7 @@ src_configure() {
use static && HOST_LDFLAGS+=" -static"
tc-ld-disable-gold #439082 #466536 #526348
- export TARGET_LDFLAGS=${LDFLAGS}
+ export TARGET_LDFLAGS+=" ${LDFLAGS}"
unset LDFLAGS
tc-export CC NM OBJCOPY STRIP
diff --git a/sys-boot/grub/grub-2.02_beta2-r7.ebuild b/sys-boot/grub/grub-2.02_beta2-r7.ebuild
index 0719627cb423..a6d15edc1e96 100644
--- a/sys-boot/grub/grub-2.02_beta2-r7.ebuild
+++ b/sys-boot/grub/grub-2.02_beta2-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild,v 1.8 2015/03/17 02:00:07 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild,v 1.9 2015/03/17 02:07:08 floppym Exp $
EAPI=5
@@ -245,7 +245,7 @@ src_configure() {
use static && HOST_LDFLAGS+=" -static"
tc-ld-disable-gold #439082 #466536 #526348
- export TARGET_LDFLAGS=${LDFLAGS}
+ export TARGET_LDFLAGS+=" ${LDFLAGS}"
unset LDFLAGS
tc-export CC NM OBJCOPY STRIP
diff --git a/sys-boot/grub/grub-9999-r1.ebuild b/sys-boot/grub/grub-9999-r1.ebuild
index c6a79cbcc2b7..e4e989ad9891 100644
--- a/sys-boot/grub/grub-9999-r1.ebuild
+++ b/sys-boot/grub/grub-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999-r1.ebuild,v 1.31 2015/03/17 02:00:07 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999-r1.ebuild,v 1.32 2015/03/17 02:07:08 floppym Exp $
EAPI=5
@@ -245,7 +245,7 @@ src_configure() {
use static && HOST_LDFLAGS+=" -static"
tc-ld-disable-gold #439082 #466536 #526348
- export TARGET_LDFLAGS=${LDFLAGS}
+ export TARGET_LDFLAGS+=" ${LDFLAGS}"
unset LDFLAGS
tc-export CC NM OBJCOPY STRIP