summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-10-13 19:25:31 +0000
committerJeroen Roovers <jer@gentoo.org>2011-10-13 19:25:31 +0000
commit10cdc3e49ec8baae17b05f63cbd7bc97b4e735fe (patch)
tree4553d3c7da83e5925ba94690ebf5502b60c577b3 /sys-boot
parent[app-emulation/xen-pvgrub] Use toolchain function instead of calling LD direc... (diff)
downloadgentoo-2-10cdc3e49ec8baae17b05f63cbd7bc97b4e735fe.tar.gz
gentoo-2-10cdc3e49ec8baae17b05f63cbd7bc97b4e735fe.tar.bz2
gentoo-2-10cdc3e49ec8baae17b05f63cbd7bc97b4e735fe.zip
Version bump. Add LINGUAS support.
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/unetbootin/ChangeLog7
-rw-r--r--sys-boot/unetbootin/unetbootin-563.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/sys-boot/unetbootin/ChangeLog b/sys-boot/unetbootin/ChangeLog
index 0541c5e34556..a8dcd551c9b7 100644
--- a/sys-boot/unetbootin/ChangeLog
+++ b/sys-boot/unetbootin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/unetbootin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.64 2011/09/06 18:48:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.65 2011/10/13 19:25:31 jer Exp $
+
+*unetbootin-563 (13 Oct 2011)
+
+ 13 Oct 2011; Jeroen Roovers <jer@gentoo.org> +unetbootin-563.ebuild:
+ Version bump. Add LINGUAS support.
06 Sep 2011; Jeroen Roovers <jer@gentoo.org> unetbootin-549.ebuild,
unetbootin-555.ebuild:
diff --git a/sys-boot/unetbootin/unetbootin-563.ebuild b/sys-boot/unetbootin/unetbootin-563.ebuild
new file mode 100644
index 000000000000..1ccef96301fb
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-563.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-563.ebuild,v 1.1 2011/10/13 19:25:31 jer Exp $
+
+EAPI="4"
+
+inherit qt4-r2
+
+DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
+distributions."
+HOMEPAGE="http://unetbootin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+UNETBOOTIN_LINGUAS="
+ am ar ast be bg bn ca cs da de el eo es et eu fi fo fr gl he hr hu id it ja lt
+ lv ml ms nan nb nl nn pl pt pt_BR ro ru sk sl sr sv sw tr uk ur vi zh_CN zh_TW
+"
+
+for lingua in ${UNETBOOTIN_LINGUAS}; do
+ IUSE="${IUSE} linguas_${lingua}"
+done
+
+S="${WORKDIR}"
+
+DEPEND="x11-libs/qt-gui"
+RDEPEND="${DEPEND}
+ sys-fs/mtools
+ sys-boot/syslinux
+ app-arch/p7zip"
+
+src_configure() {
+ lupdate ${PN}.pro || die
+ lrelease ${PN}.pro || die
+ eqmake4 ${PN}.pro || die
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/share/applications
+ doins ${PN}.desktop
+
+ for file in ${PN}*.png; do
+ size="${file/${PN}_}"
+ size="${size/.png}x${size/.png}"
+ insinto /usr/share/icons/hicolor/${size}/apps
+ newins ${file} ${PN}.png
+ done
+
+ local lingua
+ for lingua in ${UNETBOOTIN_LINGUAS}; do
+ if use linguas_${lingua}; then
+ insinto /usr/share/${PN}
+ doins ${PN}_${lingua}.qm || die
+ fi
+ done
+}