summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2012-10-14 19:10:30 +0000
committerJonathan Callen <abcd@gentoo.org>2012-10-14 19:10:30 +0000
commit27a904c3d0ec55c477f99b74bddbb3473ea6291c (patch)
treee6076d105aca0bd90c2846d510e4d2b71bfdc474 /sys-boot/os-prober
parentPrepare for fortran2.eclass update (diff)
downloadgentoo-2-27a904c3d0ec55c477f99b74bddbb3473ea6291c.tar.gz
gentoo-2-27a904c3d0ec55c477f99b74bddbb3473ea6291c.tar.bz2
gentoo-2-27a904c3d0ec55c477f99b74bddbb3473ea6291c.zip
Update to latest upstream, use upstream's installation directories
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot/os-prober')
-rw-r--r--sys-boot/os-prober/ChangeLog8
-rw-r--r--sys-boot/os-prober/os-prober-1.56.ebuild68
2 files changed, 74 insertions, 2 deletions
diff --git a/sys-boot/os-prober/ChangeLog b/sys-boot/os-prober/ChangeLog
index 712f6484766d..e51ee28a94b3 100644
--- a/sys-boot/os-prober/ChangeLog
+++ b/sys-boot/os-prober/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/os-prober
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/ChangeLog,v 1.14 2012/06/29 16:25:49 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/ChangeLog,v 1.15 2012/10/14 19:10:30 abcd Exp $
+
+*os-prober-1.56 (14 Oct 2012)
+
+ 14 Oct 2012; Jonathan Callen <abcd@gentoo.org> +os-prober-1.56.ebuild:
+ Update to latest upstream, use upstream's installation directories
*os-prober-1.53 (29 Jun 2012)
@@ -69,4 +74,3 @@
15 Dec 2009; Jonathan Callen <abcd@gentoo.org> +os-prober-1.35.ebuild,
+files/os-prober-1.35-multilib.patch, +metadata.xml:
New ebuild. Thanks to Wizzelby <wizzleby@gmail.com> for initial ebuild.
-
diff --git a/sys-boot/os-prober/os-prober-1.56.ebuild b/sys-boot/os-prober/os-prober-1.56.ebuild
new file mode 100644
index 000000000000..c011313ab69f
--- /dev/null
+++ b/sys-boot/os-prober/os-prober-1.56.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/os-prober-1.56.ebuild,v 1.1 2012/10/14 19:10:30 abcd Exp $
+
+EAPI=4
+
+#inherit eutils multilib toolchain-funcs
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to detect other OSs on a set of drives"
+HOMEPAGE="http://packages.debian.org/source/sid/os-prober"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ # use default GNU rules
+ rm Makefile
+}
+
+src_compile() {
+ tc-export CC
+ emake newns
+}
+
+src_install() {
+ dobin os-prober linux-boot-prober
+
+ # Note: as no shared libraries are installed, /usr/lib is correct
+ exeinto /usr/lib/os-prober
+ doexe newns
+
+ insinto /usr/share/os-prober
+ doins common.sh
+
+ keepdir /var/lib/os-prober
+
+ local debarch=${ARCH%-*} dir
+
+ case ${debarch} in
+ amd64) debarch=x86 ;;
+ ppc|ppc64) debarch=powerpc ;;
+ esac
+
+ for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
+ exeinto /usr/lib/$dir
+ doexe $dir/common/*
+ if [[ -d $dir/$debarch ]]; then
+ doexe $dir/$debarch/*
+ fi
+ done
+
+ if use amd64 || use x86; then
+ exeinto /usr/lib/os-probes/mounted
+ doexe os-probes/mounted/powerpc/20macosx
+ fi
+
+ dodoc README TODO debian/changelog
+}
+
+pkg_postinst() {
+ elog "If you intend for os-prober to detect versions of Windows installed on"
+ elog "NTFS-formatted partitions, your system must be capable of reading the"
+ elog "NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g"
+}