summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-07-05 09:59:26 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-07-05 09:59:26 +0000
commit008d7ed924b587ee6166e68c538c7f81f18540d3 (patch)
tree805b85e010e33e109f230d39ccc1c91f71d5cf45 /sys-boot/grub
parentBug #209792, use "vbladed?" and a shorter chunk of arguments to match more pr... (diff)
downloadgentoo-2-008d7ed924b587ee6166e68c538c7f81f18540d3.tar.gz
gentoo-2-008d7ed924b587ee6166e68c538c7f81f18540d3.tar.bz2
gentoo-2-008d7ed924b587ee6166e68c538c7f81f18540d3.zip
Support for non-interactive from wolf31o2 per bug #228677.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc4-00103-g1beee8d x86_64)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog6
-rw-r--r--sys-boot/grub/files/grub.conf.gentoo2
-rw-r--r--sys-boot/grub/grub-0.97-r6.ebuild20
3 files changed, 19 insertions, 9 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index d79eed1efca2..2192cf1e1654 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.93 2008/06/04 20:43:51 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.94 2008/07/05 09:59:26 robbat2 Exp $
+
+ 05 Jul 2008; Robin H. Johnson <robbat2@gentoo.org> files/grub.conf.gentoo,
+ grub-0.97-r6.ebuild:
+ Support for non-interactive from wolf31o2 per bug #228677.
*grub-0.97-r6 (04 Jun 2008)
diff --git a/sys-boot/grub/files/grub.conf.gentoo b/sys-boot/grub/files/grub.conf.gentoo
index 451ec6b2c60f..0027099e492a 100644
--- a/sys-boot/grub/files/grub.conf.gentoo
+++ b/sys-boot/grub/files/grub.conf.gentoo
@@ -10,7 +10,7 @@ timeout 30
#title Gentoo Linux 2.6.24-r5
#root (hd0,0)
-#kernel /boot/kernel-genkernel-x86-2.6.24-gentoo-r5 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sda3 udev
+#kernel /boot/kernel-genkernel-x86-2.6.24-gentoo-r5 root=/dev/ram0 real_root=/dev/sda3
#initrd /boot/initramfs-genkernel-x86-2.6.24-gentoo-r5
# vim:ft=conf:
diff --git a/sys-boot/grub/grub-0.97-r6.ebuild b/sys-boot/grub/grub-0.97-r6.ebuild
index 40d4f048fd07..8bd46424440a 100644
--- a/sys-boot/grub/grub-0.97-r6.ebuild
+++ b/sys-boot/grub/grub-0.97-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r6.ebuild,v 1.2 2008/06/04 20:44:15 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r6.ebuild,v 1.3 2008/07/05 09:59:26 robbat2 Exp $
# XXX: we need to review menu.lst vs grub.conf handling. We've been converting
# all systems to grub.conf (and symlinking menu.lst to grub.conf), but
@@ -221,15 +221,21 @@ setup_boot_dir() {
}
pkg_postinst() {
- [[ -n ${DONT_MOUNT_BOOT} ]] && return 0
- setup_boot_dir "${ROOT}"/boot
- einfo "To install grub files to another device (like a usb stick), just run:"
- einfo " emerge --config =${PF}"
+ [[ -n ${DONT_MOUNT_BOOT} ]] || setup_boot_dir "${ROOT}"/boot
+ elog "To install grub files to another device (like a usb stick), just run:"
+ elog " emerge --config =${PF}"
+ elog "Alternately, you can use GRUB_ALT_INSTALLDIR=/path/to/use to tell"
+ elog "grub where to install in a non-interactive way."
+
}
pkg_config() {
local dir
- einfo "Enter the directory where you want to setup grub:"
- read dir
+ if [ ! -d "${GRUB_ALT_INSTALLDIR}" ]; then
+ einfo "Enter the directory where you want to setup grub:"
+ read dir
+ else
+ dir="${GRUB_ALT_INSTALLDIR}"
+ fi
setup_boot_dir "${dir}"
}