summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2012-03-11 11:44:45 +0000
committerWolfram Schlich <wschlich@gentoo.org>2012-03-11 11:44:45 +0000
commitd081cdb84fc774482a76ac1dc62cf4e21dc3e169 (patch)
tree178b8f2d8ad1ccd70c3a99ec19d00e2f0a93d855 /sys-block
parentrespect LDFLAGS wrt bug #339110 (diff)
downloadgentoo-2-d081cdb84fc774482a76ac1dc62cf4e21dc3e169.tar.gz
gentoo-2-d081cdb84fc774482a76ac1dc62cf4e21dc3e169.tar.bz2
gentoo-2-d081cdb84fc774482a76ac1dc62cf4e21dc3e169.zip
removed old version
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/spindown/ChangeLog6
-rw-r--r--sys-block/spindown/files/spindownd.confd14
-rw-r--r--sys-block/spindown/files/spindownd.initd61
-rw-r--r--sys-block/spindown/spindown-0.4.0-r2.ebuild46
4 files changed, 5 insertions, 122 deletions
diff --git a/sys-block/spindown/ChangeLog b/sys-block/spindown/ChangeLog
index 2186e3f193c8..0565e6d2f077 100644
--- a/sys-block/spindown/ChangeLog
+++ b/sys-block/spindown/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-block/spindown
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/spindown/ChangeLog,v 1.8 2012/03/11 11:38:51 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/spindown/ChangeLog,v 1.9 2012/03/11 11:44:45 wschlich Exp $
+
+ 11 Mar 2012; Wolfram Schlich <wschlich@gentoo.org> -spindown-0.4.0-r2.ebuild,
+ -files/spindownd.confd, -files/spindownd.initd:
+ removed old version
*spindown-0.4.0-r4 (11 Mar 2012)
diff --git a/sys-block/spindown/files/spindownd.confd b/sys-block/spindown/files/spindownd.confd
deleted file mode 100644
index b3a3b91266a9..000000000000
--- a/sys-block/spindown/files/spindownd.confd
+++ /dev/null
@@ -1,14 +0,0 @@
-# spindownd config file
-# default: /etc/spindown.conf
-#SPINDOWND_CFG=/etc/spindown.conf
-
-# spindownd lockfile
-# default: /var/lock/spindown.lock
-#SPINDOWND_LOCK=/var/lock/spindown.lock
-
-# spindownd fifo
-# default: /var/run/spindown.fifo
-#SPINDOWND_FIFO=/var/run/spindown.fifo
-
-# extra options for spindownd
-#SPINDOWND_OPTS="" # you must NOT use -c or -f here!
diff --git a/sys-block/spindown/files/spindownd.initd b/sys-block/spindown/files/spindownd.initd
deleted file mode 100644
index ed2e04ad0b97..000000000000
--- a/sys-block/spindown/files/spindownd.initd
+++ /dev/null
@@ -1,61 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-SPINDOWND_BIN="/usr/sbin/spindownd"
-SPINDOWND_CFG=${SPINDOWND_CFG:-/etc/spindown.conf}
-SPINDOWND_LOCK=${SPINDOWND_LOCK:-/var/lock/spindown.lock}
-SPINDOWND_FIFO=${SPINDOWND_FIFO:-/var/run/spindown.fifo}
-
-extra_started_commands="reload"
-
-depend() {
- need localmount
- after bootmisc
-}
-
-checkconfig() {
- # check for config file
- if [ ! -e "${SPINDOWND_CFG}" ]; then
- eerror
- eerror "The spindownd config file (${SPINDOWND_CFG})"
- eerror "is missing!"
- eerror
- return 1
- fi
- # check for leftover lockfile
- if [ -f "${SPINDOWND_LOCK}" ]; then
- ewarn
- ewarn "The spindownd lockfile (${SPINDOWND_LOCK})"
- ewarn "exists although the service is not marked as started."
- ewarn "Will remove the lockfile and start the service in 10s"
- ewarn "if not interrupted..."
- ewarn
- sleep 10
- if ! rm -f "${SPINDOWND_LOCK}"; then
- eerror "Failed to remove the spindownd lockfile (${SPINDOWND_LOCK})"
- return 1
- fi
- fi
-}
-
-start() {
- checkconfig || return 1
- ebegin "Starting spindownd"
- start-stop-daemon --start --exec ${SPINDOWND_BIN} \
- -- -c ${SPINDOWND_CFG} -f ${SPINDOWND_FIFO} ${SPINDOWND_OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping spindownd"
- start-stop-daemon --stop --exec ${SPINDOWND_BIN}
- eend $?
-}
-
-reload() {
- ebegin "Reloading spindownd configuration"
- start-stop-daemon --exec ${SPINDOWND_BIN} \
- --signal HUP
- eend $?
-}
diff --git a/sys-block/spindown/spindown-0.4.0-r2.ebuild b/sys-block/spindown/spindown-0.4.0-r2.ebuild
deleted file mode 100644
index fd61f2da335c..000000000000
--- a/sys-block/spindown/spindown-0.4.0-r2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/spindown/spindown-0.4.0-r2.ebuild,v 1.1 2012/01/01 01:04:34 idl0r Exp $
-
-inherit eutils
-
-DESCRIPTION="Spindown is a daemon that can spin down idle disks"
-HOMEPAGE="http://code.google.com/p/spindown"
-SRC_URI="http://spindown.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}
- sys-apps/sg3_utils"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-CFLAGS.patch
-}
-
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- insinto /etc
- newins spindown.conf.example spindown.conf
- newinitd "${FILESDIR}"/spindownd.initd spindownd
- newconfd "${FILESDIR}"/spindownd.confd spindownd
- dosbin spindownd
- dodoc CHANGELOG README TODO spindown.conf.example
-}
-
-pkg_postinst() {
- elog "Before starting spindownd the first time"
- elog "you should modify /etc/spindown.conf"
- elog
- elog "To start spindownd by default"
- elog "you should add it to the default runlevel:"
- elog " rc-update add spindownd default"
-}