summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-04-06 17:47:08 +0000
committerHanno Böck <hanno@gentoo.org>2008-04-06 17:47:08 +0000
commitf5b4e091f43af8499c1b842e9a8d01bbcc6e2a22 (patch)
tree592e7799edd5d08da42e5aec14ad5fa2d3514da7 /sys-auth
parentfix LICENSE, bug #204327 (diff)
downloadgentoo-2-f5b4e091f43af8499c1b842e9a8d01bbcc6e2a22.tar.gz
gentoo-2-f5b4e091f43af8499c1b842e9a8d01bbcc6e2a22.tar.bz2
gentoo-2-f5b4e091f43af8499c1b842e9a8d01bbcc6e2a22.zip
pam_mount update
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-0.35.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index b909284ec93a..6b5a923249da 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.12 2008/03/04 21:10:07 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.13 2008/04/06 17:47:08 hanno Exp $
+
+*pam_mount-0.35 (06 Apr 2008)
+
+ 06 Apr 2008; Hanno Boeck <hanno@gentoo.org> +pam_mount-0.35.ebuild:
+ Version bump.
04 Mar 2008; Hanno Boeck <hanno@gentoo.org> pam_mount-0.32.ebuild:
Add pkgconfig dep and remove deprecated luks-dep.
diff --git a/sys-auth/pam_mount/pam_mount-0.35.ebuild b/sys-auth/pam_mount/pam_mount-0.35.ebuild
new file mode 100644
index 000000000000..9aa89b007078
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-0.35.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-0.35.ebuild,v 1.1 2008/04/06 17:47:08 hanno Exp $
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.15
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.15
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.0.5
+ sys-process/lsof"
+
+src_compile() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}