summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-06-11 19:36:15 +0000
committerHanno Böck <hanno@gentoo.org>2008-06-11 19:36:15 +0000
commite7b8be272f0b4284304911a40f1a9801cad983f7 (patch)
tree956cb7055335556d939c1b2443d300c3389d6e03 /sys-auth
parentlibhx bump (diff)
downloadgentoo-2-e7b8be272f0b4284304911a40f1a9801cad983f7.tar.gz
gentoo-2-e7b8be272f0b4284304911a40f1a9801cad983f7.tar.bz2
gentoo-2-e7b8be272f0b4284304911a40f1a9801cad983f7.zip
pam_mount bump
(Portage version: 2.1.5.4)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-0.40.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 99892bc1d95e..eefb629ff741 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.16 2008/06/02 14:35:45 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.17 2008/06/11 19:36:15 hanno Exp $
+
+*pam_mount-0.40 (11 Jun 2008)
+
+ 11 Jun 2008; Hanno Boeck <hanno@gentoo.org> +pam_mount-0.40.ebuild:
+ Version bump.
*pam_mount-0.39 (02 Jun 2008)
diff --git a/sys-auth/pam_mount/pam_mount-0.40.ebuild b/sys-auth/pam_mount/pam_mount-0.40.ebuild
new file mode 100644
index 000000000000..5921b7b4b70a
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-0.40.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-0.40.ebuild,v 1.1 2008/06/11 19:36:15 hanno Exp $
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.18
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.18
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.0.5
+ sys-process/lsof"
+
+src_compile() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}