summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2007-04-11 16:59:35 +0000
committerTony Vroon <chainsaw@gentoo.org>2007-04-11 16:59:35 +0000
commit84e55b7a608840ed4aeea29cba5891cc4474a3d1 (patch)
tree1d2d1b36d5a0199048b7e3ecfb6c2958ce397882 /sys-auth
parentStable on alpha wrt bug 171797 (diff)
downloadgentoo-2-84e55b7a608840ed4aeea29cba5891cc4474a3d1.tar.gz
gentoo-2-84e55b7a608840ed4aeea29cba5891cc4474a3d1.tar.bz2
gentoo-2-84e55b7a608840ed4aeea29cba5891cc4474a3d1.zip
Version bump, closes bug #172837. This release requires UINPUT support in the kernel and features USB-level debugging. It should also keep the fingerprint reader from heating up as much as it did on 0.2.2
(Portage version: 2.1.2.3)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/thinkfinger/ChangeLog9
-rw-r--r--sys-auth/thinkfinger/files/digest-thinkfinger-0.33
-rw-r--r--sys-auth/thinkfinger/thinkfinger-0.3.ebuild57
3 files changed, 68 insertions, 1 deletions
diff --git a/sys-auth/thinkfinger/ChangeLog b/sys-auth/thinkfinger/ChangeLog
index 5f31735af655..9ce3e92bc7a9 100644
--- a/sys-auth/thinkfinger/ChangeLog
+++ b/sys-auth/thinkfinger/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/thinkfinger
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/thinkfinger/ChangeLog,v 1.4 2007/02/27 14:58:09 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/thinkfinger/ChangeLog,v 1.5 2007/04/11 16:59:35 chainsaw Exp $
+
+*thinkfinger-0.3 (11 Apr 2007)
+
+ 11 Apr 2007; Tony Vroon <chainsaw@gentoo.org> +thinkfinger-0.3.ebuild:
+ Version bump, closes bug #172837. This release requires UINPUT support in
+ the kernel and features USB-level debugging. It should also keep the
+ fingerprint reader from heating up as much as it did on 0.2.2
27 Feb 2007; Piotr Jaroszyński <peper@gentoo.org>
thinkfinger-0.2.2-r1.ebuild:
diff --git a/sys-auth/thinkfinger/files/digest-thinkfinger-0.3 b/sys-auth/thinkfinger/files/digest-thinkfinger-0.3
new file mode 100644
index 000000000000..7f5c6403227b
--- /dev/null
+++ b/sys-auth/thinkfinger/files/digest-thinkfinger-0.3
@@ -0,0 +1,3 @@
+MD5 588565233bcbea5ff0a7f5314361c380 thinkfinger-0.3.tar.gz 372053
+RMD160 7a83e7234bc6687f581df3b68b92cc06bf5b24cb thinkfinger-0.3.tar.gz 372053
+SHA256 9741ae205aadc9f576be73c382596266300e709371e72574a86e339ebf978f4b thinkfinger-0.3.tar.gz 372053
diff --git a/sys-auth/thinkfinger/thinkfinger-0.3.ebuild b/sys-auth/thinkfinger/thinkfinger-0.3.ebuild
new file mode 100644
index 000000000000..ff7bd492d447
--- /dev/null
+++ b/sys-auth/thinkfinger/thinkfinger-0.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/thinkfinger/thinkfinger-0.3.ebuild,v 1.1 2007/04/11 16:59:35 chainsaw Exp $
+
+inherit pam linux-info
+
+DESCRIPTION="Support for the UPEK/SGS Thomson Microelectronics fingerprint reader, often seen in Thinkpads"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://thinkfinger.sourceforge.net/"
+
+RDEPEND=">=dev-libs/libusb-0.1.12
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ >=dev-util/pkgconfig-0.9.0"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug pam"
+
+src_compile() {
+ if useq pam; then
+ CONFIG_CHECK="INPUT_UINPUT"
+ ERROR_CFG="Your kernel needs uinput for the pam module to work"
+ check_extra_config
+ fi
+ econf \
+ $(use_enable pam) \
+ $(use_enable debug usb-debug) \
+ "--with-securedir=$(getpam_mod_dir)" \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ keepdir /etc/pam_thinkfinger
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ elog "Use tf-tool --acquire to take a finger print"
+ elog "tf-tool will write the finger print file to /tmp/test.bir"
+ elog ""
+ if useq pam ; then
+ elog "To add a fingerprint to PAM, use tf-tool --add-user USERNAME"
+ elog ""
+ elog "Add the following to /etc/pam.d/system-auth after pam_env.so"
+ elog "auth sufficient pam_thinkfinger.so"
+ elog ""
+ elog "Your system-auth should look similar to:"
+ elog "auth required pam_env.so"
+ elog "auth sufficient pam_thinkfinger.so"
+ elog "auth sufficient pam_unix.so try_first_pass likeauth nullok"
+ fi
+}