summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-01-20 06:08:12 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-01-20 06:08:12 +0000
commit84c1923926d27237c943c1196fd0096bd296af6d (patch)
tree84c1e045c3713b7aaacdc7e67e5c06e0653bbd16 /sys-auth
parentupdate keystone for bug 498510 (diff)
downloadgentoo-2-84c1923926d27237c943c1196fd0096bd296af6d.tar.gz
gentoo-2-84c1923926d27237c943c1196fd0096bd296af6d.tar.bz2
gentoo-2-84c1923926d27237c943c1196fd0096bd296af6d.zip
updated init scripts :D
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/keystone/ChangeLog9
-rw-r--r--sys-auth/keystone/files/keystone.confd6
-rw-r--r--sys-auth/keystone/files/keystone.initd59
-rw-r--r--sys-auth/keystone/files/keystone.initd.havana57
-rw-r--r--sys-auth/keystone/keystone-2013.1.4-r2.ebuild5
-rw-r--r--sys-auth/keystone/keystone-2013.1.9999.ebuild5
-rw-r--r--sys-auth/keystone/keystone-2013.2.1-r1.ebuild7
-rw-r--r--sys-auth/keystone/keystone-2013.2.9999.ebuild7
-rw-r--r--sys-auth/keystone/keystone-9999.ebuild7
9 files changed, 34 insertions, 128 deletions
diff --git a/sys-auth/keystone/ChangeLog b/sys-auth/keystone/ChangeLog
index 77ffcd2fe535..cad16fa8259c 100644
--- a/sys-auth/keystone/ChangeLog
+++ b/sys-auth/keystone/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/keystone
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.57 2014/01/20 05:58:14 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.58 2014/01/20 06:08:12 prometheanfire Exp $
+
+ 20 Jan 2014; Matthew Thode <prometheanfire@gentoo.org>
+ -files/keystone.initd.havana, files/keystone.confd, files/keystone.initd,
+ keystone-2013.1.4-r2.ebuild, keystone-2013.1.9999.ebuild,
+ keystone-2013.2.1-r1.ebuild, keystone-2013.2.9999.ebuild,
+ keystone-9999.ebuild:
+ updated init scripts :D
*keystone-2013.2.1-r1 (20 Jan 2014)
*keystone-2013.1.4-r2 (20 Jan 2014)
diff --git a/sys-auth/keystone/files/keystone.confd b/sys-auth/keystone/files/keystone.confd
index 670ec22b3757..669fa0a7ad11 100644
--- a/sys-auth/keystone/files/keystone.confd
+++ b/sys-auth/keystone/files/keystone.confd
@@ -1,3 +1,3 @@
-CONFIG_FILE=/etc/keystone/keystone.conf
-LOG_FILE=/var/log/keystone/keystone.log
-PID_PATH=/var/run/keystone
+#KEYSTONE_CONF=/etc/keystone/keystone.conf
+#KEYSTONE_USER=keystone
+KEYSTONE_ARGS="--logfile /var/log/keystone/keystone.log"
diff --git a/sys-auth/keystone/files/keystone.initd b/sys-auth/keystone/files/keystone.initd
index f7c4acd01626..c6eca47e2355 100644
--- a/sys-auth/keystone/files/keystone.initd
+++ b/sys-auth/keystone/files/keystone.initd
@@ -1,56 +1,17 @@
#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/files/keystone.initd,v 1.3 2013/11/18 03:24:30 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/files/keystone.initd,v 1.4 2014/01/20 06:08:12 prometheanfire Exp $
-depend() {
- need net
-}
-
-BASENAME=$(echo $SVCNAME | cut -d '-' -f 1)
+description="Starts both the service and administrative APIs in a single process to provide catalog, authorization, and authentication services for OpenStack"
-checkconfig() {
- if [ ! -r /etc/conf.d/$BASENAME ]; then
- eerror "No keystone service confd file found: /etc/conf.d/$BASENAME)"
- return 1
- fi
- . /etc/conf.d/$BASENAME
-
- if [ ! -r ${CONFIG_FILE} ]; then
- eerror "No keystone config file found: ${CONFIG_FILE})"
- return 1
- fi
-
- return 0
-}
+command=/usr/bin/keystone-all
+pidfile=/var/run/keystone.pid
+required_files="${KEYSTONE_CONF:-/etc/keystone/keystone.conf}"
+start_stop_daemon_args="--background --make-pidfile --user ${KEYSTONE_USER:-keystone}"
+command_args="${KEYSTONE_ARGS}"
-start() {
- checkconfig || return $?
- . /etc/conf.d/$BASENAME
-
- if [ ! -d ${PID_PATH} ]; then
- mkdir ${PID_PATH}
- fi
-
- ebegin "Starting ${SVCNAME}"
-
- start-stop-daemon --start --quiet --make-pidfile --pidfile "${PID_PATH}/${SVCNAME}.pid" --exec /usr/bin/${SVCNAME}-all --background -- --config-file=${CONFIG_FILE} --log-file=${LOG_FILE}
-
- eend $? "Failed to start ${SVCNAME}"
-}
-
-stop() {
- checkconfig || return $?
- . /etc/conf.d/$BASENAME
-
- ebegin "Stopping ${SVCNAME}"
-
- start-stop-daemon --stop --pidfile "${PID_PATH}/${SVCNAME}.pid" \
- --exec /usr/bin/${SVCNAME}-all
- eend $? "Failed to stop ${SVCNAME}"
+depend() {
+ need net
}
-
-#restart() {
-#
-#}
diff --git a/sys-auth/keystone/files/keystone.initd.havana b/sys-auth/keystone/files/keystone.initd.havana
deleted file mode 100644
index 44be4b82f124..000000000000
--- a/sys-auth/keystone/files/keystone.initd.havana
+++ /dev/null
@@ -1,57 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/files/keystone.initd.havana,v 1.1 2013/12/13 17:31:30 prometheanfire Exp $
-
-depend() {
- need net
-}
-
-BASENAME=$(echo $SVCNAME | cut -d '-' -f 1)
-
-checkconfig() {
- if [ ! -r /etc/conf.d/$BASENAME ]; then
- eerror "No keystone service confd file found: /etc/conf.d/$BASENAME)"
- return 1
- fi
- . /etc/conf.d/$BASENAME
-
- if [ ! -r ${CONFIG_FILE} ]; then
- eerror "No keystone config file found: ${CONFIG_FILE})"
- return 1
- fi
-
- return 0
-}
-
-
-start() {
- checkconfig || return $?
- . /etc/conf.d/$BASENAME
-
- if [ ! -d ${PID_PATH} ]; then
- mkdir ${PID_PATH}
- fi
-
- ebegin "Starting ${SVCNAME}"
-
- start-stop-daemon --start --quiet --user keystone \
- --make-pidfile --pidfile "${PID_PATH}/${SVCNAME}.pid" --exec /usr/bin/${SVCNAME}-all --background -- --config-file=${CONFIG_FILE} --log-file=${LOG_FILE}
-
- eend $? "Failed to start ${SVCNAME}"
-}
-
-stop() {
- checkconfig || return $?
- . /etc/conf.d/$BASENAME
-
- ebegin "Stopping ${SVCNAME}"
-
- start-stop-daemon --stop --pidfile "${PID_PATH}/${SVCNAME}.pid" \
- --exec /usr/bin/${SVCNAME}-all
- eend $? "Failed to stop ${SVCNAME}"
-}
-
-#restart() {
-#
-#}
diff --git a/sys-auth/keystone/keystone-2013.1.4-r2.ebuild b/sys-auth/keystone/keystone-2013.1.4-r2.ebuild
index 15c1edbefefa..41189ad0e4a6 100644
--- a/sys-auth/keystone/keystone-2013.1.4-r2.ebuild
+++ b/sys-auth/keystone/keystone-2013.1.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.1.4-r2.ebuild,v 1.1 2014/01/20 05:58:14 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.1.4-r2.ebuild,v 1.2 2014/01/20 06:08:12 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -82,8 +82,7 @@ python_install() {
newinitd "${FILESDIR}/keystone.initd" keystone
diropts -m 0750
- dodir /var/log/keystone /etc/keystone
- keepdir /etc/keystone
+ keepdir /etc/keystone /var/log/keystone
insinto /etc/keystone
doins etc/keystone.conf.sample etc/logging.conf.sample
doins etc/default_catalog.templates etc/policy.json
diff --git a/sys-auth/keystone/keystone-2013.1.9999.ebuild b/sys-auth/keystone/keystone-2013.1.9999.ebuild
index e87e8c0362b4..cc8ef4e2e284 100644
--- a/sys-auth/keystone/keystone-2013.1.9999.ebuild
+++ b/sys-auth/keystone/keystone-2013.1.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.1.9999.ebuild,v 1.9 2014/01/20 05:58:14 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.1.9999.ebuild,v 1.10 2014/01/20 06:08:12 prometheanfire Exp $
EAPI=5
#test restricted becaues of bad requirements given (old webob for instance)
@@ -82,8 +82,7 @@ python_install() {
newinitd "${FILESDIR}/keystone.initd" keystone
diropts -m 0750
- dodir /var/log/keystone /etc/keystone
- keepdir /etc/keystone
+ keepdir /etc/keystone /var/log/keystone
insinto /etc/keystone
doins etc/keystone.conf.sample etc/logging.conf.sample
doins etc/default_catalog.templates etc/policy.json
diff --git a/sys-auth/keystone/keystone-2013.2.1-r1.ebuild b/sys-auth/keystone/keystone-2013.2.1-r1.ebuild
index 73018da07da3..a072f2647111 100644
--- a/sys-auth/keystone/keystone-2013.2.1-r1.ebuild
+++ b/sys-auth/keystone/keystone-2013.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.2.1-r1.ebuild,v 1.1 2014/01/20 05:58:14 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.2.1-r1.ebuild,v 1.2 2014/01/20 06:08:12 prometheanfire Exp $
EAPI=5
@@ -98,14 +98,13 @@ python_install() {
newinitd "${FILESDIR}/keystone.initd" keystone
diropts -m 0750
- dodir /var/log/keystone /etc/keystone
- keepdir /etc/keystone
+ keepdir /etc/keystone /var/log/keystone
insinto /etc/keystone
doins etc/keystone.conf.sample etc/logging.conf.sample
doins etc/default_catalog.templates etc/policy.json
doins etc/policy.v3cloudsample.json etc/keystone-paste.ini
- fowners keystone:keystone /var/log/keystone /etc/keystone
+ fowners keystone:keystone /etc/keystone /var/log/keystone
}
pkg_postinst() {
diff --git a/sys-auth/keystone/keystone-2013.2.9999.ebuild b/sys-auth/keystone/keystone-2013.2.9999.ebuild
index 157787829944..405d807fb031 100644
--- a/sys-auth/keystone/keystone-2013.2.9999.ebuild
+++ b/sys-auth/keystone/keystone-2013.2.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.2.9999.ebuild,v 1.9 2014/01/20 05:58:13 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.2.9999.ebuild,v 1.10 2014/01/20 06:08:12 prometheanfire Exp $
EAPI=5
@@ -100,14 +100,13 @@ python_install() {
newinitd "${FILESDIR}/keystone.initd" keystone
diropts -m 0750
- dodir /var/log/keystone /etc/keystone
- keepdir /etc/keystone
+ keepdir /etc/keystone /var/log/keystone
insinto /etc/keystone
doins etc/keystone.conf.sample etc/logging.conf.sample
doins etc/default_catalog.templates etc/policy.json
doins etc/policy.v3cloudsample.json etc/keystone-paste.ini
- fowners keystone:keystone /var/log/keystone /etc/keystone
+ fowners keystone:keystone /etc/keystone /var/log/keystone
}
pkg_postinst() {
diff --git a/sys-auth/keystone/keystone-9999.ebuild b/sys-auth/keystone/keystone-9999.ebuild
index e6314486675b..d7d253fc6b6b 100644
--- a/sys-auth/keystone/keystone-9999.ebuild
+++ b/sys-auth/keystone/keystone-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-9999.ebuild,v 1.13 2014/01/20 05:58:13 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-9999.ebuild,v 1.14 2014/01/20 06:08:12 prometheanfire Exp $
EAPI=5
@@ -100,14 +100,13 @@ python_install() {
newinitd "${FILESDIR}/keystone.initd" keystone
diropts -m 0750
- dodir /var/log/keystone /etc/keystone
- keepdir /etc/keystone
+ keepdir /etc/keystone /var/log/keystone
insinto /etc/keystone
doins etc/keystone.conf.sample etc/logging.conf.sample
doins etc/default_catalog.templates etc/policy.json
doins etc/policy.v3cloudsample.json etc/keystone-paste.ini
- fowners keystone:keystone /var/log/keystone /etc/keystone
+ fowners keystone:keystone /etc/keystone /var/log/keystone
}
pkg_postinst() {