summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-09-19 02:40:41 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-09-19 02:40:41 +0000
commit5c5268dce346cda325b249c5a7607665b9550b5f (patch)
tree4b4de739dd406932ff6bb70a595d20c9a59f596c /sys-auth
parentBug #189669, fix non-deterministic inclusion of libaudit. USE=audit is masked... (diff)
downloadgentoo-2-5c5268dce346cda325b249c5a7607665b9550b5f.tar.gz
gentoo-2-5c5268dce346cda325b249c5a7607665b9550b5f.tar.bz2
gentoo-2-5c5268dce346cda325b249c5a7607665b9550b5f.zip
add latest ConsoleKit from Gentopia
(Portage version: 2.1.3.9)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/consolekit/ChangeLog7
-rw-r--r--sys-auth/consolekit/consolekit-0.2.3.ebuild61
-rw-r--r--sys-auth/consolekit/files/digest-consolekit-0.2.33
3 files changed, 70 insertions, 1 deletions
diff --git a/sys-auth/consolekit/ChangeLog b/sys-auth/consolekit/ChangeLog
index 770b10a82ab0..d9d07e63acea 100644
--- a/sys-auth/consolekit/ChangeLog
+++ b/sys-auth/consolekit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/consolekit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.20 2007/09/06 20:49:29 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.21 2007/09/19 02:40:41 cardoe Exp $
+
+*consolekit-0.2.3 (19 Sep 2007)
+
+ 19 Sep 2007; Doug Goldstein <cardoe@gentoo.org> +consolekit-0.2.3.ebuild:
+ add latest ConsoleKit from Gentopia
06 Sep 2007; Doug Goldstein <cardoe@gentoo.org>
-files/consolekit-0.2.0-gdk-to-x11.patch,
diff --git a/sys-auth/consolekit/consolekit-0.2.3.ebuild b/sys-auth/consolekit/consolekit-0.2.3.ebuild
new file mode 100644
index 000000000000..c246f592216f
--- /dev/null
+++ b/sys-auth/consolekit/consolekit-0.2.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/consolekit-0.2.3.ebuild,v 1.1 2007/09/19 02:40:41 cardoe Exp $
+
+inherit eutils autotools multilib pam
+
+MY_PN="ConsoleKit"
+MY_PV="${PV//_pre*/}"
+
+DESCRIPTION="Framework for defining and tracking users, login sessions and seats."
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/ConsoleKit"
+SRC_URI="http://people.freedesktop.org/~mccann/dist/${MY_PN}-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="debug pam"
+
+# Not parallel make safe
+MAKEOPTS="$MAKEOPTS -j1"
+
+RDEPEND=">=dev-libs/glib-2.7
+ >=dev-libs/dbus-glib-0.61
+ >=x11-libs/libX11-1.0.0
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable pam pam-module) \
+ --with-pam-module-dir=/$(getpam_mod_dir) \
+ --with-pid-file=/var/run/consolekit.pid \
+ --with-dbus-services=/usr/share/dbus-1/services/ \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ #crappy Redhat init script
+ rm -f "${D}/etc/rc.d/init.d/ConsoleKit"
+ rm -r "${D}/etc/rc.d/"
+
+ #Portage barfs on .la files
+ rm -f "${D}/$(get_libdir)/security/pam_ck_connector.la"
+
+ # Gentoo style init script
+ newinitd "${FILESDIR}"/${PN}-0.1.rc consolekit
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "You need to restart ConsoleKit to get the new features."
+ ewarn "This can be done with /etc/init.d/consolekit restart"
+ ewarn "but make sure you do this and then restart your session"
+ ewarn "otherwise you will get access denied for certain actions"
+ ewarn
+}
diff --git a/sys-auth/consolekit/files/digest-consolekit-0.2.3 b/sys-auth/consolekit/files/digest-consolekit-0.2.3
new file mode 100644
index 000000000000..9fedd7f9cb12
--- /dev/null
+++ b/sys-auth/consolekit/files/digest-consolekit-0.2.3
@@ -0,0 +1,3 @@
+MD5 dc4b3194ec583b03747ffc909a5571da ConsoleKit-0.2.3.tar.gz 468591
+RMD160 457c1a08e9d2fc789537127c9d069088588c035b ConsoleKit-0.2.3.tar.gz 468591
+SHA256 1b9571f958d3c3be464a6261947c6f817948e878166bca4616f4ac3ac9f02e47 ConsoleKit-0.2.3.tar.gz 468591