summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-08 20:01:48 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-08 20:01:48 +0000
commit53b4d4c6e921c818fc9bed06d19e6010ef724a7e (patch)
tree4a6fd415e08688c4ac9bfdf7ca052ae1a280d250 /sys-auth
parentDrop KDE 4.2.0 (diff)
downloadgentoo-2-53b4d4c6e921c818fc9bed06d19e6010ef724a7e.tar.gz
gentoo-2-53b4d4c6e921c818fc9bed06d19e6010ef724a7e.tar.bz2
gentoo-2-53b4d4c6e921c818fc9bed06d19e6010ef724a7e.zip
Do not add version info to pam module #261598 and fix up pam.d files #261677 (both by Diego E. Pettenò).
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_bioapi/ChangeLog11
-rw-r--r--sys-auth/pam_bioapi/pam_bioapi-0.4.0-r1.ebuild47
2 files changed, 56 insertions, 2 deletions
diff --git a/sys-auth/pam_bioapi/ChangeLog b/sys-auth/pam_bioapi/ChangeLog
index 0c87dc008740..2a7720891d57 100644
--- a/sys-auth/pam_bioapi/ChangeLog
+++ b/sys-auth/pam_bioapi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/pam_bioapi
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_bioapi/ChangeLog,v 1.7 2008/11/30 16:16:29 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_bioapi/ChangeLog,v 1.8 2009/03/08 20:01:48 vapier Exp $
+
+*pam_bioapi-0.4.0-r1 (08 Mar 2009)
+
+ 08 Mar 2009; Mike Frysinger <vapier@gentoo.org>
+ +pam_bioapi-0.4.0-r1.ebuild:
+ Do not add version info to pam module #261598 and fix up pam.d files
+ #261677 (both by Diego E. Pettenò).
30 Nov 2008; Markus Meier <maekke@gentoo.org> pam_bioapi-0.4.0.ebuild:
x86 stable, bug #249330
diff --git a/sys-auth/pam_bioapi/pam_bioapi-0.4.0-r1.ebuild b/sys-auth/pam_bioapi/pam_bioapi-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..bb068a802bad
--- /dev/null
+++ b/sys-auth/pam_bioapi/pam_bioapi-0.4.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_bioapi/pam_bioapi-0.4.0-r1.ebuild,v 1.1 2009/03/08 20:01:48 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="PAM interface to bioapi package"
+HOMEPAGE="http://code.google.com/p/pam-bioapi/"
+SRC_URI="http://pam-bioapi.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-auth/bioapi
+ sys-libs/pam
+ dev-db/sqlite"
+RDEPEND="${DEPEND}
+ sys-auth/tfm-fingerprint"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-headers.patch #241322
+ sed -i \
+ -e 's/-version-info 0:4:0/-avoid-version/' \
+ libpam_bioapi/Makefile.in #261598
+ sed -i \
+ -e 's:@prefix@::' \
+ -e '/pam_unix.so/s:.*:auth include system-auth:' \
+ etc/pam.d/{bioapi_chbird,test-pam_bioapi}.in #261598
+}
+
+src_compile() {
+ econf --sbindir=/sbin || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/security "${D}"/$(get_libdir)/ || die
+ rm -f "${D}"/$(get_libdir)/security/*.la
+}