summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-11-20 00:28:32 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-11-20 00:28:32 +0000
commit3495befde264ce032b3d305fe29fdd41818038a4 (patch)
tree9045a5a98de0de9a8dd9c312ac8530820c3cd071 /sys-auth
parentQA - remove die from econf call; add die to do... function calls (diff)
downloadgentoo-2-3495befde264ce032b3d305fe29fdd41818038a4.tar.gz
gentoo-2-3495befde264ce032b3d305fe29fdd41818038a4.tar.bz2
gentoo-2-3495befde264ce032b3d305fe29fdd41818038a4.zip
Initial import of ykclient ebuild; ebuild by Brant Gurganus in bug #343551.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/ykclient/ChangeLog10
-rw-r--r--sys-auth/ykclient/files/ykclient-2.3-rpath.patch12
-rw-r--r--sys-auth/ykclient/metadata.xml16
-rw-r--r--sys-auth/ykclient/ykclient-2.3.ebuild32
4 files changed, 70 insertions, 0 deletions
diff --git a/sys-auth/ykclient/ChangeLog b/sys-auth/ykclient/ChangeLog
new file mode 100644
index 000000000000..caf9a26b3044
--- /dev/null
+++ b/sys-auth/ykclient/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-auth/ykclient
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykclient/ChangeLog,v 1.1 2010/11/20 00:28:32 flameeyes Exp $
+
+*ykclient-2.3 (20 Nov 2010)
+
+ 20 Nov 2010; Diego E. Pettenò <flameeyes@gentoo.org> +ykclient-2.3.ebuild,
+ +files/ykclient-2.3-rpath.patch, +metadata.xml:
+ Initial import of ykclient ebuild; ebuild by Brant Gurganus in bug #343551.
+
diff --git a/sys-auth/ykclient/files/ykclient-2.3-rpath.patch b/sys-auth/ykclient/files/ykclient-2.3-rpath.patch
new file mode 100644
index 000000000000..56e196a961c1
--- /dev/null
+++ b/sys-auth/ykclient/files/ykclient-2.3-rpath.patch
@@ -0,0 +1,12 @@
+Index: ykclient-2.3/Makefile.am
+===================================================================
+--- ykclient-2.3.orig/Makefile.am
++++ ykclient-2.3/Makefile.am
+@@ -54,7 +54,6 @@ ykclient_LDADD = ./libykclient.la
+
+ # Self tests.
+
+-AM_LDFLAGS = -no-install
+ LDADD = libykclient.la
+
+ check_PROGRAMS = selftest
diff --git a/sys-auth/ykclient/metadata.xml b/sys-auth/ykclient/metadata.xml
new file mode 100644
index 000000000000..e2fed4ff1680
--- /dev/null
+++ b/sys-auth/ykclient/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>brant@gurganus.name</email>
+ <name>Brant Gurganus</name>
+ <description>Proxied co-maintainer, assign bugs to him</description>
+ </maintainer>
+
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ <name>Diego Elio Pettenò</name>
+ <description>Proxy maintainer, CC him on bugs</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-auth/ykclient/ykclient-2.3.ebuild b/sys-auth/ykclient/ykclient-2.3.ebuild
new file mode 100644
index 000000000000..24ca736f151a
--- /dev/null
+++ b/sys-auth/ykclient/ykclient-2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykclient/ykclient-2.3.ebuild,v 1.1 2010/11/20 00:28:32 flameeyes Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="Yubico C client library"
+SRC_URI="http://yubico-c-client.googlecode.com/files/${P}.tar.gz"
+HOMEPAGE="http://code.google.com/p/yubico-c-client/"
+
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE=""
+
+RDEPEND=">=net-misc/curl-7.21.1"
+DEPEND="${RDEPEND}"
+
+# Tests require an active network connection, we don't want to run them
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-rpath.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+ find "${D}" -name '*.la' -delete || die
+}