summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-10-23 16:41:42 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-10-23 16:41:42 +0000
commit19dd976f13dbe2ad8919e501f363cd0ae479a71a (patch)
treee6a269d69132684a733fed29c90d23ac6c95238d /sys-auth/ykpers
parentRemove old vulnerable versions (diff)
downloadgentoo-2-19dd976f13dbe2ad8919e501f363cd0ae479a71a.tar.gz
gentoo-2-19dd976f13dbe2ad8919e501f363cd0ae479a71a.tar.bz2
gentoo-2-19dd976f13dbe2ad8919e501f363cd0ae479a71a.zip
Add ykpers, proxy-maintained by Brant Gurganus. Ebuild and patch from bug #342105, updated for style and repoman.
(Portage version: 2.2.0_alpha1/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/ykpers')
-rw-r--r--sys-auth/ykpers/ChangeLog11
-rw-r--r--sys-auth/ykpers/files/ykpers-1.3.4-rpath.patch12
-rw-r--r--sys-auth/ykpers/metadata.xml16
-rw-r--r--sys-auth/ykpers/ykpers-1.3.4.ebuild31
4 files changed, 70 insertions, 0 deletions
diff --git a/sys-auth/ykpers/ChangeLog b/sys-auth/ykpers/ChangeLog
new file mode 100644
index 000000000000..31ada24fb9d4
--- /dev/null
+++ b/sys-auth/ykpers/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-auth/ykpers
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ChangeLog,v 1.1 2010/10/23 16:41:42 flameeyes Exp $
+
+*ykpers-1.3.4 (23 Oct 2010)
+
+ 23 Oct 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +ykpers-1.3.4.ebuild, +files/ykpers-1.3.4-rpath.patch, +metadata.xml:
+ Add ykpers, proxy-maintained by Brant Gurganus. Ebuild and patch from bug
+ #342105, updated for style and repoman.
+
diff --git a/sys-auth/ykpers/files/ykpers-1.3.4-rpath.patch b/sys-auth/ykpers/files/ykpers-1.3.4-rpath.patch
new file mode 100644
index 000000000000..5e78e52e0daa
--- /dev/null
+++ b/sys-auth/ykpers/files/ykpers-1.3.4-rpath.patch
@@ -0,0 +1,12 @@
+Index: ykpers-1.3.4/Makefile.am
+===================================================================
+--- ykpers-1.3.4.orig/Makefile.am
++++ ykpers-1.3.4/Makefile.am
+@@ -69,7 +69,6 @@ dist_man1_MANS = ykpersonalize.1
+
+ # Self tests.
+
+-AM_LDFLAGS = -no-install
+ LDADD = ./libykpers-1.la
+
+ ctests = selftest$(EXEEXT)
diff --git a/sys-auth/ykpers/metadata.xml b/sys-auth/ykpers/metadata.xml
new file mode 100644
index 000000000000..e2fed4ff1680
--- /dev/null
+++ b/sys-auth/ykpers/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>brant@gurganus.name</email>
+ <name>Brant Gurganus</name>
+ <description>Proxied co-maintainer, assign bugs to him</description>
+ </maintainer>
+
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ <name>Diego Elio Pettenò</name>
+ <description>Proxy maintainer, CC him on bugs</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-auth/ykpers/ykpers-1.3.4.ebuild b/sys-auth/ykpers/ykpers-1.3.4.ebuild
new file mode 100644
index 000000000000..5c18a7254ffe
--- /dev/null
+++ b/sys-auth/ykpers/ykpers-1.3.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ykpers-1.3.4.ebuild,v 1.1 2010/10/23 16:41:42 flameeyes Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
+SRC_URI="http://yubikey-personalization.googlecode.com/files/${P}.tar.gz"
+HOMEPAGE="http://code.google.com/p/yubikey-personalizaiton/"
+
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE=""
+
+RDEPEND=">=sys-auth/libyubikey-1.6
+ >=dev-libs/libusb-1.0.8"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-rpath.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README doc/* || die
+ find "${D}" -name '*.la' -delete || die
+}