summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Andreetta <satya@gentoo.org>2006-04-27 11:33:46 +0000
committerChristian Andreetta <satya@gentoo.org>2006-04-27 11:33:46 +0000
commitd320cbb9de1f8a1154f3825af5d3ec35fff76f1b (patch)
tree3eb8d430b80439481fca86cad6761dc848bf5663 /sys-auth/pam_smb/pam_smb-2.0.0_rc5-r1.ebuild
parentFixing duff SHA256 digests: Bug # 131293 (diff)
downloadgentoo-2-d320cbb9de1f8a1154f3825af5d3ec35fff76f1b.tar.gz
gentoo-2-d320cbb9de1f8a1154f3825af5d3ec35fff76f1b.tar.bz2
gentoo-2-d320cbb9de1f8a1154f3825af5d3ec35fff76f1b.zip
bash>=3.1 compatibility (thanks to Beech Horn: bug #126539)
(Portage version: 2.1_pre7-r4)
Diffstat (limited to 'sys-auth/pam_smb/pam_smb-2.0.0_rc5-r1.ebuild')
-rw-r--r--sys-auth/pam_smb/pam_smb-2.0.0_rc5-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-auth/pam_smb/pam_smb-2.0.0_rc5-r1.ebuild b/sys-auth/pam_smb/pam_smb-2.0.0_rc5-r1.ebuild
new file mode 100644
index 000000000000..510d4c0d53df
--- /dev/null
+++ b/sys-auth/pam_smb/pam_smb-2.0.0_rc5-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_smb/pam_smb-2.0.0_rc5-r1.ebuild,v 1.1 2006/04/27 11:33:46 satya Exp $
+
+inherit eutils
+
+DESCRIPTION="The PAM SMB module, which allows authentication against an NT server."
+HOMEPAGE="http://www.csn.ul.ie/~airlied/pam_smb/"
+
+MY_P=${P/_rc/-rc}
+
+S=${WORKDIR}/${MY_P}
+SRC_URI="mirror://samba/pam_smb/v2/${MY_P}.tar.gz
+ http://www.csn.ul.ie/~airlied/pam_smb/v2/pam_smb-2.0.0-rc5.tar.gz"
+
+DEPEND=">=sys-libs/pam-0.75"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/10-pam_smb-bash-3.1.patch
+}
+
+src_compile() {
+ econf --disable-root-only || die
+ emake || die
+}
+
+src_install() {
+ exeinto /lib/security
+ doexe pamsmbm/pam_smb_auth.so
+ exeinto /usr/sbin
+ doexe pamsmbd/pamsmbd
+
+ dodoc BUGS CHANGES COPYING README TODO INSTALL \
+ faq/{pam_smb_faq.sgml,additions.txt}
+ docinto pam.d
+ dodoc pam_smb.conf*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pamsmbd-init pamsmbd
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You must create /etc/pam_smb.conf yourself, containing"
+ einfo "your domainname, PDC and BDC. See example files in docdir."
+ einfo
+}