summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Riosa <vivo@gentoo.org>2006-06-24 13:47:06 +0000
committerFrancesco Riosa <vivo@gentoo.org>2006-06-24 13:47:06 +0000
commit4e818eec7f2a07ede71e201f6bab7b9035fcfbeb (patch)
treefbe85b7a20b4e5a1d300725cb60627bff4f7600a /sys-auth/pam_mysql
parentremove sendfile USE (diff)
downloadgentoo-2-4e818eec7f2a07ede71e201f6bab7b9035fcfbeb.tar.gz
gentoo-2-4e818eec7f2a07ede71e201f6bab7b9035fcfbeb.tar.bz2
gentoo-2-4e818eec7f2a07ede71e201f6bab7b9035fcfbeb.zip
added "openssl" USE flag
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'sys-auth/pam_mysql')
-rw-r--r--sys-auth/pam_mysql/ChangeLog9
-rw-r--r--sys-auth/pam_mysql/files/digest-pam_mysql-0.7_rc1-r13
-rw-r--r--sys-auth/pam_mysql/pam_mysql-0.7_rc1-r1.ebuild36
3 files changed, 47 insertions, 1 deletions
diff --git a/sys-auth/pam_mysql/ChangeLog b/sys-auth/pam_mysql/ChangeLog
index 40a3a40ab2e5..fffaff3782f4 100644
--- a/sys-auth/pam_mysql/ChangeLog
+++ b/sys-auth/pam_mysql/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/pam_mysql
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mysql/ChangeLog,v 1.7 2006/05/19 18:56:22 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mysql/ChangeLog,v 1.8 2006/06/24 13:47:06 vivo Exp $
+
+*pam_mysql-0.7_rc1-r1 (24 Jun 2006)
+
+ 24 Jun 2006; Francesco Riosa <vivo@gentoo.org>
+ +pam_mysql-0.7_rc1-r1.ebuild:
+ Added "openssl" USE flag, add support for md5 and sha1 encryption.
+ Fix bug #137806, thanks to the reporter Carsten Tschense.
19 May 2006; Tobias Scherbaum <dertobi123@gentoo.org>
pam_mysql-0.7_rc1.ebuild:
diff --git a/sys-auth/pam_mysql/files/digest-pam_mysql-0.7_rc1-r1 b/sys-auth/pam_mysql/files/digest-pam_mysql-0.7_rc1-r1
new file mode 100644
index 000000000000..45796e4c3933
--- /dev/null
+++ b/sys-auth/pam_mysql/files/digest-pam_mysql-0.7_rc1-r1
@@ -0,0 +1,3 @@
+MD5 6177183d7e98dc12f2e444c9fbd4f13c pam_mysql-0.7RC1.tar.gz 335240
+RMD160 ffa908bf2f458c48571f0f172f841ef861ad0b47 pam_mysql-0.7RC1.tar.gz 335240
+SHA256 cb3cf89b9b51cb196ee8d731f85acbab72b4878a3a7c4183c5534161d4385ce7 pam_mysql-0.7RC1.tar.gz 335240
diff --git a/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r1.ebuild b/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r1.ebuild
new file mode 100644
index 000000000000..9cbb84b6b1be
--- /dev/null
+++ b/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r1.ebuild,v 1.1 2006/06/24 13:47:06 vivo Exp $
+
+inherit libtool
+
+DESCRIPTION="pam_mysql is a module for pam to authenticate users with mysql"
+HOMEPAGE="http://pam-mysql.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/pam-mysql/${P/_rc/RC}.tar.gz"
+DEPEND=">=sys-libs/pam-0.72 >=dev-db/mysql-3.23.38"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ppc ~sparc x86"
+IUSE="openssl"
+S="${WORKDIR}/${P/_rc/RC}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ elibtoolize
+}
+
+src_compile() {
+ local myconf
+ myconf="${myconf} $(use_with openssl)"
+ econf ${myconf}
+ emake
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc CREDITS ChangeLog NEWS README
+}