summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-07-02 14:04:58 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-07-02 14:04:58 +0000
commit3b8c179720d2dbcad339e1cfe64d0565a3c8203d (patch)
treeee9b91a199d7242d1d90b66e7bbcb7d98b9e39cd /sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild
parentStable on alpha. (diff)
downloadgentoo-2-3b8c179720d2dbcad339e1cfe64d0565a3c8203d.tar.gz
gentoo-2-3b8c179720d2dbcad339e1cfe64d0565a3c8203d.tar.bz2
gentoo-2-3b8c179720d2dbcad339e1cfe64d0565a3c8203d.zip
Moved from app-admin/pam_dotfile to sys-auth/pam_dotfile.
Diffstat (limited to 'sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild')
-rw-r--r--sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild b/sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild
new file mode 100644
index 000000000000..fb2e6e762cdd
--- /dev/null
+++ b/sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_dotfile/pam_dotfile-0.7-r1.ebuild,v 1.1 2005/07/02 14:04:58 flameeyes Exp $
+
+inherit eutils pam
+
+MY_P="${P/_beta/beta}"
+S="${WORKDIR}/${MY_P}"
+
+PATCHLEVEL="1"
+DESCRIPTION="pam module to allow password-storing in \$HOME/dotfiles"
+HOMEPAGE="http://www.stud.uni-hamburg.de/users/lennart/projects/pam_dotfile/"
+SRC_URI="http://www.stud.uni-hamburg.de/users/lennart/projects/pam_dotfile/${MY_P}.tar.gz
+ http://digilander.libero.it/dgp85/gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+DEPEND="doc? ( www-client/lynx )
+ virtual/pam"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ EPATCH_SUFFIX="patch" epatch ${WORKDIR}/${PV}
+ sed -i -e 's:./configure:#./configure:' ${S}/bootstrap.sh
+ sed -i -e "s:aclocal:aclocal -I ${WORKDIR}/${PV}/m4:" ${S}/bootstrap.sh
+
+ sh bootstrap.sh
+}
+
+src_compile() {
+ local myconf
+
+ econf \
+ $(use_enable doc lynx) \
+ "--with-pammoddir=$(getpam_mod_dir)" \
+ || die
+ emake || die
+}
+
+src_install() {
+ make -C src DESTDIR=${D} install
+ make -C man DESTDIR=${D} install
+
+ rm -f ${D}/$(getpam_mod_dir)/pam_dotfile.la
+ fperms 4111 /usr/sbin/pam-dotfile-helper
+
+ dodoc README
+ dohtml doc/*
+}