summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2005-12-21 07:43:14 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2005-12-21 07:43:14 +0000
commitef9f107bc881581b6bf787ae1eee9b47cb081edb (patch)
tree5061175cd4d39b7063395aed597b44f9f134050a /sys-auth/nss-mdns
parentsys-auth/nss-mdns import (diff)
downloadgentoo-2-ef9f107bc881581b6bf787ae1eee9b47cb081edb.tar.gz
gentoo-2-ef9f107bc881581b6bf787ae1eee9b47cb081edb.tar.bz2
gentoo-2-ef9f107bc881581b6bf787ae1eee9b47cb081edb.zip
Adding postinst message
(Portage version: 2.1_pre1)
Diffstat (limited to 'sys-auth/nss-mdns')
-rw-r--r--sys-auth/nss-mdns/ChangeLog6
-rw-r--r--sys-auth/nss-mdns/Manifest5
-rw-r--r--sys-auth/nss-mdns/files/mdns.allow3
-rw-r--r--sys-auth/nss-mdns/nss-mdns-0.7.ebuild27
4 files changed, 37 insertions, 4 deletions
diff --git a/sys-auth/nss-mdns/ChangeLog b/sys-auth/nss-mdns/ChangeLog
index 21c502caf512..b07c05fdead4 100644
--- a/sys-auth/nss-mdns/ChangeLog
+++ b/sys-auth/nss-mdns/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-auth/nss-mdns
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-mdns/ChangeLog,v 1.1 2005/12/21 07:20:16 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-mdns/ChangeLog,v 1.2 2005/12/21 07:43:14 compnerd Exp $
+
+ 21 Dec 2005; Saleem Abdulrasool <compnerd@gentoo.org> +files/mdns.allow,
+ nss-mdns-0.7.ebuild:
+ Adding pkg_postinst() message
*nss-mdns-0.7 (21 Dec 2005)
diff --git a/sys-auth/nss-mdns/Manifest b/sys-auth/nss-mdns/Manifest
index 4dc526d659fb..0794e83fe88f 100644
--- a/sys-auth/nss-mdns/Manifest
+++ b/sys-auth/nss-mdns/Manifest
@@ -1,4 +1,5 @@
-MD5 4862e10da184c4205267946dce33381b ChangeLog 386
+MD5 c74d37d715877a657b8b01c6d5004ef6 ChangeLog 517
MD5 ee0896021a20061f05ae89540938f0c2 files/digest-nss-mdns-0.7 64
+MD5 e571bfc04e713afe6b26f9de16906d2e files/mdns.allow 29
MD5 728f679932dff0305b3c2f2f28568dc6 metadata.xml 359
-MD5 72e1c90c216393bc4b086e11393e8b35 nss-mdns-0.7.ebuild 702
+MD5 7b8da43562dc43fbbed30e75383575b0 nss-mdns-0.7.ebuild 1402
diff --git a/sys-auth/nss-mdns/files/mdns.allow b/sys-auth/nss-mdns/files/mdns.allow
new file mode 100644
index 000000000000..80b49b097b03
--- /dev/null
+++ b/sys-auth/nss-mdns/files/mdns.allow
@@ -0,0 +1,3 @@
+# mdns.allow:
+.local.
+.local
diff --git a/sys-auth/nss-mdns/nss-mdns-0.7.ebuild b/sys-auth/nss-mdns/nss-mdns-0.7.ebuild
index 328b18f7765d..3cd45aad248c 100644
--- a/sys-auth/nss-mdns/nss-mdns-0.7.ebuild
+++ b/sys-auth/nss-mdns/nss-mdns-0.7.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-mdns/nss-mdns-0.7.ebuild,v 1.1 2005/12/21 07:20:16 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-mdns/nss-mdns-0.7.ebuild,v 1.2 2005/12/21 07:43:14 compnerd Exp $
+
+inherit eutils
DESCRIPTION="Name Service Switch module for Multicast DNS"
HOMEPAGE="http://0pointer.de/lennart/projects/nss-mdns/"
@@ -21,5 +23,28 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die "install failed"
+
+ insinto /etc
+ doins ${FILESDIR}/mdns.allow
+
dodoc README
}
+
+pkg_postinst() {
+ ewarn
+ ewarn "You must modify your name service switch look up file to enable"
+ ewarn "multicast DNS lookups. If you wish to resolve only IPv6 addresses"
+ ewarn "use mdns6. For IPv4 addresses only, use mdns4. To resolve both"
+ ewarn "use mdns2. Keep in mind that mdns2 will be slower if there are no"
+ ewarn "IPv6 addresses on the network."
+ ewarn
+ ewarn "Add the appropriate mdns into the hosts line in /etc/nsswitch.conf"
+ ewarn "An example line looks like:"
+ einfo "hosts: files mdns4 dns"
+ ewarn
+ ewarn "Add any domains other than those ending in .local to"
+ ewarn "/etc/mdns.allow"
+ ewarn
+ ebeep 5
+ sleep 10
+}