summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-10-23 16:38:55 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-10-23 16:38:55 +0000
commit299110d00717647bb974a311700af1bc6b51ffbc (patch)
tree94241e52021b519cee4970909486fcd4bb48aeac /sys-auth/libyubikey/libyubikey-1.6.ebuild
parentmake_language_..._lines: declare more variables as local, these are used in T... (diff)
downloadgentoo-2-299110d00717647bb974a311700af1bc6b51ffbc.tar.gz
gentoo-2-299110d00717647bb974a311700af1bc6b51ffbc.tar.bz2
gentoo-2-299110d00717647bb974a311700af1bc6b51ffbc.zip
Add libyubikey, proxy-maintained by Brant Gurganus. Ebuild and patch from bug #342103, updated for style and repoman.
(Portage version: 2.2.0_alpha1/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/libyubikey/libyubikey-1.6.ebuild')
-rw-r--r--sys-auth/libyubikey/libyubikey-1.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-auth/libyubikey/libyubikey-1.6.ebuild b/sys-auth/libyubikey/libyubikey-1.6.ebuild
new file mode 100644
index 000000000000..9c3c3fe21c03
--- /dev/null
+++ b/sys-auth/libyubikey/libyubikey-1.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libyubikey/libyubikey-1.6.ebuild,v 1.1 2010/10/23 16:38:54 flameeyes Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="Yubico C low-level library"
+SRC_URI="http://yubico-c.googlecode.com/files/${P}.tar.gz"
+HOMEPAGE="http://code.google.com/p/yubico-c/"
+
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-rpath.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS || die
+ find "${D}" -name '*.la' -delete || die
+}