summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2011-09-13 07:40:48 +0000
committerHanno Böck <hanno@gentoo.org>2011-09-13 07:40:48 +0000
commitec0d705c9dc2dbf68459d3abd9a32ffcd0bd96f7 (patch)
treecbddce4f35ca105a2818462a6e0bf9d8c5575732 /sys-auth/libnss-mysql
parentVersion bump webpy to 0.36. (diff)
downloadgentoo-2-ec0d705c9dc2dbf68459d3abd9a32ffcd0bd96f7.tar.gz
gentoo-2-ec0d705c9dc2dbf68459d3abd9a32ffcd0bd96f7.tar.bz2
gentoo-2-ec0d705c9dc2dbf68459d3abd9a32ffcd0bd96f7.zip
libnss-mysql: install location back to /usr, because it needs to be on the same partition as libmysql.
(Portage version: 2.1.10.15/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/libnss-mysql')
-rw-r--r--sys-auth/libnss-mysql/ChangeLog9
-rw-r--r--sys-auth/libnss-mysql/libnss-mysql-1.5.ebuild38
-rw-r--r--sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r2.ebuild (renamed from sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915.ebuild)20
3 files changed, 22 insertions, 45 deletions
diff --git a/sys-auth/libnss-mysql/ChangeLog b/sys-auth/libnss-mysql/ChangeLog
index b4f8ef0b3bbf..58080ee6fc5a 100644
--- a/sys-auth/libnss-mysql/ChangeLog
+++ b/sys-auth/libnss-mysql/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/libnss-mysql
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-mysql/ChangeLog,v 1.18 2011/05/28 12:05:24 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-mysql/ChangeLog,v 1.19 2011/09/13 07:40:48 hanno Exp $
+
+*libnss-mysql-1.5_p20060915-r2 (13 Sep 2011)
+
+ 13 Sep 2011; Hanno Boeck <hanno@gentoo.org>
+ +libnss-mysql-1.5_p20060915-r2.ebuild:
+ Change install location back to /usr/lib, it needs to be on the same
+ partition as libmysql, else boot failures may occur.
28 May 2011; Brent Baude <ranger@gentoo.org>
libnss-mysql-1.5_p20060915-r1.ebuild:
diff --git a/sys-auth/libnss-mysql/libnss-mysql-1.5.ebuild b/sys-auth/libnss-mysql/libnss-mysql-1.5.ebuild
deleted file mode 100644
index cc9e5649a43e..000000000000
--- a/sys-auth/libnss-mysql/libnss-mysql-1.5.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-mysql/libnss-mysql-1.5.ebuild,v 1.10 2007/12/30 03:22:27 chtekk Exp $
-
-inherit multilib
-
-KEYWORDS="amd64 ppc ~sparc x86"
-
-DESCRIPTION="NSS MySQL Library."
-HOMEPAGE="http://libnss-mysql.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-DEPEND="virtual/mysql"
-RDEPEND="${DEPEND}"
-
-src_install() {
- dodir "/etc"
- dodir "/usr/$(get_libdir)"
- einstall libdir="${D}/usr/$(get_libdir)"
-
- newdoc sample/README README.sample
- dodoc AUTHORS DEBUGGING FAQ INSTALL NEWS README THANKS \
- TODO UPGRADING ChangeLog
-
- for subdir in sample/{linux,freebsd,complex,minimal} ; do
- docinto "${subdir}"
- dodoc "${subdir}/"{*.sql,*.cfg}
- done
-}
-
-pkg_postinst() {
- einfo "As of version 1.3, the [section] lines in the configuration files"
- einfo "are meaningless and will be ignored. Remove them to avoid extra"
- einfo "parsing overhead."
-}
diff --git a/sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915.ebuild b/sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r2.ebuild
index 0b8adb5ec45e..38a758fa8d84 100644
--- a/sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915.ebuild
+++ b/sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915.ebuild,v 1.1 2010/02/23 12:43:44 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libnss-mysql/libnss-mysql-1.5_p20060915-r2.ebuild,v 1.1 2011/09/13 07:40:48 hanno Exp $
EAPI=2
-inherit multilib
+inherit eutils multilib autotools
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
@@ -18,10 +18,18 @@ IUSE="debug"
DEPEND="virtual/mysql"
S="${WORKDIR}/${PN}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-automagic-debug.diff
+ eautoconf
+}
+
src_configure() {
- # authentication libraries don't belong into usr,
- # please don't change this
- econf --libdir="/$(get_libdir)" \
+ # Usually, authentication libraries don't belong into usr.
+ # But here, it's required that the lib is in the same dir
+ # as libmysql, because else failures may occur on boot if
+ # udev tries to access a user / group that doesn't exist
+ # on the system before /usr is mounted.
+ econf --libdir="/usr/$(get_libdir)" \
$(use_enable debug)
}