summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-01-01 08:10:17 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-01-01 08:10:17 +0000
commit642581ff8680b3cf1029e0967fcc06bdde5e41b8 (patch)
treed7210920903f14b484ae073b438932bc361dd65b /sys-auth/keystone
parentxmonad-0.11 release (diff)
downloadgentoo-2-642581ff8680b3cf1029e0967fcc06bdde5e41b8.tar.gz
gentoo-2-642581ff8680b3cf1029e0967fcc06bdde5e41b8.tar.bz2
gentoo-2-642581ff8680b3cf1029e0967fcc06bdde5e41b8.zip
update to eapi5 and distutils-r1
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-auth/keystone')
-rw-r--r--sys-auth/keystone/ChangeLog9
-rw-r--r--sys-auth/keystone/files/keystone_test-requires.patch33
-rw-r--r--sys-auth/keystone/keystone-2012.2.ebuild49
-rw-r--r--sys-auth/keystone/keystone-9999.ebuild51
4 files changed, 117 insertions, 25 deletions
diff --git a/sys-auth/keystone/ChangeLog b/sys-auth/keystone/ChangeLog
index 81319794810f..07ecf765cb90 100644
--- a/sys-auth/keystone/ChangeLog
+++ b/sys-auth/keystone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/keystone
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.3 2012/12/31 13:50:34 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.4 2013/01/01 08:10:17 prometheanfire Exp $
+
+ 01 Jan 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +files/keystone_test-requires.patch, keystone-2012.2.ebuild,
+ keystone-9999.ebuild:
+ update to eapi5 and distutils-r1
31 Dec 2012; Kacper Kowalik <xarthisius@gentoo.org> keystone-9999.ebuild:
Use EGIT_REPO_URI to point to git sources, rather than invalid in this case
diff --git a/sys-auth/keystone/files/keystone_test-requires.patch b/sys-auth/keystone/files/keystone_test-requires.patch
new file mode 100644
index 000000000000..7af7c1d41c52
--- /dev/null
+++ b/sys-auth/keystone/files/keystone_test-requires.patch
@@ -0,0 +1,33 @@
+diff -u tools.orig/test-requires tools/test-requires
+--- tools.orig/test-requires 2012-09-25 20:27:12.000000000 -0400
++++ tools/test-requires 2013-01-01 02:43:38.316340359 -0500
+@@ -2,7 +2,7 @@
+ python-memcached
+
+ # Optional backend: LDAP
+-python-ldap==2.3.13 # authenticate against an existing LDAP server
++python-ldap # authenticate against an existing LDAP server
+
+ # Testing
+ coverage # computes code coverage percentages
+@@ -12,15 +12,16 @@
+ openstack.nose_plugin
+ nosehtmloutput
+ pylint # static code analysis
+-pep8==1.3.3 # checks for PEP8 code style compliance
+-Sphinx>=1.1.2 # required to build documentation
++pep8 # checks for PEP8 code style compliance
++Sphinx # required to build documentation
+ unittest2 # backport of unittest lib in python 2.7
+ webtest # test wsgi apps without starting an http server
+-distribute>=0.6.24
++distribute
+
+ # for python-keystoneclient
+ httplib2
+-python-keystoneclient>=0.1,<0.2
++#python-keystoneclient>=0.1,<0.2
++python-keystoneclient
+
+ # swift_auth test dependencies
+ http://tarballs.openstack.org/swift/swift-master.tar.gz#egg=swift
diff --git a/sys-auth/keystone/keystone-2012.2.ebuild b/sys-auth/keystone/keystone-2012.2.ebuild
index 67e1aa7cc99a..30c90daabf7a 100644
--- a/sys-auth/keystone/keystone-2012.2.ebuild
+++ b/sys-auth/keystone/keystone-2012.2.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2012.2.ebuild,v 1.1 2012/11/28 21:59:34 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2012.2.ebuild,v 1.2 2013/01/01 08:10:17 prometheanfire Exp $
-EAPI=4
+EAPI=5
+#test restricted becaues of bad requirements given (old webob for instance)
+RESTRICT="test"
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
+inherit distutils-r1
DESCRIPTION="Keystone is the Openstack authentication, authorization, and
service catalog written in Python."
@@ -19,9 +18,10 @@ LICENSE="Apache-2.0"
SLOT="folsom"
KEYWORDS="~amd64 ~x86"
IUSE="+sqlite mysql postgres ldap"
+#IUSE="+sqlite mysql postgres ldap test"
#todo, seperate out rdepend via use flags
-DEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
dev-python/eventlet
dev-python/greenlet
@@ -47,9 +47,36 @@ RDEPEND="${DEPEND}
sys-auth/keystone[ldap]
) )
"
+# test? ( dev-python/Babel
+# dev-python/decorator
+# dev-python/eventlet
+# dev-python/greenlet
+# dev-python/httplib2
+# dev-python/iso8601
+# dev-python/lxml
+# dev-python/netifaces
+# dev-python/nose
+# dev-python/nosexcover
+# dev-python/passlib
+# dev-python/paste
+# dev-python/pastedeploy
+# dev-python/python-pam
+# dev-python/repoze-lru
+# dev-python/routes
+# dev-python/sphinx
+# >=dev-python/sqlalchemy-migrate-0.7
+# dev-python/tempita
+# >=dev-python/webob-1.0.8
+# dev-python/webtest
+# )
+#PATCHES=( "${FILESDIR}"/keystone_test-requires.patch )
+#
+#python_test() {
+# "${PYTHON}" setup.py nosetests || die
+#}
-src_install() {
- distutils_src_install
+python_install() {
+ distutils-r1_python_install
newconfd "${FILESDIR}/keystone.confd" keystone
newinitd "${FILESDIR}/keystone.initd" keystone
diff --git a/sys-auth/keystone/keystone-9999.ebuild b/sys-auth/keystone/keystone-9999.ebuild
index 5bb02b2b0389..b8ce770a7748 100644
--- a/sys-auth/keystone/keystone-9999.ebuild
+++ b/sys-auth/keystone/keystone-9999.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-9999.ebuild,v 1.2 2012/12/31 13:50:34 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-9999.ebuild,v 1.3 2013/01/01 08:10:17 prometheanfire Exp $
-EAPI=4
+EAPI=5
+#test restricted becaues of bad requirements given (old webob for instance)
+RESTRICT="test"
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit git-2 distutils
+inherit git-2 distutils-r1
DESCRIPTION="Keystone is the Openstack authentication, authorization, and
service catalog written in Python."
HOMEPAGE="https://launchpad.net/keystone"
-EGIT_REPO_URI="https://github.com/openstack/keystone.git"
+SRC_URI="https://github.com/openstack/keystone.git"
LICENSE="Apache-2.0"
SLOT="folsom"
KEYWORDS=""
IUSE="+sqlite mysql postgres ldap"
+#IUSE="+sqlite mysql postgres ldap test"
#todo, seperate out rdepend via use flags
-DEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
dev-python/eventlet
dev-python/greenlet
@@ -47,9 +47,36 @@ RDEPEND="${DEPEND}
sys-auth/keystone[ldap]
) )
"
+# test? ( dev-python/Babel
+# dev-python/decorator
+# dev-python/eventlet
+# dev-python/greenlet
+# dev-python/httplib2
+# dev-python/iso8601
+# dev-python/lxml
+# dev-python/netifaces
+# dev-python/nose
+# dev-python/nosexcover
+# dev-python/passlib
+# dev-python/paste
+# dev-python/pastedeploy
+# dev-python/python-pam
+# dev-python/repoze-lru
+# dev-python/routes
+# dev-python/sphinx
+# >=dev-python/sqlalchemy-migrate-0.7
+# dev-python/tempita
+# >=dev-python/webob-1.0.8
+# dev-python/webtest
+# )
+#PATCHES=( "${FILESDIR}"/keystone_test-requires.patch )
+#
+#python_test() {
+# "${PYTHON}" setup.py nosetests || die
+#}
-src_install() {
- distutils_src_install
+python_install() {
+ distutils-r1_python_install
newconfd "${FILESDIR}/keystone.confd" keystone
newinitd "${FILESDIR}/keystone.initd" keystone