summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-01-18 07:34:04 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-01-18 07:34:04 +0000
commit48e5f78f137455ef7798b2d1badef1fd72ce4911 (patch)
tree7007e657428a1e569158ff112348f1f8e46b0c42 /sys-auth/keystone
parentAdd live ebuild for 1.7 branch (diff)
downloadgentoo-2-48e5f78f137455ef7798b2d1badef1fd72ce4911.tar.gz
gentoo-2-48e5f78f137455ef7798b2d1badef1fd72ce4911.tar.bz2
gentoo-2-48e5f78f137455ef7798b2d1badef1fd72ce4911.zip
made use of required_use
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-auth/keystone')
-rw-r--r--sys-auth/keystone/ChangeLog6
-rw-r--r--sys-auth/keystone/keystone-2012.2.ebuild12
-rw-r--r--sys-auth/keystone/keystone-9999.ebuild12
3 files changed, 11 insertions, 19 deletions
diff --git a/sys-auth/keystone/ChangeLog b/sys-auth/keystone/ChangeLog
index 2a531d449c85..da3697d3c3b5 100644
--- a/sys-auth/keystone/ChangeLog
+++ b/sys-auth/keystone/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-auth/keystone
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.7 2013/01/16 21:19:34 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.8 2013/01/18 07:34:04 prometheanfire Exp $
+
+ 18 Jan 2013; Matthew Thode <prometheanfire@gentoo.org> keystone-2012.2.ebuild,
+ keystone-9999.ebuild:
+ made use of required_use
16 Jan 2013; Michał Górny <mgorny@gentoo.org> keystone-2012.2.ebuild,
keystone-9999.ebuild:
diff --git a/sys-auth/keystone/keystone-2012.2.ebuild b/sys-auth/keystone/keystone-2012.2.ebuild
index 35142d6d6621..5f84e89c946a 100644
--- a/sys-auth/keystone/keystone-2012.2.ebuild
+++ b/sys-auth/keystone/keystone-2012.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2012.2.ebuild,v 1.4 2013/01/16 21:19:33 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2012.2.ebuild,v 1.5 2013/01/18 07:34:03 prometheanfire Exp $
EAPI=5
#test restricted becaues of bad requirements given (old webob for instance)
@@ -19,6 +19,7 @@ SLOT="folsom"
KEYWORDS="~amd64 ~x86"
IUSE="+sqlite mysql postgres ldap"
#IUSE="+sqlite mysql postgres ldap test"
+REQUIRED_USE="|| ( ldap mysql postgres sqlite )"
#todo, seperate out rdepend via use flags
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
@@ -39,14 +40,7 @@ RDEPEND="${DEPEND}
sqlite? ( dev-python/sqlalchemy[sqlite] )
mysql? ( dev-python/sqlalchemy[mysql] )
postgres? ( dev-python/sqlalchemy[postgres] )
- ldap? ( dev-python/python-ldap )
- ( || (
- sys-auth/keystone[sqlite]
- sys-auth/keystone[mysql]
- sys-auth/keystone[postgres]
- sys-auth/keystone[ldap]
- ) )
- "
+ ldap? ( dev-python/python-ldap )"
# test? ( dev-python/Babel
# dev-python/decorator
# dev-python/eventlet
diff --git a/sys-auth/keystone/keystone-9999.ebuild b/sys-auth/keystone/keystone-9999.ebuild
index 2307c58cc9de..e02bad94f602 100644
--- a/sys-auth/keystone/keystone-9999.ebuild
+++ b/sys-auth/keystone/keystone-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-9999.ebuild,v 1.6 2013/01/16 21:19:33 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-9999.ebuild,v 1.7 2013/01/18 07:34:03 prometheanfire Exp $
EAPI=5
#test restricted becaues of bad requirements given (old webob for instance)
@@ -19,6 +19,7 @@ SLOT="folsom"
KEYWORDS=""
IUSE="+sqlite mysql postgres ldap"
#IUSE="+sqlite mysql postgres ldap test"
+REQUIRED_USE="|| ( ldap mysql postgres sqlite )"
#todo, seperate out rdepend via use flags
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
@@ -39,14 +40,7 @@ RDEPEND="${DEPEND}
sqlite? ( dev-python/sqlalchemy[sqlite] )
mysql? ( dev-python/sqlalchemy[mysql] )
postgres? ( dev-python/sqlalchemy[postgres] )
- ldap? ( dev-python/python-ldap )
- ( || (
- sys-auth/keystone[sqlite]
- sys-auth/keystone[mysql]
- sys-auth/keystone[postgres]
- sys-auth/keystone[ldap]
- ) )
- "
+ ldap? ( dev-python/python-ldap )"
# test? ( dev-python/Babel
# dev-python/decorator
# dev-python/eventlet