summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-04-11 03:52:22 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-04-11 03:52:22 +0000
commit779b35567d4e46c2b81edb4bf3dd4a77e8e7aeb0 (patch)
treeb21c6564e3eec1eb475ba55a79c3ad6cbba86f33 /sys-auth/consolekit
parentStable for HPPA (bug #173556). (diff)
downloadgentoo-2-779b35567d4e46c2b81edb4bf3dd4a77e8e7aeb0.tar.gz
gentoo-2-779b35567d4e46c2b81edb4bf3dd4a77e8e7aeb0.tar.bz2
gentoo-2-779b35567d4e46c2b81edb4bf3dd4a77e8e7aeb0.zip
rev bump
(Portage version: 2.1.2.3)
Diffstat (limited to 'sys-auth/consolekit')
-rw-r--r--sys-auth/consolekit/ChangeLog7
-rw-r--r--sys-auth/consolekit/consolekit-0.2.1.ebuild70
-rw-r--r--sys-auth/consolekit/files/digest-consolekit-0.2.13
3 files changed, 79 insertions, 1 deletions
diff --git a/sys-auth/consolekit/ChangeLog b/sys-auth/consolekit/ChangeLog
index 986a4ffbfdef..37594189c46a 100644
--- a/sys-auth/consolekit/ChangeLog
+++ b/sys-auth/consolekit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/consolekit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.8 2007/04/10 00:47:45 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.9 2007/04/11 03:52:22 cardoe Exp $
+
+*consolekit-0.2.1 (11 Apr 2007)
+
+ 11 Apr 2007; Doug Goldstein <cardoe@gentoo.org> +consolekit-0.2.1.ebuild:
+ rev bump
10 Apr 2007; Doug Goldstein <cardoe@gentoo.org> -consolekit-0.2.0.ebuild,
consolekit-0.2.0-r1.ebuild:
diff --git a/sys-auth/consolekit/consolekit-0.2.1.ebuild b/sys-auth/consolekit/consolekit-0.2.1.ebuild
new file mode 100644
index 000000000000..99f4cce91575
--- /dev/null
+++ b/sys-auth/consolekit/consolekit-0.2.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/consolekit-0.2.1.ebuild,v 1.1 2007/04/11 03:52:22 cardoe Exp $
+
+inherit eutils autotools multilib
+
+MY_PN="ConsoleKit"
+
+DESCRIPTION="Framework for defining and tracking users, login sessions and seats."
+HOMEPAGE="http://if.only.it.had.one"
+SRC_URI="http://people.freedesktop.org/~mccann/dist/${MY_PN}-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug pam"
+
+# Not parallel make safe
+MAKEOPTS="$MAKEOPTS -j1"
+
+RDEPEND=">=dev-libs/glib-2.7
+ >=dev-libs/dbus-glib-0.61
+ >=x11-libs/libX11-1.0.0
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-0.2.0-pam-lib-fix.patch
+ epatch "${FILESDIR}"/${PN}-0.2.0-gdk-to-x11.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable pam pam-module) \
+ --with-slibdir=/$(get_libdir) \
+ --with-pid-file=/var/run/consolekit.pid \
+ --with-dbus-services=/usr/share/dbus-1/services/ \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ #crappy Redhat init script
+ rm -f "${D}/etc/rc.d/init.d/ConsoleKit"
+ rm -r "${D}/etc/rc.d/"
+
+ #Portage barfs on .la files
+ rm -f "${D}/$(get_libdir)/security/pam_ck_connector.la"
+
+ # Gentoo style init script
+ newinitd "${FILESDIR}"/${PN}-0.1.rc consolekit
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "You need to restart ConsoleKit to get the new features."
+ ewarn "This can be done with /etc/init.d/consolekit restart"
+ ewarn "but make sure you do this and then restart your session"
+ ewarn "otherwise you will get access denied for certain actions"
+ ewarn
+}
diff --git a/sys-auth/consolekit/files/digest-consolekit-0.2.1 b/sys-auth/consolekit/files/digest-consolekit-0.2.1
new file mode 100644
index 000000000000..ff4c5277a892
--- /dev/null
+++ b/sys-auth/consolekit/files/digest-consolekit-0.2.1
@@ -0,0 +1,3 @@
+MD5 8bf5e83931a8a3c2abcd541781e1554c ConsoleKit-0.2.1.tar.gz 455036
+RMD160 73bc8b6a15e193c346bc9516c6def0df4cac3fb6 ConsoleKit-0.2.1.tar.gz 455036
+SHA256 059290d71bd71665cb1f3d40a5900c9e5ef422855070838b60a963d5bfaef61f ConsoleKit-0.2.1.tar.gz 455036