summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Kroah-Hartman <gregkh@gentoo.org>2004-09-23 19:13:36 +0000
committerGreg Kroah-Hartman <gregkh@gentoo.org>2004-09-23 19:13:36 +0000
commitfa70dcc1351f64a7033f6a6a4d37e22f20b69121 (patch)
treea22b9bcf2487120bf83caae35bb08efd84f1b506 /sys-apps
parentFixed gcc-3.4 compile issues (Manifest recommit) (diff)
downloadgentoo-2-fa70dcc1351f64a7033f6a6a4d37e22f20b69121.tar.gz
gentoo-2-fa70dcc1351f64a7033f6a6a4d37e22f20b69121.tar.bz2
gentoo-2-fa70dcc1351f64a7033f6a6a4d37e22f20b69121.zip
new release
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hotplug/ChangeLog10
-rw-r--r--sys-apps/hotplug/Manifest2
-rw-r--r--sys-apps/hotplug/files/digest-hotplug-200409231
-rw-r--r--sys-apps/hotplug/files/isapnp.rc.empty0
-rw-r--r--sys-apps/hotplug/hotplug-20040923.ebuild72
5 files changed, 84 insertions, 1 deletions
diff --git a/sys-apps/hotplug/ChangeLog b/sys-apps/hotplug/ChangeLog
index 49607eef207f..031e7a4005c2 100644
--- a/sys-apps/hotplug/ChangeLog
+++ b/sys-apps/hotplug/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/hotplug
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.48 2004/09/21 00:13:46 gregkh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.49 2004/09/23 19:13:35 gregkh Exp $
+
+*hotplug-20040923 (23 Sep 2004)
+
+ 23 Sep 2004; Greg Kroah-Hartman <gregkh@gentoo.org> +files/isapnp.rc.empty,
+ +hotplug-20040923.ebuild:
+ New release, fixes the isapnp.rc bug.
+ Also explicitly call out the coldplug package, and the
+ /lib/firmware move.
*hotplug-20040920 (20 Sep 2004)
diff --git a/sys-apps/hotplug/Manifest b/sys-apps/hotplug/Manifest
index 998510a5f82c..a890e0d1c1cb 100644
--- a/sys-apps/hotplug/Manifest
+++ b/sys-apps/hotplug/Manifest
@@ -1,4 +1,5 @@
MD5 00fece6b3f0270079f9d1d9d6ab3fa8d ChangeLog 8248
+MD5 919516e32388f644aed7a49272fb494f hotplug-20040923.ebuild 2016
MD5 0632c150f5e144e0d542b93aaf21e939 hotplug-20040920.ebuild 1837
MD5 34941ac9da8e298070b69145a9aefe52 hotplug-20040401.ebuild 1520
MD5 1f70c719d6a669a311cdc1d8fe804866 hotplug-20030805-r2.ebuild 1882
@@ -7,6 +8,7 @@ MD5 fe6609fa5c00549e997a01bb0b2d487c hotplug-20040105.ebuild 1719
MD5 075d5a933d6175160a02ddf15bd4f454 metadata.xml 260
MD5 2fdc27ccc01d4fca5e045531e0c96eb7 files/hotplug.rc.empty 878
MD5 6038bb8c3af43a0e6f0aa876e4307df6 files/digest-hotplug-20040920 69
+MD5 8cecfadba72f89724706c45119b15e49 files/digest-hotplug-20040923 69
MD5 a3281f5b866be688f79d9a46d060180a files/digest-hotplug-20030805-r2 151
MD5 a3281f5b866be688f79d9a46d060180a files/digest-hotplug-20030805-r3 151
MD5 f9303a2467242ed310370ddcd63414b6 files/digest-hotplug-20040105 151
diff --git a/sys-apps/hotplug/files/digest-hotplug-20040923 b/sys-apps/hotplug/files/digest-hotplug-20040923
new file mode 100644
index 000000000000..9910c869236c
--- /dev/null
+++ b/sys-apps/hotplug/files/digest-hotplug-20040923
@@ -0,0 +1 @@
+MD5 1542af9cbe1053cfde9421007f702cf2 hotplug-2004_09_23.tar.gz 44802
diff --git a/sys-apps/hotplug/files/isapnp.rc.empty b/sys-apps/hotplug/files/isapnp.rc.empty
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-apps/hotplug/files/isapnp.rc.empty
diff --git a/sys-apps/hotplug/hotplug-20040923.ebuild b/sys-apps/hotplug/hotplug-20040923.ebuild
new file mode 100644
index 000000000000..635ac381f7ed
--- /dev/null
+++ b/sys-apps/hotplug/hotplug-20040923.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20040923.ebuild,v 1.1 2004/09/23 19:13:35 gregkh Exp $
+
+inherit eutils
+
+# source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
+MY_P=${PN}-${PV:0:4}_${PV:4:2}_${PV:6:2}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="USB and PCI hotplug scripts"
+HOMEPAGE="http://linux-hotplug.sourceforge.net"
+SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~mips"
+IUSE=""
+
+# hotplug needs pcimodules utility provided by pcitutils-2.1.9-r1
+DEPEND=">=sys-apps/pciutils-2.1.9
+ >=sys-apps/usbutils-0.9
+ sys-apps/hotplug-base"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # patches go here if needed...
+}
+
+src_install() {
+ into /
+ doman *.8
+ dodoc README README.modules ChangeLog
+
+ cd ${S}/etc/hotplug
+ insinto /etc/hotplug
+ doins blacklist hotplug.functions *map
+
+ exeinto /etc/hotplug
+ doexe *.agent *.rc *.permissions
+ # stupid isapnp.rc files...
+ newexe ${FILESDIR}/isapnp.rc.empty isapnp.rc
+
+ dodir /usr/lib/hotplug/firmware
+ dodir /etc/hotplug/usb
+ dodir /etc/hotplug/pci
+ cd ${S}/etc/hotplug.d/default
+ exeinto /etc/hotplug.d/default
+ doexe default.hotplug
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/hotplug.rc.empty hotplug
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/usb.confd usb
+ dodir /var/run/usb
+}
+
+pkg_postinst() {
+ ewarn "WARNING: The hotplug init script is now gone (dead and burried.)"
+ ewarn "WARNING: If you want to load modules for hardware that was already"
+ ewarn "WARNING: discovered at boot time, like the old hotplug init script"
+ ewarn "WARNING: did, then emerge the coldplug package."
+ ewarn ""
+ ewarn "WARNING: All firmware loaded by the hotplug scripts needs to be"
+ ewarn "WARNING: moved to the /lib/firmware directory, as the scripts now"
+ ewarn "WARNING: expect it to be in that location."
+ ewarn ""
+ ewarn "If you still have the file /etc/hotplug/isapnp.rc on your system,"
+ ewarn "please delete it by hand, the file /etc/hotplug/pnp.rc superseeds it."
+}