summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-21 00:00:21 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-21 00:00:21 +0000
commitf28936e0e66ae9c4d0360d8d5fa526954fdff992 (patch)
tree79da1e3d878fcbc34fd44dc0abf6e118f2194b1a /sys-apps
parentfix default runlevel generation (Manifest recommit) (diff)
downloadgentoo-2-f28936e0e66ae9c4d0360d8d5fa526954fdff992.tar.gz
gentoo-2-f28936e0e66ae9c4d0360d8d5fa526954fdff992.tar.bz2
gentoo-2-f28936e0e66ae9c4d0360d8d5fa526954fdff992.zip
look for files in /etc/init.d instead of /init.d
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/baselayout/ChangeLog5
-rw-r--r--sys-apps/baselayout/baselayout-1.10.3.ebuild4
-rw-r--r--sys-apps/baselayout/baselayout-1.10.4.ebuild4
3 files changed, 7 insertions, 6 deletions
diff --git a/sys-apps/baselayout/ChangeLog b/sys-apps/baselayout/ChangeLog
index e31eb4d28294..4662de370da2 100644
--- a/sys-apps/baselayout/ChangeLog
+++ b/sys-apps/baselayout/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for sys-apps/baselayout
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.168 2004/08/20 23:54:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.169 2004/08/21 00:00:21 vapier Exp $
# See the gentoo-src rc-scripts ChangeLog for up-to-date release information:
# http://www.gentoo.org/cgi-bin/viewcvs.cgi/rc-scripts/ChangeLog?rev=HEAD&cvsroot=gentoo-src&content-type=text/vnd.viewcvs-markup
@@ -8,7 +8,8 @@
20 Aug 2004; Mike Frysinger <vapier@gentoo.org> baselayout-1.10.3.ebuild,
baselayout-1.10.4.ebuild:
Fix default runlevel generation. Seems the variable name was changed from foo
- to x, but not all instances of foo were changed over.
+ to x, but not all instances of foo were changed over. Also, the script was
+ checking for the files in /init.d/ instead of /etc/init.d/.
*baselayout-1.10.4 (18 Aug 2004)
diff --git a/sys-apps/baselayout/baselayout-1.10.3.ebuild b/sys-apps/baselayout/baselayout-1.10.3.ebuild
index 327c9672dac3..c219a1d94cd1 100644
--- a/sys-apps/baselayout/baselayout-1.10.3.ebuild
+++ b/sys-apps/baselayout/baselayout-1.10.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.10.3.ebuild,v 1.3 2004/08/20 23:54:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.10.3.ebuild,v 1.4 2004/08/21 00:00:21 vapier Exp $
inherit flag-o-matic eutils
@@ -427,7 +427,7 @@ pkg_postinst() {
einfo "Creating default runlevel symlinks for ${x}"
mkdir -p ${ROOT}/etc/runlevels/${x}
for y in $(<${ROOT}/usr/share/baselayout/rc-lists/${x}); do
- if [[ ! -e ${ROOT}/init.d/${y} ]]; then
+ if [[ ! -e ${ROOT}/etc/init.d/${y} ]]; then
ewarn "init.d/${y} not found -- ignoring"
else
ln -sfn ${ROOT}/etc/init.d/${y} \
diff --git a/sys-apps/baselayout/baselayout-1.10.4.ebuild b/sys-apps/baselayout/baselayout-1.10.4.ebuild
index 4922aa444189..6b0d4c251f4e 100644
--- a/sys-apps/baselayout/baselayout-1.10.4.ebuild
+++ b/sys-apps/baselayout/baselayout-1.10.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.10.4.ebuild,v 1.3 2004/08/20 23:54:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.10.4.ebuild,v 1.4 2004/08/21 00:00:21 vapier Exp $
inherit flag-o-matic eutils
@@ -427,7 +427,7 @@ pkg_postinst() {
einfo "Creating default runlevel symlinks for ${x}"
mkdir -p ${ROOT}/etc/runlevels/${x}
for y in $(<${ROOT}/usr/share/baselayout/rc-lists/${x}); do
- if [[ ! -e ${ROOT}/init.d/${y} ]]; then
+ if [[ ! -e ${ROOT}/etc/init.d/${y} ]]; then
ewarn "init.d/${y} not found -- ignoring"
else
ln -sfn ${ROOT}/etc/init.d/${y} \