summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-15 05:22:23 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-15 05:22:23 +0000
commitf05d23a7f65335868cde615a9068546c30a709c0 (patch)
treef19e9624da335b046ef6b6b93c0cb9e7a6d46d64 /sys-apps
parentFix incorrect header deletion when switching profiles #330299 by Pinky. (diff)
downloadgentoo-2-f05d23a7f65335868cde615a9068546c30a709c0.tar.gz
gentoo-2-f05d23a7f65335868cde615a9068546c30a709c0.tar.bz2
gentoo-2-f05d23a7f65335868cde615a9068546c30a709c0.zip
Manually decompress the lzma archive if host PM cannot #271543.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sandbox/ChangeLog8
-rw-r--r--sys-apps/sandbox/sandbox-1.6-r2.ebuild10
-rw-r--r--sys-apps/sandbox/sandbox-2.2.ebuild14
3 files changed, 24 insertions, 8 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index c2701cc0b4fd..4f7fc292cc16 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/sandbox
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.132 2009/11/21 14:02:47 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.133 2010/08/15 05:22:23 vapier Exp $
+
+ 15 Aug 2010; Mike Frysinger <vapier@gentoo.org> sandbox-1.6-r2.ebuild,
+ sandbox-2.2.ebuild:
+ Manually decompress the lzma archive if host PM cannot #271543.
21 Nov 2009; Raúl Porcel <armin76@gentoo.org> sandbox-2.2.ebuild:
Mark 2.2 -sparc as it doesn't work very well, bug #293632
diff --git a/sys-apps/sandbox/sandbox-1.6-r2.ebuild b/sys-apps/sandbox/sandbox-1.6-r2.ebuild
index 0c16ee7111f2..007a7c16fac3 100644
--- a/sys-apps/sandbox/sandbox-1.6-r2.ebuild
+++ b/sys-apps/sandbox/sandbox-1.6-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.6-r2.ebuild,v 1.14 2009/09/08 17:49:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.6-r2.ebuild,v 1.15 2010/08/15 05:22:23 vapier Exp $
#
# don't monkey with this ebuild unless contacting portage devs.
@@ -19,7 +19,7 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
IUSE=""
-DEPEND="|| ( app-arch/xz-utils app-arch/lzma-utils )
+DEPEND="app-arch/xz-utils
>=app-misc/pax-utils-0.1.19" #265376
RDEPEND=""
@@ -33,6 +33,10 @@ sandbox_death_notice() {
src_unpack() {
unpack ${A}
+ if [[ ! -d ${S} ]] ; then
+ # When upgrading from older version, lzma unpack may not work #271543
+ lzma -dc "${DISTDIR}/${A}" | tar xf - || die
+ fi
cd "${S}"
epatch "${FILESDIR}"/${P}-disable-qa-static.patch
epatch "${FILESDIR}"/${P}-disable-pthread.patch
diff --git a/sys-apps/sandbox/sandbox-2.2.ebuild b/sys-apps/sandbox/sandbox-2.2.ebuild
index f55ca5b3ad04..af2ff9e1b982 100644
--- a/sys-apps/sandbox/sandbox-2.2.ebuild
+++ b/sys-apps/sandbox/sandbox-2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-2.2.ebuild,v 1.2 2009/11/21 14:02:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-2.2.ebuild,v 1.3 2010/08/15 05:22:23 vapier Exp $
#
# don't monkey with this ebuild unless contacting portage devs.
@@ -19,7 +19,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh -sparc ~x86 ~sparc-fbsd -x86-fbsd"
IUSE="multilib"
-DEPEND="|| ( app-arch/xz-utils app-arch/lzma-utils )
+DEPEND="app-arch/xz-utils
>=app-misc/pax-utils-0.1.19" #265376
RDEPEND=""
@@ -33,6 +33,14 @@ sandbox_death_notice() {
sb_get_install_abis() { use multilib && get_install_abis || echo ${ABI:-default} ; }
+src_unpack() {
+ unpack ${A}
+ if [[ ! -d ${S} ]] ; then
+ # When upgrading from older version, lzma unpack may not work #271543
+ lzma -dc "${DISTDIR}/${A}" | tar xf - || die
+ fi
+}
+
src_compile() {
filter-lfs-flags #90228