summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-06-15 07:19:35 +0000
committerNed Ludd <solar@gentoo.org>2004-06-15 07:19:35 +0000
commite4a2b3a468f12fa693df4f50e38652f5fbb59644 (patch)
tree28c0066c7d8e75590b6819b8dc2bc81e7db182d8 /sys-apps
parentPatching around another crash. (Manifest recommit) (diff)
downloadgentoo-2-e4a2b3a468f12fa693df4f50e38652f5fbb59644.tar.gz
gentoo-2-e4a2b3a468f12fa693df4f50e38652f5fbb59644.tar.bz2
gentoo-2-e4a2b3a468f12fa693df4f50e38652f5fbb59644.zip
added nonis patch and uclibc USE to allow shadow to be compiled under uclibc envs
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/shadow/ChangeLog7
-rw-r--r--sys-apps/shadow/files/shadow-4.0.4.1-nonis.patch53
-rw-r--r--sys-apps/shadow/shadow-4.0.4.1-r2.ebuild7
3 files changed, 64 insertions, 3 deletions
diff --git a/sys-apps/shadow/ChangeLog b/sys-apps/shadow/ChangeLog
index 52763fef8d5b..11bcd4ccc27a 100644
--- a/sys-apps/shadow/ChangeLog
+++ b/sys-apps/shadow/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/shadow
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/ChangeLog,v 1.57 2004/06/11 16:34:20 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/ChangeLog,v 1.58 2004/06/15 07:19:35 solar Exp $
+
+ 15 Jun 2004; <solar@gentoo.org> shadow-4.0.4.1-r2.ebuild,
+ files/shadow-4.0.4.1-nonis.patch:
+ added nonis patch and uclibc USE to allow shadow to be compiled under uclibc
+ envs
11 Jun 2004; Bryan Østergaard <kloeri@gentoo.org> shadow-4.0.4.1-r1.ebuild:
Stable on alpha.
diff --git a/sys-apps/shadow/files/shadow-4.0.4.1-nonis.patch b/sys-apps/shadow/files/shadow-4.0.4.1-nonis.patch
new file mode 100644
index 000000000000..288c19fe6c44
--- /dev/null
+++ b/sys-apps/shadow/files/shadow-4.0.4.1-nonis.patch
@@ -0,0 +1,53 @@
+--- ./libmisc/login_access.c.nonis Mon May 5 23:44:15 2003
++++ ./libmisc/login_access.c Wed Jan 28 11:44:10 2004
+@@ -50,7 +50,9 @@
+ #include <netinet/in.h>
+ #include <arpa/inet.h> /* for inet_ntoa() */
+ extern struct group *getgrnam ();
++#ifdef USE_NIS
+ extern int innetgr ();
++#endif
+
+ #if !defined(MAXHOSTNAMELEN) || (MAXHOSTNAMELEN < 64)
+ #undef MAXHOSTNAMELEN
+@@ -187,6 +189,7 @@
+ return (name);
+ }
+
++#ifdef USE_NIS
+ /* netgroup_match - match group against machine or user */
+
+ static int
+@@ -203,6 +206,7 @@
+
+ return innetgr (group, machine, user, mydomain);
+ }
++#endif
+
+ /* user_match - match a username against one token */
+
+@@ -226,8 +230,10 @@
+ *at = 0;
+ return (user_match (tok, string)
+ && from_match (at + 1, myhostname ()));
++#ifdef USE_NIS
+ } else if (tok[0] == '@') { /* netgroup */
+ return (netgroup_match (tok + 1, (char *) 0, string));
++#endif
+ } else if (string_match (tok, string)) { /* ALL or exact match */
+ return (YES);
+ } else if ((group = getgrnam (tok))) { /* try group membership */
+@@ -285,9 +291,13 @@
+ * if it matches the head of the string.
+ */
+
++#ifdef USE_NIS
+ if (tok[0] == '@') { /* netgroup */
+ return (netgroup_match (tok + 1, string, (char *) 0));
+ } else if (string_match (tok, string)) { /* ALL or exact match */
++#else
++ if (string_match (tok, string)) { /* ALL or exact match */
++#endif
+ return (YES);
+ } else if (tok[0] == '.') { /* domain: match last fields */
+ if ((str_len = strlen (string)) > (tok_len = strlen (tok))
diff --git a/sys-apps/shadow/shadow-4.0.4.1-r2.ebuild b/sys-apps/shadow/shadow-4.0.4.1-r2.ebuild
index be5981c1d00a..efe46db08a3f 100644
--- a/sys-apps/shadow/shadow-4.0.4.1-r2.ebuild
+++ b/sys-apps/shadow/shadow-4.0.4.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.4.1-r2.ebuild,v 1.2 2004/06/06 03:48:49 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.4.1-r2.ebuild,v 1.3 2004/06/15 07:19:35 solar Exp $
inherit eutils libtool gnuconfig flag-o-matic
@@ -15,7 +15,7 @@ SRC_URI="ftp://ftp.pld.org.pl/software/shadow/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~mips ~hppa amd64 ~ia64 ~ppc64 ~s390"
-IUSE="pam selinux nls"
+IUSE="pam selinux nls uclibc"
DEPEND=">=sys-libs/cracklib-2.7-r3
pam? ( >=sys-libs/pam-0.75-r4 )
@@ -36,6 +36,9 @@ src_unpack() {
use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}
+ # uclibc support, corrects NIS usage
+ use uclibc && epatch ${FILESDIR}/shadow-4.0.4.1-nonis.patch
+
# Get su to call pam_open_session(), and also set DISPLAY and XAUTHORITY,
# else the session entries in /etc/pam.d/su never get executed, and
# pam_xauth for one, is then never used. This should close bug #8831.