summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tgall@gentoo.org>2005-07-08 02:16:51 +0000
committerTom Gall <tgall@gentoo.org>2005-07-08 02:16:51 +0000
commite20b3d7f2c7c57f4ef4f896845e8709a604a9a2f (patch)
tree7807105876e5f3ad2ae5d6c20f25ab66130b0072 /sys-apps
parentmake error message more compact (diff)
downloadgentoo-2-e20b3d7f2c7c57f4ef4f896845e8709a604a9a2f.tar.gz
gentoo-2-e20b3d7f2c7c57f4ef4f896845e8709a604a9a2f.tar.bz2
gentoo-2-e20b3d7f2c7c57f4ef4f896845e8709a604a9a2f.zip
take advantage of ibm use flag and add hvsi supported
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/baselayout/ChangeLog6
-rw-r--r--sys-apps/baselayout/baselayout-1.11.12-r4.ebuild21
2 files changed, 16 insertions, 11 deletions
diff --git a/sys-apps/baselayout/ChangeLog b/sys-apps/baselayout/ChangeLog
index 01e1f57c4bef..2e53b2319487 100644
--- a/sys-apps/baselayout/ChangeLog
+++ b/sys-apps/baselayout/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for sys-apps/baselayout
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.250 2005/06/27 14:19:53 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.251 2005/07/08 02:16:51 tgall Exp $
# See the gentoo-src rc-scripts ChangeLog for up-to-date release information:
# http://www.gentoo.org/cgi-bin/viewcvs.cgi/rc-scripts/ChangeLog?rev=HEAD&cvsroot=gentoo-src&content-type=text/vnd.viewcvs-markup
+ 07 Jul 2005; Tom Gall <tgall@gentoo.org>
+ baselayout-1.11.12-r4.ebuild:
+ update for use of ibm and hvsi0 console
+
27 Jun 2005; Tom Gall <tgall@gentoo.org>
baselayout-1.11.12-r4.ebuild:
slight tweak for hvc console systems.
diff --git a/sys-apps/baselayout/baselayout-1.11.12-r4.ebuild b/sys-apps/baselayout/baselayout-1.11.12-r4.ebuild
index 3565991d1b11..1a701f3fae26 100644
--- a/sys-apps/baselayout/baselayout-1.11.12-r4.ebuild
+++ b/sys-apps/baselayout/baselayout-1.11.12-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.11.12-r4.ebuild,v 1.7 2005/06/27 14:19:53 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.11.12-r4.ebuild,v 1.8 2005/07/08 02:16:51 tgall Exp $
inherit flag-o-matic eutils toolchain-funcs multilib
@@ -16,7 +16,7 @@ SRC_URI="mirror://gentoo/rc-scripts-${SV}${SVREV}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="bootstrap build static unicode"
+IUSE="bootstrap build static unicode ibm"
# This version of baselayout needs gawk in /bin, but as we do not have
# a c++ compiler during bootstrap, we cannot depend on it if "bootstrap"
@@ -61,19 +61,20 @@ src_unpack() {
# Tweak arch-specific details
cd "${S}"
+
case $(tc-arch) in
- ppc64)
- if [[ -e ${ROOT}/dev/hvc ]] ; then
- cat <<-EOF >> etc/inittab
- #HVC CONSOLE
- #hvc0:12345:respawn:/sbin/agetty -L 9600 hvc0
- EOF
- fi
- ;;
sparc)
sed -i -e '/^KEYMAP=/s:us:sunkeymap:' etc/conf.d/keymaps || die
;;
esac
+
+ if use ibm ; then
+ cat <<-EOF >> etc/inittab
+ #HVC / HVSI CONSOLE
+ #hvc0:12345:respawn:/sbin/agetty -L 9600 hvc0
+ #hvsi:12345:respawn:/sbin/agetty -L 19200 hvsi0
+ EOF
+ fi
}
src_compile() {