summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Jackson <iggy@gentoo.org>2004-10-04 05:11:18 +0000
committerBrian Jackson <iggy@gentoo.org>2004-10-04 05:11:18 +0000
commitc78ce34ef9f841dae7747661504e22fa06e66a49 (patch)
tree63a7e87f88c73a2017f4fe5f68fbacd9a243dd5e /sys-apps
parentNo longer setting gentoo version as it breaks some autoconf version checking.... (diff)
downloadgentoo-2-c78ce34ef9f841dae7747661504e22fa06e66a49.tar.gz
gentoo-2-c78ce34ef9f841dae7747661504e22fa06e66a49.tar.bz2
gentoo-2-c78ce34ef9f841dae7747661504e22fa06e66a49.zip
switched custom ARCH setting code to use set_arch_to_* from eutils
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pcmcia-cs/ChangeLog5
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.2.7-r1.ebuild12
2 files changed, 7 insertions, 10 deletions
diff --git a/sys-apps/pcmcia-cs/ChangeLog b/sys-apps/pcmcia-cs/ChangeLog
index 33f160227d33..31417e8040b9 100644
--- a/sys-apps/pcmcia-cs/ChangeLog
+++ b/sys-apps/pcmcia-cs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/pcmcia-cs
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/ChangeLog,v 1.73 2004/09/27 05:23:49 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/ChangeLog,v 1.74 2004/10/04 05:11:18 iggy Exp $
+
+ 04 Oct 2004; <iggy@gentoo.org> pcmcia-cs-3.2.7-r1.ebuild:
+ switched custom ARCH setting code to use set_arch_to_* from eutils
27 Sep 2004; Doug Goldstein <cardoe@gentoo.org> pcmcia-cs-3.2.5-r1.ebuild,
pcmcia-cs-3.2.5.ebuild, pcmcia-cs-3.2.7-r1.ebuild, pcmcia-cs-3.2.7.ebuild:
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.7-r1.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.7-r1.ebuild
index 98fe50c309cd..f7fb4298dea6 100644
--- a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.7-r1.ebuild
+++ b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.7-r1.ebuild,v 1.2 2004/09/27 05:23:49 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.7-r1.ebuild,v 1.3 2004/10/04 05:11:18 iggy Exp $
inherit eutils
@@ -91,14 +91,7 @@ src_compile() {
myconf="${myconf} --cardbus"
fi
- # x86 is not a valid arch for configure... use a case statement
- # here to make it easy for other arches to add their own
- # workarounds.
- case "${ARCH}" in
- x86) myarch="i386" ;;
- *) myarch="${ARCH}" ;;
- esac
-
+ set_arch_to_kernel
# Use $CFLAGS for user tools, but standard kernel optimizations
# for the kernel modules (for compatibility).
#
@@ -122,6 +115,7 @@ src_compile() {
src_install () {
make PREFIX=${D} install || die "failed installing"
+ set_arch_to_portage
# remove included rc scripts since we have our own
rm -rf ${D}/etc/rc*.d