summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Jones <carpaski@gentoo.org>2003-04-09 12:47:45 +0000
committerNicholas Jones <carpaski@gentoo.org>2003-04-09 12:47:45 +0000
commitc312dbcdcd23fc25da80072763c51f6b505795d6 (patch)
tree4444f5724dbcd9e629e070f8fbaa0f62b1bfffac /sys-apps
parentnew version (diff)
downloadgentoo-2-c312dbcdcd23fc25da80072763c51f6b505795d6.tar.gz
gentoo-2-c312dbcdcd23fc25da80072763c51f6b505795d6.tar.bz2
gentoo-2-c312dbcdcd23fc25da80072763c51f6b505795d6.zip
fixing ebuild
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/manifest2
-rw-r--r--sys-apps/portage/portage-2.0.47-r14.ebuild62
2 files changed, 28 insertions, 36 deletions
diff --git a/sys-apps/portage/manifest b/sys-apps/portage/manifest
index c5e8920fb512..fc8629fb9955 100644
--- a/sys-apps/portage/manifest
+++ b/sys-apps/portage/manifest
@@ -1,4 +1,4 @@
-MD5 53fd926221107782a1607643e3371593 portage-2.0.47-r14.ebuild 8797
+MD5 d88eb7be0ee6f5641fa00b247bccd127 portage-2.0.47-r14.ebuild 8901
MD5 9d8eeadd510a609a0cf6714d458a9b10 portage-2.0.47-r13.ebuild 8901
MD5 a90435c5b02c6561a04aab8b2755fd1b portage-2.0.47-r10.ebuild 8844
MD5 30286e3aa7a1e245e2a6ddaa35a090c5 ChangeLog 409
diff --git a/sys-apps/portage/portage-2.0.47-r14.ebuild b/sys-apps/portage/portage-2.0.47-r14.ebuild
index fcabd00cace4..b8bab0d1c928 100644
--- a/sys-apps/portage/portage-2.0.47-r14.ebuild
+++ b/sys-apps/portage/portage-2.0.47-r14.ebuild
@@ -1,5 +1,5 @@
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.47-r14.ebuild,v 1.1 2003/04/09 11:56:12 carpaski Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.47-r14.ebuild,v 1.2 2003/04/09 12:47:41 carpaski Exp $
IUSE="build"
@@ -15,25 +15,7 @@ HOMEPAGE="http://www.gentoo.org"
KEYWORDS="alpha arm hppa mips ppc sparc x86"
#KEYWORDS="~alpha ~arm ~hppa ~mips ~ppc ~sparc ~x86"
LICENSE="GPL-2"
-RDEPEND="!build? ( >=sys-apps/fileutils-4.1.8 dev-python/python-fchksum >=dev-lang/python-2.2.1 sys-apps/debianutils >=app-shells/bash-2.05a )"
-
-get_portver() {
- python -c "import portage,string; print string.join(portage.pkgsplit(portage.best(portage.db[\"${ROOT}\"][\"vartree\"].dbapi.match(\"sys-apps/portage\"))))"
-}
-
-compare_pver() {
- if python -c "import portage,string,sys; sys.exit(portage.pkgcmp(string.split(\"$1\"),string.split(\"$2\"))>=0)"; then
- return 0
- fi
- return 1
-}
-
-src_unpack() {
- cd ${WORKDIR}
- echo tar xjf ${DISTDIR}/${PF}.tar.bz2
- tar xjf ${DISTDIR}/${PF}.tar.bz2 || die "No portage tarball in distfiles."
- #get_portver > ${WORKDIR}/previous-version
-}
+RDEPEND="!build? ( >=sys-apps/sed-4.0.5 >=sys-apps/fileutils-4.1.8 dev-python/python-fchksum >=dev-lang/python-2.2.1 sys-apps/debianutils >=app-shells/bash-2.05a )"
src_compile() {
cd ${S}/src; gcc ${CFLAGS} tbz2tool.c -o tbz2tool
@@ -43,6 +25,7 @@ src_compile() {
else
make || die
fi
+ cd ${S}/bin
}
src_install() {
@@ -78,7 +61,7 @@ src_install() {
doins make.globals make.conf
;;
esac
- use build && rm -f ${D}/etc/make.conf
+ use build && [ -f /etc/make.conf ] && rm -f ${D}/etc/make.conf
doins etc-update.conf dispatch-conf.conf
#python modules
@@ -87,7 +70,7 @@ src_install() {
./setup.py install --root ${D} || die
cd ${S}/pym
insinto /usr/lib/python2.2/site-packages
- doins xpak.py portage.py output.py
+ doins xpak.py portage.py output.py cvstree.py
#binaries, libraries and scripts
@@ -110,11 +93,11 @@ src_install() {
dosym ../lib/portage/bin/ebuild.sh /usr/sbin/ebuild.sh
dosym ../lib/portage/bin/etc-update /usr/sbin/etc-update
- #dosym /usr/lib/portage/bin/portage-maintain /usr/sbin/portage-maintain
dosym ../lib/portage/bin/env-update /usr/sbin/env-update
dosym ../lib/portage/bin/xpak /usr/bin/xpak
dosym ../lib/portage/bin/repoman /usr/bin/repoman
dosym ../lib/portage/bin/tbz2tool /usr/bin/tbz2tool
+ dosym ../lib/portage/bin/portageq /usr/bin/portageq
dosym ../lib/portage/bin/g-cpan.pl /usr/bin/g-cpan.pl
dosym ../lib/portage/bin/quickpkg /usr/bin/quickpkg
@@ -161,11 +144,11 @@ pkg_postinst() {
fi
echo
- einfo "NOTICE: PLEASE update your make.globals. All user changes to variables"
- einfo "in make.globals should be placed in make.conf. DO NOT MODIFY make.globals."
+ eerror "NOTICE: PLEASE update your make.globals. All user changes to variables"
+ eerror "in make.globals should be placed in make.conf. DO NOT MODIFY make.globals."
echo
- einfo "NOTICE: The wheel group requirement for non-root users has been changed to"
- einfo "group portage. Group portage must be a valid group for user to use portage."
+ eerror "NOTICE: The wheel group requirement for non-root users has been changed to"
+ eerror "group portage. Group portage must be a valid group for user to use portage."
echo
einfo "Feature additions are noted in help and make.conf descriptions. Update"
einfo "them using 'etc-update' please. Maintaining current configs for portage"
@@ -176,16 +159,19 @@ pkg_postinst() {
einfo "should be in your worldfile but were removed by a recently discovered"
einfo "'-e bug' or if you deleted it: run 'regenworld' as root."
echo
- einfo "The 2.0.47 line of portages contains an optional userpriv mode that"
- einfo "enables portage to drop root privleges and run as a normal user. It is"
- einfo "enabled via FEATURES by adding userpriv."
- echo
- einfo "Please 'emerge sync' after merging portage to update some permissions."
+ eerror "The late 2.0.47 portages contains enhanced digests which contain all"
+ eerror "the files and ebuilds used, not just the archives extracted. This is to"
+ eerror "help discovering corruption and increasing security and should require"
+ eerror "no extra work from end-users. If portage reports a bad file that is not"
+ eerror "in the distfiles directory, after you've deleted it an re-sync'd, report it."
echo
if [ -z $PORTAGE_TEST ]; then
- echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
- echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
- sleep 5
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ sleep 8
# Kill the existing counter and generate a new one.
echo -n "Recalculating the counter... "
@@ -236,6 +222,8 @@ pkg_postinst() {
rm -f ${ROOT}usr/lib/python2.2/site-packages/portage.py[co]
rm -f ${ROOT}usr/lib/python2.2/site-packages/output.py[co]
+ rm -f ${ROOT}usr/lib/python2.2/site-packages/cvstree.py[co]
+ rm -f ${ROOT}usr/lib/python2.2/site-packages/emergehelp.py[co]
chmod 2775 ${ROOT}var/cache/edb/dep ${ROOT}var/cache/edb/dep/*
chown -R root.wheel ${ROOT}var/cache/edb/dep
@@ -244,6 +232,8 @@ pkg_postinst() {
python -O -c "import py_compile; py_compile.compile('${ROOT}usr/lib/python2.2/site-packages/portage.py')" || die
python -c "import py_compile; py_compile.compile('${ROOT}usr/lib/python2.2/site-packages/output.py')" || die
python -O -c "import py_compile; py_compile.compile('${ROOT}usr/lib/python2.2/site-packages/output.py')" || die
+ python -c "import py_compile; py_compile.compile('${ROOT}usr/lib/python2.2/site-packages/cvstree.py')" || die
+ python -O -c "import py_compile; py_compile.compile('${ROOT}usr/lib/python2.2/site-packages/cvstree.py')" || die
python -c "import py_compile; py_compile.compile('${ROOT}usr/lib/portage/bin/emergehelp.py')" || die
python -O -c "import py_compile; py_compile.compile('${ROOT}usr/lib/portage/bin/emergehelp.py')" || die
@@ -252,3 +242,5 @@ pkg_postinst() {
chmod -R g+rws /var/tmp/ccache &>/dev/null
fi
}
+
+