summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-19 06:22:27 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-19 06:22:27 +0000
commitacc3933de06bedbb58b1f7d04080b6518eb9ffd7 (patch)
tree523171cd8fc80cd1c0bd3e5de73535b53ba22dfd /sys-apps
parentAdded ~sparc keyword. (Manifest recommit) (diff)
downloadgentoo-2-acc3933de06bedbb58b1f7d04080b6518eb9ffd7.tar.gz
gentoo-2-acc3933de06bedbb58b1f7d04080b6518eb9ffd7.tar.bz2
gentoo-2-acc3933de06bedbb58b1f7d04080b6518eb9ffd7.zip
clean up and add arm for testing
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/chpax/chpax-0.6.1.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/sys-apps/chpax/chpax-0.6.1.ebuild b/sys-apps/chpax/chpax-0.6.1.ebuild
index 7f54ca1f2088..31e0308e53a0 100644
--- a/sys-apps/chpax/chpax-0.6.1.ebuild
+++ b/sys-apps/chpax/chpax-0.6.1.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/chpax/chpax-0.6.1.ebuild,v 1.8 2004/06/01 20:31:48 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/chpax/chpax-0.6.1.ebuild,v 1.9 2004/06/19 06:22:27 vapier Exp $
-inherit flag-o-matic
+inherit flag-o-matic gcc
DESCRIPTION="Manages various PaX related flags for ELF32, ELF64, and a.out binaries."
+HOMEPAGE="http://pax.grsecurity.net/"
SRC_URI="mirror://chpax-${PV}.tar.bz2
http://dev.gentoo.org/~solar/pax/chpax/chpax-${PV}.tar.bz2"
-HOMEPAGE="http://pax.grsecurity.net"
-KEYWORDS="x86 amd64 sparc ppc hppa ia64 ~mips alpha"
+
LICENSE="public-domain"
SLOT="0"
-
+KEYWORDS="x86 ppc sparc ~mips alpha ~arm hppa amd64 ia64"
#IUSE="static"
+
DEPEND="virtual/glibc"
src_unpack() {
@@ -23,13 +24,12 @@ src_unpack() {
src_compile() {
# use static && append-ldflags -static ; # breaks with current ssp.
-
- emake CC="${CC}" TARGET="chpax ${LDFLAGS:0}" || die "Parallel Make Failed"
+ emake CC="$(gcc-getCC)" TARGET="chpax ${LDFLAGS:0}" || die "Parallel Make Failed"
}
src_install() {
into /
- dosbin chpax
+ dosbin chpax || die
fperms 711 /sbin/chpax
dodoc Changelog README
@@ -39,5 +39,4 @@ src_install() {
newins ${FILESDIR}/pax-conf.d chpax
exeinto /etc/init.d
newexe ${FILESDIR}/pax-init.d chpax
-
}