summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-06-08 21:43:04 +0000
committerMike Frysinger <vapier@gentoo.org>2010-06-08 21:43:04 +0000
commita390abab96eb3378a379b5d1f30eddabdecc9fa1 (patch)
tree969292dcae0fa0dc6f96ccd5f022814b74358282 /sys-apps
parentFix dependencies (bug #323189). (diff)
downloadgentoo-2-a390abab96eb3378a379b5d1f30eddabdecc9fa1.tar.gz
gentoo-2-a390abab96eb3378a379b5d1f30eddabdecc9fa1.tar.bz2
gentoo-2-a390abab96eb3378a379b5d1f30eddabdecc9fa1.zip
Version bump #292840 by Mr. Anderson and Michał Górny.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/attr/ChangeLog10
-rw-r--r--sys-apps/attr/attr-2.4.44.ebuild52
-rw-r--r--sys-apps/attr/files/attr-2.4.44-gettext.patch63
-rw-r--r--sys-apps/attr/files/attr-2.4.44-headers.patch12
4 files changed, 135 insertions, 2 deletions
diff --git a/sys-apps/attr/ChangeLog b/sys-apps/attr/ChangeLog
index 632d2136c3f0..7fb329b76ced 100644
--- a/sys-apps/attr/ChangeLog
+++ b/sys-apps/attr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/attr
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.117 2009/03/14 12:31:23 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.118 2010/06/08 21:43:04 vapier Exp $
+
+*attr-2.4.44 (08 Jun 2010)
+
+ 08 Jun 2010; Mike Frysinger <vapier@gentoo.org> +attr-2.4.44.ebuild,
+ +files/attr-2.4.44-gettext.patch, +files/attr-2.4.44-headers.patch:
+ Version bump #292840 by Mr. Anderson and Michał Górny.
06 Mar 2009; Jeroen Roovers <jer@gentoo.org> attr-2.4.43.ebuild:
Stable for HPPA (bug #259431).
diff --git a/sys-apps/attr/attr-2.4.44.ebuild b/sys-apps/attr/attr-2.4.44.ebuild
new file mode 100644
index 000000000000..3338888c6bdc
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.44.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.44.ebuild,v 1.1 2010/06/08 21:43:04 vapier Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Extended attributes tools"
+HOMEPAGE="http://savannah.nongnu.org/projects/attr"
+SRC_URI="mirror://nongnu/${PN}/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )
+ sys-devel/autoconf"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4.44-gettext.patch
+ epatch "${FILESDIR}"/${P}-headers.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+ strip-linguas po
+}
+
+src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ $(use_enable nls gettext) \
+ --libexecdir=/usr/$(get_libdir) \
+ --bindir=/bin
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install install-lib install-dev || die
+ # the man-pages packages provides the man2 files
+ rm -r "${D}"/usr/share/man/man2
+ prepalldocs
+
+ # we install attr into /bin, so we need the shared lib with it
+ gen_usr_ldscript -a attr
+}
diff --git a/sys-apps/attr/files/attr-2.4.44-gettext.patch b/sys-apps/attr/files/attr-2.4.44-gettext.patch
new file mode 100644
index 000000000000..49c2d32bdce4
--- /dev/null
+++ b/sys-apps/attr/files/attr-2.4.44-gettext.patch
@@ -0,0 +1,63 @@
+--- include/gettext.h
++++ include/gettext.h
+@@ -0,0 +1,10 @@
++#include <config.h>
++#ifdef ENABLE_GETTEXT
++# include <libintl.h>
++# define _(x) gettext(x)
++#else
++# define _(x) (x)
++# define textdomain(d) do { } while (0)
++# define bindtextdomain(d,dir) do { } while (0)
++#endif
++#include <locale.h>
+--- attr/attr.c
++++ attr/attr.c
+@@ -26,6 +26,7 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <locale.h>
++#include "gettext.h"
+
+ #include <attr/attributes.h>
+ #include "config.h"
+--- libattr/attr_copy_file.c.orig 2007-09-20 02:51:37.000000000 -0400
++++ libattr/attr_copy_file.c 2007-09-20 02:51:51.000000000 -0400
+@@ -19,6 +19,7 @@
+
+ #if defined (HAVE_CONFIG_H)
+ #include "config.h"
++#include "gettext.h"
+ #endif
+
+ #include <sys/types.h>
+--- libattr/attr_copy_fd.c.orig 2007-09-20 02:52:23.000000000 -0400
++++ libattr/attr_copy_fd.c 2007-09-20 02:52:31.000000000 -0400
+@@ -19,6 +19,7 @@
+
+ #if defined (HAVE_CONFIG_H)
+ #include "config.h"
++#include "gettext.h"
+ #endif
+
+ #include <sys/types.h>
+--- getfattr/getfattr.c.orig 2007-09-20 02:52:49.000000000 -0400
++++ getfattr/getfattr.c 2007-09-20 02:52:59.000000000 -0400
+@@ -30,6 +30,7 @@
+ #include <regex.h>
+ #include <ftw.h>
+ #include <locale.h>
++#include "gettext.h"
+
+ #include <attr/xattr.h>
+ #include "config.h"
+--- setfattr/setfattr.c.orig 2007-09-20 02:53:12.000000000 -0400
++++ setfattr/setfattr.c 2007-09-20 02:53:20.000000000 -0400
+@@ -28,6 +28,7 @@
+ #include <getopt.h>
+ #include <locale.h>
+ #include <ctype.h>
++#include "gettext.h"
+
+ #include <attr/xattr.h>
+ #include "config.h"
diff --git a/sys-apps/attr/files/attr-2.4.44-headers.patch b/sys-apps/attr/files/attr-2.4.44-headers.patch
new file mode 100644
index 000000000000..9d97fd3ad3c7
--- /dev/null
+++ b/sys-apps/attr/files/attr-2.4.44-headers.patch
@@ -0,0 +1,12 @@
+needs string.h for strchr()
+
+--- attr/libmisc/quote.c
++++ attr/libmisc/quote.c
+@@ -19,6 +19,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <ctype.h>
+ #include "misc.h"
+