summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Bennett <spb@gentoo.org>2006-05-05 12:08:33 +0000
committerStephen Bennett <spb@gentoo.org>2006-05-05 12:08:33 +0000
commit9f3c8551cd23e045bc175fe5645d89af6250405a (patch)
tree2760c6fe222c39460ec7fb7f5fa4b9eb1e4b77cd /sys-apps
parentversion bump and remove old versions (diff)
downloadgentoo-2-9f3c8551cd23e045bc175fe5645d89af6250405a.tar.gz
gentoo-2-9f3c8551cd23e045bc175fe5645d89af6250405a.tar.bz2
gentoo-2-9f3c8551cd23e045bc175fe5645d89af6250405a.zip
Version bump.
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/paludis/files/digest-paludis-0.2.23
-rw-r--r--sys-apps/paludis/paludis-0.2.2.ebuild54
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/paludis/files/digest-paludis-0.2.2 b/sys-apps/paludis/files/digest-paludis-0.2.2
new file mode 100644
index 000000000000..17de649969a3
--- /dev/null
+++ b/sys-apps/paludis/files/digest-paludis-0.2.2
@@ -0,0 +1,3 @@
+MD5 457165bb4b418b561ce2c96507f5651e paludis-0.2.2.tar.bz2 381202
+RMD160 872a1390a19c9826b59ebcb058e3372100aea55c paludis-0.2.2.tar.bz2 381202
+SHA256 ad655c83d140b80a08d8b6ac22baee4ca323a016d43a354ec072f2d770582097 paludis-0.2.2.tar.bz2 381202
diff --git a/sys-apps/paludis/paludis-0.2.2.ebuild b/sys-apps/paludis/paludis-0.2.2.ebuild
new file mode 100644
index 000000000000..9e61479ec6d4
--- /dev/null
+++ b/sys-apps/paludis/paludis-0.2.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/paludis-0.2.2.ebuild,v 1.1 2006/05/05 12:08:33 spb Exp $
+
+DESCRIPTION="paludis, the other package mangler"
+HOMEPAGE="http://paludis.berlios.de/"
+SRC_URI="http://download.berlios.de/paludis/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="
+ dev-cpp/libebt
+ >=app-shells/bash-3
+ doc? ( app-doc/doxygen )"
+
+RDEPEND="
+ >=app-admin/eselect-1.0.2
+ >=app-shells/bash-3
+ net-misc/wget
+ net-misc/rsync
+ !mips? ( sys-apps/sandbox )"
+
+PROVIDE="virtual/portage"
+
+src_compile() {
+ econf --disable-qa \
+ $(use_enable doc doxygen ) \
+ $(use_enable !mips sandbox ) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+ if use doc ; then
+ make doxygen || die "make doxygen failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS README ChangeLog NEWS
+
+ if use doc ; then
+ dohtml -r doc/html/
+ fi
+}
+
+src_test() {
+ # Work around Portage bug
+ addwrite /var/cache
+ emake check || die "Make check failed"
+}
+