summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2006-10-08 01:21:20 +0000
committerZac Medico <zmedico@gentoo.org>2006-10-08 01:21:20 +0000
commit6fdbc638ebe1b7d6af30abe594324c0b5408569e (patch)
tree4e2e9ec7ef0e6ccc11a1d4791c3ec8eb99c9d684 /sys-apps
parentInitial ebuild by Aggelos Orfanakos <agorf@void.gr>, #145815 (diff)
downloadgentoo-2-6fdbc638ebe1b7d6af30abe594324c0b5408569e.tar.gz
gentoo-2-6fdbc638ebe1b7d6af30abe594324c0b5408569e.tar.bz2
gentoo-2-6fdbc638ebe1b7d6af30abe594324c0b5408569e.zip
2.1.2_pre2-r6 revbump. This fixes bugs #149608, #150359, #150377, and #150381.
(Portage version: 2.1.2_pre2-r6)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/ChangeLog9
-rw-r--r--sys-apps/portage/files/dep_transform.patch12
-rw-r--r--sys-apps/portage/files/digest-portage-2.1.2_pre2-r69
-rw-r--r--sys-apps/portage/portage-2.1.2_pre2-r6.ebuild206
4 files changed, 235 insertions, 1 deletions
diff --git a/sys-apps/portage/ChangeLog b/sys-apps/portage/ChangeLog
index 15317de69583..9b2398059e7b 100644
--- a/sys-apps/portage/ChangeLog
+++ b/sys-apps/portage/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/portage
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.263 2006/10/06 11:36:47 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.264 2006/10/08 01:21:20 zmedico Exp $
+
+*portage-2.1.2_pre2-r6 (08 Oct 2006)
+
+ 08 Oct 2006; Zac Medico <zmedico@gentoo.org> +portage-2.1.2_pre2-r6.ebuild,
+ +files/dep_transform.patch:
+ 2.1.2_pre2-r6 revbump. This fixes bugs #149608, #150359, #150377, and
+ #150381.
*portage-2.1.2_pre2-r5 (06 Oct 2006)
diff --git a/sys-apps/portage/files/dep_transform.patch b/sys-apps/portage/files/dep_transform.patch
new file mode 100644
index 000000000000..c4760111671a
--- /dev/null
+++ b/sys-apps/portage/files/dep_transform.patch
@@ -0,0 +1,12 @@
+Index: pym/portage_update.py
+===================================================================
+--- pym/portage_update.py (revision 4616)
++++ pym/portage_update.py (revision 4617)
+@@ -214,4 +214,6 @@
+ continue
+
+ def dep_transform(mydep, oldkey, newkey):
+- return mydep.replace(oldkey, newkey, 1)
++ if dep_getkey(mydep) == oldkey:
++ return mydep.replace(oldkey, newkey, 1)
++ return mydep
diff --git a/sys-apps/portage/files/digest-portage-2.1.2_pre2-r6 b/sys-apps/portage/files/digest-portage-2.1.2_pre2-r6
new file mode 100644
index 000000000000..4752bcda721c
--- /dev/null
+++ b/sys-apps/portage/files/digest-portage-2.1.2_pre2-r6
@@ -0,0 +1,9 @@
+MD5 07ba5c5c4277aaa5e23b031dce2932d7 portage-2.1.2_pre2-r6.patch.bz2 11618
+RMD160 de8fa5c9d3dc263cdb488d49935d05e3fd633a24 portage-2.1.2_pre2-r6.patch.bz2 11618
+SHA256 8ac31dbfddadf4e383595090dd8268bb4b3b9a79523daf97050bf893738522a4 portage-2.1.2_pre2-r6.patch.bz2 11618
+MD5 5b419eec00e4534c412ac7e9ac92760b portage-2.1.2_pre2.tar.bz2 302712
+RMD160 4bd9d9b3ce76c63d4b86d12c5645403be54903c0 portage-2.1.2_pre2.tar.bz2 302712
+SHA256 caa9828537310067885c365ee49b72d6827cedc781c85825795a46932740e0e3 portage-2.1.2_pre2.tar.bz2 302712
+MD5 322f3be926245292fc0c90bc1bf2d8cd portage-man-pl-2.1.2_pre2.tar.bz2 52838
+RMD160 c3d9d59fd68606cb9c1b3f058a1ba2ebb6774101 portage-man-pl-2.1.2_pre2.tar.bz2 52838
+SHA256 cda86d66967304338c73eb391a782aeee0b239c03d3484df04ca8db2a31bfc8c portage-man-pl-2.1.2_pre2.tar.bz2 52838
diff --git a/sys-apps/portage/portage-2.1.2_pre2-r6.ebuild b/sys-apps/portage/portage-2.1.2_pre2-r6.ebuild
new file mode 100644
index 000000000000..6e02754c14c3
--- /dev/null
+++ b/sys-apps/portage/portage-2.1.2_pre2-r6.ebuild
@@ -0,0 +1,206 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.2_pre2-r6.ebuild,v 1.1 2006/10/08 01:21:20 zmedico Exp $
+
+inherit toolchain-funcs eutils flag-o-matic
+
+DESCRIPTION="The Portage Package Management System. The primary package management and distribution system for Gentoo."
+HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+PROVIDE="virtual/portage"
+SLOT="0"
+# USE_EXPAND_HIDDEN hides ELIBC and USERLAND expansions from emerge output (see make.conf.5).
+IUSE_ELIBC="elibc_glibc elibc_uclibc elibc_FreeBSD"
+IUSE_USERLAND="userland_Darwin userland_GNU"
+IUSE="build doc selinux linguas_pl ${IUSE_ELIBC} ${IUSE_USERLAND}"
+DEPEND=">=dev-lang/python-2.3
+ !build? ( >=sys-apps/sed-4.0.5 )"
+RDEPEND=">=dev-lang/python-2.3
+ !build? ( >=sys-apps/sed-4.0.5
+ dev-python/python-fchksum
+ !userland_Darwin? ( >=app-shells/bash-3.0 ) )
+ elibc_glibc? ( sys-apps/sandbox )
+ elibc_uclibc? ( sys-apps/sandbox )
+ !userland_Darwin? ( >=app-misc/pax-utils-0.1.13 )
+ selinux? ( >=dev-python/python-selinux-2.16 )
+ doc? ( app-portage/portage-manpages )
+ >=dev-python/pycrypto-2.0.1-r5"
+SRC_ARCHIVES="http://dev.gentoo.org/~zmedico/portage/archives"
+
+PV_PL="2.1.2_pre2"
+PATCHVER_PL=""
+SRC_URI="mirror://gentoo/${PN}-${PV}.tar.bz2
+ ${SRC_ARCHIVES}/${PN}-${PV}.tar.bz2
+ linguas_pl? ( mirror://gentoo/${PN}-man-pl-${PV_PL}.tar.bz2
+ ${SRC_ARCHIVES}/${PN}-man-pl-${PV_PL}.tar.bz2 )"
+
+PATCHVER=""
+[ "${PR}" != "r0" ] && PATCHVER="-${PR}"
+if [ -n "${PATCHVER}" ]; then
+ SRC_URI="${SRC_URI} mirror://gentoo/${PN}-${PV}${PATCHVER}.patch.bz2
+ ${SRC_ARCHIVES}/${PN}-${PV}${PATCHVER}.patch.bz2"
+fi
+
+if [ -n "${PATCHVER_PL}" ]; then
+ SRC_URI="${SRC_URI} linguas_pl? ( mirror://gentoo/${PN}-man-pl-${PV_PL}${PATCHVER_PL}.patch.bz2
+ ${SRC_ARCHIVES}/${PN}-man-pl-${PV_PL}${PATCHVER_PL}.patch.bz2 )"
+fi
+
+S="${WORKDIR}"/${PN}-${PV}
+S_PL="${WORKDIR}"/${PN}-${PV_PL}
+
+portage_docs() {
+ elog ""
+ elog "For help with using portage please consult the Gentoo Handbook"
+ elog "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
+ elog ""
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if [ -n "${PATCHVER}" ]; then
+ cd "${S}"
+ epatch "${WORKDIR}/${PN}-${PV}${PATCHVER}.patch"
+ fi
+ if [ "${PR}" != "r0" ]; then
+ elog "Setting portage.VERSION to ${PVR} ..."
+ sed -i "s/^VERSION=.*/VERSION=\"${PVR}\"/" pym/portage.py || \
+ die "Failed to patch portage.VERSION"
+ eend 0
+ fi
+ if [ -n "${PATCHVER_PL}" ]; then
+ use linguas_pl && \
+ epatch "${WORKDIR}/${PN}-man-pl-${PV_PL}${PATCHVER_PL}.patch"
+ fi
+ epatch "${FILESDIR}"/dep_transform.patch
+}
+
+src_compile() {
+ append-lfs-flags
+
+ cd "${S}"/src
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o tbz2tool tbz2tool.c || \
+ die "Failed to build tbz2tool"
+
+ if use elibc_FreeBSD; then
+ cd "${S}"/src/bsd-flags
+ chmod +x setup.py
+ ./setup.py build || die "Failed to install bsd-chflags module"
+ fi
+}
+
+src_install() {
+ local portage_base="/usr/lib/portage"
+ cd "${S}"/cnf
+ insinto /etc
+ doins etc-update.conf dispatch-conf.conf make.globals
+ if [ -f "make.conf.${ARCH}".diff ]; then
+ patch make.conf "make.conf.${ARCH}".diff || \
+ die "Failed to patch make.conf.example"
+ newins make.conf make.conf.example
+ else
+ eerror ""
+ eerror "Portage does not have an arch-specific configuration for this arch."
+ eerror "Please notify the arch maintainer about this issue. Using generic."
+ eerror ""
+ newins make.conf make.conf.example
+ fi
+
+ if use elibc_FreeBSD; then
+ cd "${S}"/src/bsd-flags
+ ./setup.py install --root "${D}" || \
+ die "Failed to install bsd-chflags module"
+ fi
+
+ dodir ${portage_base}/bin
+ exeinto ${portage_base}/bin
+ # BSD and OSX need a sed wrapper so that find/xargs work properly
+ if use userland_GNU; then
+ rm "${S}"/bin/sed || die "Failed to remove sed wrapper"
+ fi
+ cd "${S}"/bin
+ doexe *
+ doexe "${S}"/src/tbz2tool
+ dosym newins ${portage_base}/bin/donewins
+
+ for mydir in pym pym/cache pym/elog_modules; do
+ dodir ${portage_base}/${mydir}
+ insinto ${portage_base}/${mydir}
+ cd "${S}"/${mydir}
+ doins *.py
+ done
+
+ doman "${S}"/man/*.[0-9]
+ if use linguas_pl; then
+ doman -i18n=pl "${S_PL}"/man/pl/*.[0-9]
+ doman -i18n=pl_PL.UTF-8 "${S_PL}"/man/pl_PL.UTF-8/*.[0-9]
+ fi
+ dodoc "${S}"/ChangeLog
+ dodoc "${S}"/NEWS
+ dodoc "${S}"/RELEASE-NOTES
+
+ dodir /usr/bin
+ for x in ebuild emerge portageq repoman tbz2tool xpak; do
+ dosym ../lib/portage/bin/${x} /usr/bin/${x}
+ done
+
+ dodir /usr/sbin
+ local my_syms="archive-conf
+ dispatch-conf
+ emaint
+ emerge-webrsync
+ env-update
+ etc-update
+ fixpackages
+ quickpkg
+ regenworld"
+ local x
+ for x in ${my_syms}; do
+ dosym ../lib/portage/bin/${x} /usr/sbin/${x}
+ done
+
+ dodir /etc/portage
+ keepdir /etc/portage
+
+ doenvd "${FILESDIR}"/05portage.envd
+}
+
+pkg_preinst() {
+ local portage_base="/usr/lib/portage"
+ if has livecvsportage ${FEATURES} && [ "${ROOT}" = "/" ]; then
+ rm -rf "${IMAGE}"/${portage_base}/pym/*
+ mv "${IMAGE}"/${portage_base}/bin/tbz2tool "${T}"
+ rm -rf "${IMAGE}"/${portage_base}/bin/*
+ mv "${T}"/tbz2tool "${IMAGE}"/${portage_base}/bin/
+ else
+ for mydir in pym pym/cache pym/elog_modules; do
+ rm "${ROOT}"/${portage_base}/${mydir}/*.pyc >& /dev/null
+ rm "${ROOT}"/${portage_base}/${mydir}/*.pyo >& /dev/null
+ done
+ fi
+}
+
+pkg_postinst() {
+ local x
+
+ if [ ! -f "${ROOT}/var/lib/portage/world" ] &&
+ [ -f "${ROOT}"/var/cache/edb/world ] &&
+ [ ! -h "${ROOT}"/var/cache/edb/world ]; then
+ mv "${ROOT}"/var/cache/edb/world "${ROOT}"/var/lib/portage/world
+ ln -s ../../lib/portage/world /var/cache/edb/world
+ fi
+
+ for x in "${ROOT}"/etc/._cfg????_make.globals; do
+ # Overwrite the globals file automatically.
+ [ -e "${x}" ] && mv -f "${x}" "${ROOT}etc/make.globals"
+ done
+
+ ewarn "In portage-2.1.2, installation actions do not necessarily pull in build time"
+ ewarn "dependencies that are not strictly required. This behavior is adjustable"
+ ewarn "via the new --with-bdeps option that is documented in the emerge(1) man page."
+ ewarn "For more information regarding this change, please refer to bug #148870."
+
+ portage_docs
+}