summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-07-10 12:06:26 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-07-10 12:06:26 +0000
commit634833b2e293ff911016b70c6556259cf8001ff9 (patch)
treeaf1d622b3fc8f19e8912d88181b0d0f3f8d7535f /sys-apps
parentVersion bump, closes bug 24155 (diff)
downloadgentoo-2-634833b2e293ff911016b70c6556259cf8001ff9.tar.gz
gentoo-2-634833b2e293ff911016b70c6556259cf8001ff9.tar.bz2
gentoo-2-634833b2e293ff911016b70c6556259cf8001ff9.zip
Version bump, closes bug 24155
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/lilo/ChangeLog8
-rw-r--r--sys-apps/lilo/Manifest4
-rw-r--r--sys-apps/lilo/files/digest-lilo-22.5.61
-rw-r--r--sys-apps/lilo/lilo-22.5.6.ebuild192
4 files changed, 202 insertions, 3 deletions
diff --git a/sys-apps/lilo/ChangeLog b/sys-apps/lilo/ChangeLog
index 88868e66906b..85d5ab55b600 100644
--- a/sys-apps/lilo/ChangeLog
+++ b/sys-apps/lilo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/lilo
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/ChangeLog,v 1.23 2003/07/10 10:03:31 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/ChangeLog,v 1.24 2003/07/10 12:06:08 phosphan Exp $
+
+*lilo-22.5.6 (10 Jul 2003)
+
+ 10 Jul 2003; Patrick Kursawe <phosphan@gentoo.org> lilo-22.5.6.ebuild:
+ Version bump. Using new download URI which quite likely will have to be
+ changed to .../obsolete/ soon :-(
10 Jul 2003; Patrick Kursawe <phosphan@gentoo.org> lilo-22.3.4.ebuild,
lilo-22.5.1.ebuild, lilo-22.5.5.ebuild:
diff --git a/sys-apps/lilo/Manifest b/sys-apps/lilo/Manifest
index e221d21438cf..084ee3978382 100644
--- a/sys-apps/lilo/Manifest
+++ b/sys-apps/lilo/Manifest
@@ -1,8 +1,8 @@
MD5 ce88b98514e48eeb2fc2005bd2e7c6f4 lilo-22.3.3-r1.ebuild 1999
-MD5 7be0bb3559f577f509403afcefa55a5c lilo-22.5.6.ebuild 4608
+MD5 197a266fc570837070f41505995c8bed lilo-22.5.6.ebuild 4608
MD5 858efb42f81f68c6659a13093c77d1bc lilo-22.5.1.ebuild 4528
MD5 9196bc4123ba28cd71702b2d7b6ba983 lilo-22.3.4.ebuild 2004
-MD5 1fd5f34bafdcce76609d90a0e50792c9 ChangeLog 3697
+MD5 bbc3c245e5569e09fe6e1a30780a1cd7 ChangeLog 3909
MD5 4ec5fe27915d3d095bcaf8d987d22d0c lilo-22.5.5.ebuild 4615
MD5 d6daac26992f472c13439776f9262b58 lilo-22.1-r3.ebuild 1583
MD5 00de3473e03e180faad32ed00335cc7b files/digest-lilo-22.1-r3 61
diff --git a/sys-apps/lilo/files/digest-lilo-22.5.6 b/sys-apps/lilo/files/digest-lilo-22.5.6
new file mode 100644
index 000000000000..5cd39211f2f0
--- /dev/null
+++ b/sys-apps/lilo/files/digest-lilo-22.5.6
@@ -0,0 +1 @@
+MD5 fd85e0cd157e77c1f565dbe649cbaaab lilo-22.5.6.tar.gz 406705
diff --git a/sys-apps/lilo/lilo-22.5.6.ebuild b/sys-apps/lilo/lilo-22.5.6.ebuild
new file mode 100644
index 000000000000..104b3c48629d
--- /dev/null
+++ b/sys-apps/lilo/lilo-22.5.6.ebuild
@@ -0,0 +1,192 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.5.6.ebuild,v 1.1 2003/07/10 12:06:10 phosphan Exp $
+
+inherit mount-boot eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Standard Linux boot loader"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/${P}.tar.gz"
+# mirror://gentoo/${P}-gentoo.diff.bz2"
+HOMEPAGE="http://brun.dyndns.org/pub/linux/lilo/"
+
+SLOT="0"
+LICENSE="BSD GPL-2"
+KEYWORDS="-* ~x86"
+
+DEPEND="dev-lang/nasm
+ >=sys-devel/bin86-0.15.5"
+
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ unpack ${P}.tar.gz || die
+ cd ${S}
+
+ # Get all the loaders to install
+# cp Makefile Makefile.orig
+# sed -e 's:# $(BOOTS): $(BOOTS):' Makefile.orig > Makefile
+
+ # This bootlogo patch is borrowed from SuSE Linux.
+ # You should see Raphaël Quinet's (quinet@gamers.org) website,
+ # http://www.gamers.org/~quinet/lilo/index.html
+# epatch ${DISTDIR}/${P}-gentoo.diff.bz2
+}
+
+src_compile() {
+ [ -z "${CC}" ] && CC="gcc"
+
+ emake CC="${CC}" OPT="-O1" \
+ lilo bootsect.b edit activate \
+ $(grep '^BOOTS' Makefile | sed -e 's:^BOOTS=::') || die
+}
+
+src_install() {
+ into /
+ dosbin lilo activate mkrescue
+ into /usr
+ dosbin keytab-lilo.pl
+
+ dodir /boot
+ insinto /boot
+ doins boot-text.b boot-menu.b boot-bmp.b chain.b mbr.b os2_d.b
+
+ insinto /etc
+ newins ${FILESDIR}/lilo.conf lilo.conf.example
+
+ doman manPages/*.[5-8]
+ dodoc CHANGES COPYING INCOMPAT README*
+ docinto samples ; dodoc sample/*
+}
+
+pkg_preinst() {
+ mount-boot_mount_boot_partition
+
+ if [ ! -L ${ROOT}/boot/boot.b -a -f ${ROOT}/boot/boot.b ]
+ then
+ einfo "Saving old boot.b..."
+ mv -f ${ROOT}/boot/boot.b ${ROOT}/boot/boot.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/boot-text.b -a -f ${ROOT}/boot/boot-text.b ]
+ then
+ einfo "Saving old boot-text.b..."
+ mv -f ${ROOT}/boot/boot-text.b ${ROOT}/boot/boot-text.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/boot-menu.b -a -f ${ROOT}/boot/boot-menu.b ]
+ then
+ einfo "Saving old boot-menu.b..."
+ mv -f ${ROOT}/boot/boot-menu.b ${ROOT}/boot/boot-menu.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/boot-bmp.b -a -f ${ROOT}/boot/boot-bmp.b ]
+ then
+ einfo "Saving old boot-bmp.b..."
+ mv -f ${ROOT}/boot/boot-bmp.b ${ROOT}/boot/boot-bmp.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/chain.b -a -f ${ROOT}/boot/chain.b ]
+ then
+ einfo "Saving old chain.b..."
+ mv -f ${ROOT}/boot/chain.b ${ROOT}/boot/chain.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/mbr.b -a -f ${ROOT}/boot/mbr.b ]
+ then
+ einfo "Saving old mbr.b..."
+ mv -f ${ROOT}/boot/mbr.b ${ROOT}/boot/mbr.old
+ fi
+
+ if [ ! -L ${ROOT}/boot/os2_d.b -a -f ${ROOT}/boot/os2_d.b ]
+ then
+ einfo "Saving old os2_d.b..."
+ mv -f ${ROOT}/boot/os2_d.b ${ROOT}/boot/os2_d.old
+ fi
+}
+
+# Check whether LILO is installed
+# This function is from /usr/sbin/mkboot from debianutils, with copyright:
+#
+# Debian GNU/Linux
+# Copyright 1996-1997 Guy Maor <maor@debian.org>
+#
+# Modified for Gentoo for use with the lilo ebuild by:
+# Martin Schlemmer <azarah@gentoo.org> (16 Mar 2003)
+#
+lilocheck () {
+ local bootpart=
+ local rootpart="$(rdev 2> /dev/null | cut -d ' ' -f 1 2> /dev/null)"
+
+ echo
+ einfon "Checking for LILO ..."
+
+ if [ "$(whoami)" != "root" ]
+ then
+ echo; echo
+ eerror "Only root can check for LILO!"
+ return 1
+ fi
+
+ if [ -z "${rootpart}" ]
+ then
+ echo; echo
+ eerror "Could not determine root partition!"
+ return 1
+ fi
+
+ if [ ! -f /etc/lilo.conf -o ! -x /sbin/lilo ]
+ then
+ echo " No"
+ return 1
+ fi
+
+ bootpart="$(perl -ne 'print $1 if /^\s*boot\s*=\s*(\S*)/' /etc/lilo.conf)"
+
+ if [ -z "${bootpart}" ]
+ then
+ # lilo defaults to current root when 'boot=' is not present
+ bootpart="${rootpart}"
+ fi
+
+ if ! dd if=${bootpart} ibs=16 count=1 2>&- | grep -q 'LILO'
+ then
+ echo; echo
+ ewarn "Yes, but I couldn't find a LILO signature on ${bootpart}"
+ ewarn "Check your /etc/lilo.conf, or run /sbin/lilo by hand."
+ return 1
+ fi
+
+ echo " Yes, on ${bootpart}"
+
+ return 0
+}
+
+
+pkg_postinst() {
+ if [ ! -e ${ROOT}/boot/boot.b -a ! -L ${ROOT}/boot/boot.b ]
+ then
+ ln -snf boot-menu.b ${ROOT}/boot/boot.b
+ fi
+
+ if [ "${ROOT}" = "/" ]
+ then
+ if lilocheck
+ then
+ einfo "Running LILO to complete the install ..."
+ /sbin/lilo &> /dev/null
+ if [ "$?" -ne 0 ]
+ then
+ echo
+ ewarn "Running /sbin/lilo failed! Please check what the problem is"
+ ewarn "before your next reboot."
+
+ echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
+ sleep 5
+ fi
+ fi
+ echo
+ fi
+}
+