summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2005-11-27 06:18:11 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2005-11-27 06:18:11 +0000
commit5ad393e37b410f625f2cc4c09de23050cb1fbaee (patch)
tree1c0dac9c237f5ad7cb87455c40ef448f36944115 /sys-apps
parentAdding Kernel Config check to resolve bug #112186 (diff)
downloadgentoo-2-5ad393e37b410f625f2cc4c09de23050cb1fbaee.tar.gz
gentoo-2-5ad393e37b410f625f2cc4c09de23050cb1fbaee.tar.bz2
gentoo-2-5ad393e37b410f625f2cc4c09de23050cb1fbaee.zip
Backporting changes to reported version
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hal/ChangeLog5
-rw-r--r--sys-apps/hal/Manifest2
-rw-r--r--sys-apps/hal/hal-0.5.4.ebuild16
3 files changed, 20 insertions, 3 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index 81103d67e2b6..a361574f086e 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.54 2005/11/27 06:10:37 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.55 2005/11/27 06:18:11 compnerd Exp $
+
+ 27 Nov 2005; Saleem Abdulrasool <compnerd@gentoo.org> hal-0.5.4.ebuild:
+ Backporting kernel check to origival reported version.
27 Nov 2005; Saleem Abdulrasool <compnerd@gentoo.org> hal-0.5.5.1.ebuild:
Adding check for CONFIG_KOBJECT_UEVENT to resolve Bug #112186. Thanks to
diff --git a/sys-apps/hal/Manifest b/sys-apps/hal/Manifest
index 1e9e0279e570..de575403e2d4 100644
--- a/sys-apps/hal/Manifest
+++ b/sys-apps/hal/Manifest
@@ -20,6 +20,6 @@ MD5 192112dfb678a9795a93d3cdcc50bb95 files/hald 543
MD5 2cf5b3c9219c87b1d9aee01f4f5f19bb hal-0.4.5-r2.ebuild 3118
MD5 1a146b79d18a689bbc8a96b81f74c7f6 hal-0.4.7-r2.ebuild 3455
MD5 8420501e80e55b313d30f4e0309c08dd hal-0.4.8.ebuild 3419
-MD5 4b5c3135d20b391903d7a8e2626313dd hal-0.5.4.ebuild 3443
+MD5 af4477ac4bb569982552130883d0c25b hal-0.5.4.ebuild 3778
MD5 c587e7d02a20b445d6b164a8c71fc1da hal-0.5.5.1.ebuild 3937
MD5 a60767d83157413d549c69b98fac962c metadata.xml 303
diff --git a/sys-apps/hal/hal-0.5.4.ebuild b/sys-apps/hal/hal-0.5.4.ebuild
index 690c31492fe1..ced07bc0ee37 100644
--- a/sys-apps/hal/hal-0.5.4.ebuild
+++ b/sys-apps/hal/hal-0.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.4.ebuild,v 1.5 2005/11/08 17:25:24 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.4.ebuild,v 1.6 2005/11/27 06:18:11 compnerd Exp $
inherit eutils linux-info
@@ -31,12 +31,26 @@ DEPEND="${RDEPEND}
## HAL Daemon drops privledges so we need group access to read disks
HALDAEMON_GROUPS="haldaemon,disk,cdrom,cdrw,floppy,usb"
+function notify_uevent() {
+ eerror
+ eerror "You must enable Kernel Userspace Events in your kernel."
+ eerror "This can be set under 'General Setup'. It is marked as"
+ eerror "CONFIG_KOBJECT_UEVENT in the config file."
+ eerror
+ ebeep 5
+
+ die "KOBJECT_UEVENT is not set"
+}
+
pkg_setup() {
linux-info_pkg_setup
kernel_is ge 2 6 10 \
|| die "You need a 2.6.10 or newer kernel to run this package"
+ linux_chkconfig_present KOBJECT_UEVENT \
+ || notify_uevent
+
if use pam_console && ! built_with_use sys-libs/pam pam_console ; then
eerror "You need to build pam with pam_console support"
eerror "Please remerge sys-libs/pam with USE=pam_console"