summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-04 06:42:49 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-04 06:42:49 +0000
commit45860c58ef378ae9c61da751e8cf3d470d6046ef (patch)
tree0ec94d62cd044b21296091ff39db89cd6cc90c4b /sys-apps
parentold (diff)
downloadgentoo-2-45860c58ef378ae9c61da751e8cf3d470d6046ef.tar.gz
gentoo-2-45860c58ef378ae9c61da751e8cf3d470d6046ef.tar.bz2
gentoo-2-45860c58ef378ae9c61da751e8cf3d470d6046ef.zip
Add a quick hack for building on hppa while we sort things out upstream #201114.
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/busybox/ChangeLog7
-rw-r--r--sys-apps/busybox/busybox-1.7.4.ebuild3
-rw-r--r--sys-apps/busybox/files/busybox-1.7.4-signal-hack.patch28
3 files changed, 36 insertions, 2 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index 51726077afc7..ee0a90252124 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/busybox
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.168 2007/12/03 17:02:43 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.169 2007/12/04 06:42:48 vapier Exp $
+
+ 04 Dec 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/busybox-1.7.4-signal-hack.patch, busybox-1.7.4.ebuild:
+ Add a quick hack for building on hppa while we sort things out upstream
+ #201114.
03 Dec 2007; Christoph Mende <angelos@gentoo.org> busybox-1.7.4.ebuild:
Stable on amd64 wrt bug #201036
diff --git a/sys-apps/busybox/busybox-1.7.4.ebuild b/sys-apps/busybox/busybox-1.7.4.ebuild
index 4ade07b129b9..c97bd0b08afa 100644
--- a/sys-apps/busybox/busybox-1.7.4.ebuild
+++ b/sys-apps/busybox/busybox-1.7.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.7.4.ebuild,v 1.2 2007/12/03 17:02:43 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.7.4.ebuild,v 1.3 2007/12/04 06:42:48 vapier Exp $
inherit eutils flag-o-matic savedconfig
@@ -87,6 +87,7 @@ src_unpack() {
# patches go here!
epatch "${FILESDIR}"/busybox-1.7.0-bb.patch
+ epatch "${FILESDIR}"/busybox-1.7.4-signal-hack.patch #201114
# work around broken ass powerpc compilers
use ppc64 && append-flags -mminimal-toc
diff --git a/sys-apps/busybox/files/busybox-1.7.4-signal-hack.patch b/sys-apps/busybox/files/busybox-1.7.4-signal-hack.patch
new file mode 100644
index 000000000000..ba1183055dd6
--- /dev/null
+++ b/sys-apps/busybox/files/busybox-1.7.4-signal-hack.patch
@@ -0,0 +1,28 @@
+workaround while we get it fixed upstream
+
+http://bugs.gentoo.org/201114
+
+--- libbb/u_signal_names.c
++++ libbb/u_signal_names.c
+@@ -66,7 +66,7 @@
+ #ifdef SIGTERM
+ [SIGTERM ] = "TERM",
+ #endif
+-#ifdef SIGSTKFLT
++#if defined(SIGSTKFLT) && SIGSTKFLT < 32
+ [SIGSTKFLT] = "STKFLT",
+ #endif
+ #ifdef SIGCHLD
+@@ -90,10 +90,10 @
+ #ifdef SIGURG
+ [SIGURG ] = "URG",
+ #endif
+-#ifdef SIGXCPU
++#if defined(SIGXCPU) && SIGXCPU < 32
+ [SIGXCPU ] = "XCPU",
+ #endif
+-#ifdef SIGXFSZ
++#if defined(SIGXFSZ) && SIGXFSZ < 32
+ [SIGXFSZ ] = "XFSZ",
+ #endif
+ #ifdef SIGVTALRM