summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-18 20:09:07 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-18 20:09:07 +0000
commit3bd5c5bc53b070b0694360e013061165f3a412d4 (patch)
treeca7c1ae25d41a28a429cbcf87729e9799def9499 /sys-apps
parentAdded new ebuild, see Bug 21378. (Manifest recommit) (diff)
downloadgentoo-2-3bd5c5bc53b070b0694360e013061165f3a412d4.tar.gz
gentoo-2-3bd5c5bc53b070b0694360e013061165f3a412d4.tar.bz2
gentoo-2-3bd5c5bc53b070b0694360e013061165f3a412d4.zip
lets get this crusty stuff moving along
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/fcron/fcron-2.0.0-r4.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/sys-apps/fcron/fcron-2.0.0-r4.ebuild b/sys-apps/fcron/fcron-2.0.0-r4.ebuild
index 41136b7e17db..415b22a40349 100644
--- a/sys-apps/fcron/fcron-2.0.0-r4.ebuild
+++ b/sys-apps/fcron/fcron-2.0.0-r4.ebuild
@@ -1,32 +1,30 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fcron/fcron-2.0.0-r4.ebuild,v 1.2 2004/04/10 02:50:55 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fcron/fcron-2.0.0-r4.ebuild,v 1.3 2004/04/18 20:09:07 vapier Exp $
inherit eutils
-IUSE=""
-
-S=${WORKDIR}/${P}
DESCRIPTION="A command scheduler with extended capabilities over cron and anacron"
HOMEPAGE="http://fcron.free.fr/"
SRC_URI="http://fcron.free.fr/${P}.src.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~hppa mips"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips hppa amd64"
+IUSE=""
DEPEND="virtual/editor"
RDEPEND="!virtual/cron
- >=sys-apps/cronbase-0.2.1-r3
- virtual/mta"
+ >=sys-apps/cronbase-0.2.1-r3
+ virtual/mta"
PROVIDE="virtual/cron"
src_unpack() {
- unpack ${A} ; cd ${S}
+ unpack ${A}
+ cd ${S}
epatch ${FILESDIR}/${P}-gentoo.diff
# fix LIBOBJS vs AC_LIBOBJ problem
- mv configure.in configure.in~
- sed <configure.in~ >configure.in -e 's|LIBOBJS|AC_LIBOBJ|g'
+ sed -i -e 's|LIBOBJS|AC_LIBOBJ|g' configure.in
autoconf || die "autoconf problem"
}
@@ -39,7 +37,8 @@ src_compile() {
--with-spooldir=/var/spool/cron \
--with-sendmail=/usr/sbin/sendmail \
--with-editor="${EDITOR}" \
- --with-cflags="${CFLAGS}" || die "bad ./configure"
+ --with-cflags="${CFLAGS}" \
+ || die "bad ./configure"
emake || die "compile problem"
}
@@ -55,7 +54,7 @@ src_install() {
doman doc/*.{1,3,5,8}
- dodoc MANIFEST VERSION doc/{CHANGES,README,LICENSE,FAQ,INSTALL,THANKS}
+ dodoc MANIFEST VERSION doc/{CHANGES,README,FAQ,INSTALL,THANKS}
newdoc ${FILESDIR}/fcron.conf fcron.conf.sample
docinto html ; dohtml doc/*.html
dodoc ${FILESDIR}/crontab