summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-04 02:08:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-04 02:08:39 +0000
commit37790cd741b06102e9118176a4b5647cd56cc85a (patch)
tree657ade413954639cb6c635780880cc295ccea889 /sys-apps
parentBumped phonon-vlc to the 0.3.1 release. (diff)
downloadgentoo-2-37790cd741b06102e9118176a4b5647cd56cc85a.tar.gz
gentoo-2-37790cd741b06102e9118176a4b5647cd56cc85a.tar.bz2
gentoo-2-37790cd741b06102e9118176a4b5647cd56cc85a.zip
Version bump; since upstream is working around init script craziness over Ubuntu and other binary distributions, we apply our own workaround by running pcscd as nobody:pcscd and hotplug it via udev. This version also drops HAL support entirely.
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pcsc-lite/ChangeLog11
-rw-r--r--sys-apps/pcsc-lite/files/99-pcscd-hotplug.rules8
-rw-r--r--sys-apps/pcsc-lite/files/pcscd-init.333
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.6.5.ebuild74
4 files changed, 125 insertions, 1 deletions
diff --git a/sys-apps/pcsc-lite/ChangeLog b/sys-apps/pcsc-lite/ChangeLog
index 7ceb52ebe017..6fecf8105769 100644
--- a/sys-apps/pcsc-lite/ChangeLog
+++ b/sys-apps/pcsc-lite/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-apps/pcsc-lite
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.91 2010/10/24 20:43:57 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.92 2010/12/04 02:08:39 flameeyes Exp $
+
+*pcsc-lite-1.6.5 (04 Dec 2010)
+
+ 04 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/99-pcscd-hotplug.rules, +pcsc-lite-1.6.5.ebuild, +files/pcscd-init.3:
+ Version bump; since upstream is working around init script craziness over
+ Ubuntu and other binary distributions, we apply our own workaround by running
+ pcscd as nobody:pcscd and hotplug it via udev. This version also drops HAL
+ support entirely.
24 Oct 2010; Dane Smith <c1pher@gentoo.org> pcsc-lite-1.5.5.ebuild,
pcsc-lite-1.6.1.ebuild:
diff --git a/sys-apps/pcsc-lite/files/99-pcscd-hotplug.rules b/sys-apps/pcsc-lite/files/99-pcscd-hotplug.rules
new file mode 100644
index 000000000000..83a1a28c6270
--- /dev/null
+++ b/sys-apps/pcsc-lite/files/99-pcscd-hotplug.rules
@@ -0,0 +1,8 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/files/99-pcscd-hotplug.rules,v 1.1 2010/12/04 02:08:39 flameeyes Exp $
+
+# We add this here so that it runs after ccid's and ifd-gempc's rules;
+# if we just added a pcscd-owned device, we hotplug the pcscd service.
+ACTION=="add", GROUP=="pcscd", RUN+="/bin/env IN_HOTPLUG=1 /etc/init.d/pcscd --quiet start"
diff --git a/sys-apps/pcsc-lite/files/pcscd-init.3 b/sys-apps/pcsc-lite/files/pcscd-init.3
new file mode 100644
index 000000000000..7d872ccef416
--- /dev/null
+++ b/sys-apps/pcsc-lite/files/pcscd-init.3
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/files/pcscd-init.3,v 1.1 2010/12/04 02:08:39 flameeyes Exp $
+
+depend() {
+ need localmount
+}
+
+start() {
+ if ! [ -d /var/run/pcscd ]; then
+ mkdir -p /var/run/pcscd
+ fi
+
+ chgrp pcscd /var/run/pcscd
+ chmod 0775 /var/run/pcscd
+
+ ebegin "Starting pcscd"
+ start-stop-daemon --start \
+ --exec /usr/sbin/pcscd \
+ --pidfile /var/run/pcscd/pcscd.pid \
+ --chuid nobody:pcscd \
+ -- ${EXTRA_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping pcscd"
+ start-stop-daemon --stop \
+ --exec /usr/sbin/pcscd \
+ --pidfile /var/run/pcscd/pcscd.pid
+ eend $?
+}
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.6.5.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.6.5.ebuild
new file mode 100644
index 000000000000..f9e4c6f3d4ea
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.6.5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.6.5.ebuild,v 1.1 2010/12/04 02:08:39 flameeyes Exp $
+
+EAPI="3"
+
+inherit multilib eutils
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://pcsclite.alioth.debian.org/"
+
+STUPID_NUM="3473"
+MY_P="${PN}-${PV/_/-}"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="usb kernel_linux"
+
+RDEPEND="usb? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${RDEPEND}
+ kernel_linux? ( sys-fs/udev )"
+
+pkg_setup() {
+ enewgroup pcscd
+}
+
+src_configure() {
+ econf \
+ --disable-maintainer-mode \
+ --disable-dependency-tracking \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-usbdropdir="/usr/$(get_libdir)/readers/usb" \
+ $(use_enable usb libusb) \
+ --disable-libhal
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS DRIVERS HELP README SECURITY ChangeLog || die
+
+ newinitd "${FILESDIR}/pcscd-init.3" pcscd || die
+
+ if use kernel_linux; then
+ insinto /lib/udev/rules.d
+ doins "${FILESDIR}"/99-pcscd-hotplug.rules || die
+ fi
+}
+
+pkg_postinst() {
+ elog "Starting from version 1.6.5, pcsc-lite will start as user nobody in"
+ elog "the pcscd group, to avoid running as root."
+ elog ""
+ elog "This also means you need the newest drivers available so that the"
+ elog "devices get the proper owner."
+ elog ""
+ elog "Furthermore, a conf.d file is no longer installed by default, as"
+ elog "the default configuration does not require one. If you need to"
+ elog "pass further options to pcscd, create a file and set the"
+ elog "EXTRA_OPTS variable."
+ elog ""
+ if use kernel_linux; then
+ elog "HAL support has been dropped by the ebuild; if you want hotplug"
+ elog "support, that's provided already by UDEV rules; you only need to"
+ elog "tell the init system to hotplug it, by setting this variable in"
+ elog "/etc/rc.conf:"
+ elog ""
+ elog " rc_hotplug=\"pcscd\""
+ fi
+}