summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-09-28 23:37:16 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-09-28 23:37:16 +0000
commit1630c4a4067c5801dd30dfe773ac2ee4a1a24972 (patch)
tree4be71729f1bfb2cdbd7c5e196d60c6c89774de06 /sys-apps
parentMarking rr-0.10.11 ~ppc for bug 322053 (diff)
downloadgentoo-2-1630c4a4067c5801dd30dfe773ac2ee4a1a24972.tar.gz
gentoo-2-1630c4a4067c5801dd30dfe773ac2ee4a1a24972.tar.bz2
gentoo-2-1630c4a4067c5801dd30dfe773ac2ee4a1a24972.zip
Version bump; the new version has an improved init script that takes less time to start (no process creation for depend calculation), and properly uses s-s-d to respect system limits; also upstream moved to libusb-1 rather than the previous libusb-0.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pcsc-lite/ChangeLog11
-rw-r--r--sys-apps/pcsc-lite/files/pcscd-init.229
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.6.4.ebuild73
3 files changed, 112 insertions, 1 deletions
diff --git a/sys-apps/pcsc-lite/ChangeLog b/sys-apps/pcsc-lite/ChangeLog
index 0cc37f8ea867..e3adf061e99d 100644
--- a/sys-apps/pcsc-lite/ChangeLog
+++ b/sys-apps/pcsc-lite/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-apps/pcsc-lite
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.86 2010/09/05 15:54:53 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.87 2010/09/28 23:37:15 flameeyes Exp $
+
+*pcsc-lite-1.6.4 (28 Sep 2010)
+
+ 28 Sep 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +pcsc-lite-1.6.4.ebuild, +files/pcscd-init.2:
+ Version bump; the new version has an improved init script that takes less
+ time to start (no process creation for depend calculation), and properly
+ uses s-s-d to respect system limits; also upstream moved to libusb-1
+ rather than the previous libusb-0.
05 Sep 2010; Raúl Porcel <armin76@gentoo.org> pcsc-lite-1.6.1.ebuild:
ia64/m68k/s390/sh/sparc stable wrt #330601
diff --git a/sys-apps/pcsc-lite/files/pcscd-init.2 b/sys-apps/pcsc-lite/files/pcscd-init.2
new file mode 100644
index 000000000000..58d4a1969347
--- /dev/null
+++ b/sys-apps/pcsc-lite/files/pcscd-init.2
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/files/pcscd-init.2,v 1.1 2010/09/28 23:37:16 flameeyes Exp $
+
+depend() {
+ # ensure there is at least one dependency or if the following
+ # is removed we're stuck with a broken init
+ need localmount
+
+ need hald
+}
+
+start() {
+ ebegin "Starting pcscd"
+ start-stop-daemon --start \
+ --exec /usr/sbin/pcscd \
+ --pidfile /var/run/pcscd/pcscd.pid \
+ -- ${PCSCD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping pcscd"
+ start-stop-daemon --stop \
+ --exec /usr/sbin/pcscd \
+ --pidfile /var/run/pcscd/pcscd.pid
+ eend $?
+}
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.6.4.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.6.4.ebuild
new file mode 100644
index 000000000000..18bcf817315b
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.6.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.6.4.ebuild,v 1.1 2010/09/28 23:37:15 flameeyes Exp $
+
+EAPI="3"
+
+inherit multilib
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://pcsclite.alioth.debian.org/"
+
+if [[ "${PV}" = "9999" ]]; then
+ inherit autotools subversion
+ ESVN_REPO_URI="svn://svn.debian.org/pcsclite/trunk"
+ S="${WORKDIR}/trunk"
+else
+ STUPID_NUM="3337"
+ MY_P="${PN}-${PV/_/-}"
+ SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="hal static usb"
+
+RDEPEND="usb? ( virtual/libusb:1 )
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if use hal && use usb; then
+ ewarn "The usb and hal USE flags cannot be enabled at the same time"
+ ewarn "Disabling the effect of USE=usb"
+ fi
+}
+
+if [[ "${PV}" == "9999" ]]; then
+ src_prepare() {
+ S="${WORKDIR}/trunk/PCSC"
+ cd "${S}"
+ AT_M4DIR="m4" eautoreconf
+ }
+fi
+
+src_configure() {
+ local myconf
+ if use hal; then
+ myconf="--enable-libhal --disable-libusb"
+ else
+ myconf="--disable-libhal $(use_enable usb libusb)"
+ fi
+
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-usbdropdir="/usr/$(get_libdir)/readers/usb" \
+ ${myconf} \
+ $(use_enable static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS DRIVERS HELP README SECURITY ChangeLog || die
+
+ newinitd "${FILESDIR}/pcscd-init.2" pcscd || die
+ newconfd "${FILESDIR}/pcscd-confd" pcscd || die
+
+ if ! use hal; then
+ sed -i -e '/need hald/d' "${D}"/etc/init.d/pcscd || die
+ fi
+}