summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-07-06 09:56:12 +0000
committerRoy Marples <uberlord@gentoo.org>2007-07-06 09:56:12 +0000
commit10b19a585d05149ea3d362052cf17adecb6fa965 (patch)
tree17d59741cbae77499211de3054d15c06b5350993 /sys-apps
parentKeyworded x86-fbsd (diff)
downloadgentoo-2-10b19a585d05149ea3d362052cf17adecb6fa965.tar.gz
gentoo-2-10b19a585d05149ea3d362052cf17adecb6fa965.tar.bz2
gentoo-2-10b19a585d05149ea3d362052cf17adecb6fa965.zip
Only include alloca.h for gcc on glibc sytsems, #183295 thanks to Nathan Smith.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pciutils/ChangeLog6
-rw-r--r--sys-apps/pciutils/files/pciutils-2.2.6-alloca.patch13
-rw-r--r--sys-apps/pciutils/pciutils-2.2.6-r1.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index f941d7cb83fb..18a2c79ffd3c 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/pciutils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.108 2007/07/06 05:09:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.109 2007/07/06 09:56:12 uberlord Exp $
+
+ 06 Jul 2007; Roy Marples <uberlord@gentoo.org>
+ +files/pciutils-2.2.6-alloca.patch, pciutils-2.2.6-r1.ebuild:
+ Only include alloca.h for gcc on glibc sytsems, #183295 thanks to Nathan Smith.
*pciutils-2.2.6-r1 (06 Jul 2007)
diff --git a/sys-apps/pciutils/files/pciutils-2.2.6-alloca.patch b/sys-apps/pciutils/files/pciutils-2.2.6-alloca.patch
new file mode 100644
index 000000000000..78ef4b9c1835
--- /dev/null
+++ b/sys-apps/pciutils/files/pciutils-2.2.6-alloca.patch
@@ -0,0 +1,13 @@
+diff -ur a/lspci.c b/lspci.c
+--- a/lspci.c 2007-03-30 10:56:35 +0100
++++ b/lspci.c 2007-07-06 10:31:54 +0100
+@@ -60,7 +60,9 @@
+ */
+
+ #ifdef __GNUC__
++#ifdef __GLIBC__
+ #include <alloca.h>
++#endif
+ #else
+ #undef alloca
+ #define alloca xmalloc
diff --git a/sys-apps/pciutils/pciutils-2.2.6-r1.ebuild b/sys-apps/pciutils/pciutils-2.2.6-r1.ebuild
index 6eee4b3af765..b7b2552d8908 100644
--- a/sys-apps/pciutils/pciutils-2.2.6-r1.ebuild
+++ b/sys-apps/pciutils/pciutils-2.2.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.6-r1.ebuild,v 1.1 2007/07/06 05:09:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.6-r1.ebuild,v 1.2 2007/07/06 09:56:12 uberlord Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -22,6 +22,7 @@ src_unpack() {
epatch "${FILESDIR}"/pcimodules-${PN}-2.2.6.patch
epatch "${FILESDIR}"/${PN}-2.2.6-link.patch #160421
epatch "${FILESDIR}"/${PN}-2.2.4-update-pciids.patch
+ epatch "${FILESDIR}"/${PN}-2.2.6-alloca.patch
sed -i "/^LIBDIR=/s:/lib:/$(get_libdir):" Makefile
}