summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-14 03:17:38 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-14 03:17:38 +0000
commit41a9ddec1bf83ccfdedab96fdb552277db2eda23 (patch)
treeccaf3a3065ff77df079b063faf091ffeec4a989d /sys-apps/util-linux
parentVersion bump. (diff)
downloadgentoo-2-41a9ddec1bf83ccfdedab96fdb552277db2eda23.tar.gz
gentoo-2-41a9ddec1bf83ccfdedab96fdb552277db2eda23.tar.bz2
gentoo-2-41a9ddec1bf83ccfdedab96fdb552277db2eda23.zip
Fix by Derick Swanepoel to have umount respect -n when using -r #98675.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog7
-rw-r--r--sys-apps/util-linux/files/util-linux-2.12q-umount-dont-write-mtab-with-remount.patch18
-rw-r--r--sys-apps/util-linux/util-linux-2.12q-r2.ebuild5
3 files changed, 28 insertions, 2 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index af5b78990b4e..965ee6569e8a 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.110 2005/09/13 23:56:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.111 2005/09/14 03:17:38 vapier Exp $
+
+ 14 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/util-linux-2.12q-umount-dont-write-mtab-with-remount.patch,
+ util-linux-2.12q-r2.ebuild:
+ Fix by Derick Swanepoel to have umount respect -n when using -r #98675.
13 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+files/util-linux-2.12-only-root-can-remount.patch,
diff --git a/sys-apps/util-linux/files/util-linux-2.12q-umount-dont-write-mtab-with-remount.patch b/sys-apps/util-linux/files/util-linux-2.12q-umount-dont-write-mtab-with-remount.patch
new file mode 100644
index 000000000000..2b8f4ad36c3f
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.12q-umount-dont-write-mtab-with-remount.patch
@@ -0,0 +1,18 @@
+Make umount respect the -n option when using -r
+
+Patch by Derick Swanepoel
+
+http://bugs.gentoo.org/98675
+
+--- mount/umount.c
++++ mount/umount.c
+@@ -349,7 +349,8 @@
+ remnt.mnt_type = remnt.mnt_fsname = NULL;
+ remnt.mnt_dir = xstrdup(node);
+ remnt.mnt_opts = xstrdup("ro");
+- update_mtab(node, &remnt);
++ if (!nomtab && mtab_is_writable())
++ update_mtab(node, &remnt);
+ return 0;
+ } else if (errno != EBUSY) { /* hmm ... */
+ perror("remount");
diff --git a/sys-apps/util-linux/util-linux-2.12q-r2.ebuild b/sys-apps/util-linux/util-linux-2.12q-r2.ebuild
index ea006f95b880..8a540f925655 100644
--- a/sys-apps/util-linux/util-linux-2.12q-r2.ebuild
+++ b/sys-apps/util-linux/util-linux-2.12q-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12q-r2.ebuild,v 1.2 2005/09/13 23:56:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12q-r2.ebuild,v 1.3 2005/09/14 03:17:38 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -62,6 +62,9 @@ src_unpack() {
# Disable the -r option for non-root users #105805
epatch "${FILESDIR}"/${PN}-2.12-only-root-can-remount.patch
+ # Respect -n with -r and umount #98675
+ epatch "${FILESDIR}"/${PN}-2.12q-umount-dont-write-mtab-with-remount.patch
+
# Fix unreadable df output when using devfs ... this check is kind of
# a hack, but whatever, the output isnt critical at all :P
[[ -e /dev/.devfsd ]] && epatch "${FILESDIR}"/no-symlink-resolve.patch